CPS Crank Position Sensor failing? - Page 5 - JeepForum.com
Reply
 
LinkBack Thread Tools
post #61 of 63 Old 10-11-2015, 04:33 PM
lekrolak
Registered User
1999 XJ Cherokee 
 
Join Date: Oct 2015
Location: Jacksonville
Posts: 1
Xj CPS Sensor

I had the similar starting issues. Then I changed out the CPS with one from NAPA. One week later the jeep would crank, start and run for 2-3 seconds and die. Checked fuel, and wire connections. Then I got desperate. I wiped off the original CPS sensor that I didn't throw away and installed. Runs great now. FYI only buy Mopar/Jeep sensors! Others don't seem to have good quality control and fail.

lekrolak is offline  
Sponsored Links
Advertisement
 
post #62 of 63 Old 01-24-2016, 08:52 PM
Hacker777
Registered User
 
Join Date: Jan 2016
Posts: 2
Solved!! (I know this is an old thread but the following might be helpful)

4.0L Jeep

Had the same problems (CPS and CPK Codes) rough idle or no start. Read posts, here and other forums. Was going to re-replace (distributor style) Cam Position sensor but decided to grab hold of the tone spinny thingy that the sensor senses. (Don’t do this while it’s spinning). I thought to myself “Hmmm that’s odd…. this spinny thing rotates freely. This is supposed to be, directly, geared to the oil pump / crankshaft” I then decided to pull it out….”Clink clank clunk” The small gear that was on the Cam position sensor shaft dropped into the oil pan.

The spring pin that holds the gear to the Cam position sensor shaft had sheared off. Once I got the gear out of the oil pan and replaced the whole assembly the engine worked fine.

The intermittent nature was due to friction between the shaft and gear that allowed the shaft to spin and give an intermittent signal to the CPS.

Hope this helps.
Hacker777 is offline  
post #63 of 63 Old 07-01-2016, 05:07 PM
lirum
Registered User
 
Join Date: Jul 2016
Posts: 1
Working on my brother's 1990XJ.

I believe my Crank Position Sensor or Cam Shaft Sensor is faulty. Bought and replaced the CPS (I believe I did that properly) with a NAPA part, but the jeep still will not start. I want to confirm that the new CPS is indeed faulty.

Here is CJ7-Tim's comprehensive list of symptoms and ones that I am specifically seeing.

Symptoms-
- Starter cranks and cranks but engine won't start up [Correct.]
- Fuel gauge and voltage gauges may not work or display properly. [Fuel gauge does not move when key turned to on with either CPS connected or disconnected / Voltage moves to ~11 when key turned on with both CPS connected and disconnected]
- You sometimes will have No Bus on the odometer after 30-60 seconds. [Not seen]
- A failed CPS/CKP may or may not throw a CEL trouble code. [CEL = Check Engine Light, yes? I have seen the car running and it does not show after 60 seconds of key in on position.]
- No spark at the spark plugs. [Correct.]
- Fuel pump should run and prime for 3-5 seconds. [I believe so. I hear something move in the engine after key position turned to on, and smell gas if key is turned on and off 4-6 times.]

This fills enough of the conditions for me to think it's the CPS. But I replaced that... so, I want to verify the replacement CPS is good or bad before I move on to replacing the Cam Shaft Sensor.

Following CJ7-Tim's diagnostic steps, I get hung up on

"Exchange the fuel pump relay and the ASD relay with one of the other similar ones in the PDC to eliminate the relays as the cause of the no-start..."

I found the relays, but I'm fuzzy on the specifics of swapping them with "similar ones". Does this mean I unplug the ASD relay and swap it with... what? My options are AUX FAN, FUEL PUMP, ABS PUMP (which is missing), A/C, STARTER, ABS SYSTEM (missing). Can I swap the ASD (Auto ShutDown, yes?) with any of these others to test the ASD and then Fuel Pump?

Thank you in advance for the questions. I'll be back with more later.
lirum is offline  
Reply

Tags
cps , cranking not starting , crankshsft position , No bus , no start , no-bus

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Crank position sensor 97jeepgcl XJ Cherokee Technical Forum 6 12-19-2009 11:34 AM
crank position sensor dancinbills XJ Cherokee Technical Forum 1 11-05-2009 05:57 AM
Crank Position Sensor, Which One? DesertOne XJ Cherokee Technical Forum 9 03-29-2009 09:04 PM
XJ Crank position sensor....help me please craigincali XJ Cherokee Technical Forum 2 05-18-2007 10:09 PM
How do you get a crank position sensor out? Matt Gertsch XJ Cherokee Technical Forum 6 03-31-2005 10:19 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome