CCV hose goes where? - JeepForum.com
 
LinkBack Thread Tools
post #1 of 9 Old 06-01-2016, 09:47 PM Thread Starter
Ryan_Colorado
Registered User
 
Join Date: Mar 2016
Location: Loveland
Posts: 98
CCV hose goes where?

Ok, I'll hopefully name all these right. The air inlet hose attached to the front PCV elbow is presently just dangling down unattached. It was this way when I bought it. Where is it supposed to be connected to? There appears to be a taped-off inlet in the back of the airbox. Is that where this hose is supposed to go?

The grommets and elbows (front and back) appear to be leaking. There's also oil in the airbox that I know fixing has been covered elsewhere on here. Figuring out this hose is step one.

Thanks!

Ryan_Colorado is offline  
Sponsored Links
Advertisement
 
post #2 of 9 Old 06-01-2016, 10:18 PM
ou2mame
Registered User
 
Join Date: Mar 2004
Location: long island, ny
Posts: 685
What year?

Sent from my HTC M9 using Tapatalk
ou2mame is offline  
post #3 of 9 Old 06-01-2016, 10:35 PM
shooptube
Big Brother
 
shooptube's Avatar
1997 XJ Cherokee 
 
Join Date: May 2013
Location: Southgate
Posts: 4,077
Garage

Quote:
Originally Posted by Luke95 View Post
I am Moar low.
Build Thread:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


Instagram:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
shooptube is offline  
 
post #4 of 9 Old 06-02-2016, 08:51 AM
axlaxl
Registered User
2000 XJ Cherokee 
 
Join Date: May 2014
Location: Brooklyn
Posts: 451
Check out this pic and the thread below for info on the 4.0 PCV/CCV. Should answer most if not all of your questions. Make sure you have the proper elbows for the front and rear as they have different flow rates.

https://www.jeepforum.com/forum/f11/c...-flow-2829394/
Attached Images
 
axlaxl is offline  
post #5 of 9 Old 06-03-2016, 11:42 AM Thread Starter
Ryan_Colorado
Registered User
 
Join Date: Mar 2016
Location: Loveland
Posts: 98
Mine is a '90. I'll check if there's a inlet on the box in that spot. I think the one in back that's covered in tape is on the lower portion of the box (below the air filter)? This diagram appears to connect above it. Hmm. I'll get back to you. Thanks!
Ryan_Colorado is offline  
post #6 of 9 Old 06-05-2016, 02:23 PM
cruiser54
Web Wheeler
 
cruiser54's Avatar
1990 MJ Comanche 
 
Join Date: Oct 2009
Location: Prescott
Posts: 12,285
Here:
Attached Images
 

If you own a Renix Jeep, you must check this out:


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


My Jeep technical photos:


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
cruiser54 is offline  
post #7 of 9 Old 06-05-2016, 02:24 PM
cruiser54
Web Wheeler
 
cruiser54's Avatar
1990 MJ Comanche 
 
Join Date: Oct 2009
Location: Prescott
Posts: 12,285
This could be helpful also:

http://cruiser54.com/?p=121

If you own a Renix Jeep, you must check this out:


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


My Jeep technical photos:


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
cruiser54 is offline  
post #8 of 9 Old 06-06-2016, 01:13 PM Thread Starter
Ryan_Colorado
Registered User
 
Join Date: Mar 2016
Location: Loveland
Posts: 98
Hey, that's really helpful, thanks! I see it is supposed to go to the inlet in the back of the box. Any idea why it might be disconnected?

This guy made some changes. Something with the coolant lines also that I'll take a pic of sometime.
Ryan_Colorado is offline  
post #9 of 9 Old 06-06-2016, 02:09 PM
cruiser54
Web Wheeler
 
cruiser54's Avatar
1990 MJ Comanche 
 
Join Date: Oct 2009
Location: Prescott
Posts: 12,285
Who knows. Maybe too cheap to replace them?

Let's see photos of the coolant lines.

If you own a Renix Jeep, you must check this out:


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


My Jeep technical photos:


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
cruiser54 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome