JeepForum.com

JeepForum.com (https://www.jeepforum.com/forum/)
-   XJ Cherokee Technical Forum (https://www.jeepforum.com/forum/f11/)
-   -   Blew a head (https://www.jeepforum.com/forum/f11/blew-head-4360283/)

Enuminada 06-18-2019 11:14 PM

Blew a head
 
Thats were it started, im encountering a 9v batt gauge, after having replaced the head, and gasket and such. New belt is squealing loud. voltage wasnt dropping before the rebuild, so it dies after running for a bit. new plugs installed and got its timing in place via bringing cylinder one tdc, and aligning the roller cap. unsure about the belt being the culprit as i have it rather tight, just needing guidance as i bought this off of a friend knowing i could fix. its been a roller coaster. hoping i just need to tighten the tensioner more, but its holding a charge problem is weird... 99 xj.

S8NNG8 06-19-2019 07:09 AM

My ZJ 4.0 was recently having voltage issues. Tightened the belt till the squeal stopped and no more problem.

Enuminada 06-19-2019 05:44 PM

That fixed the voltage error but now it stalls out and the code p1391 is thrown and dies when put into gear... the crank position sensor is new so im back on the coster, while idling its does well but still does bog out.

S8NNG8 06-19-2019 09:06 PM

Don't doubt the possibility of parts being bad right out of the box. These days it should be the first thing to suspect.


The time now is 12:05 AM.

Powered by vBulletin Version 3.8.8
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.

User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.