AC issue- compressor not engaging - Page 5 - JeepForum.com
 1Likes
Reply
 
LinkBack Thread Tools
post #61 of 71 Old 08-30-2010, 03:41 PM
phmaris
Registered User
1999 XJ Cherokee 
 
Join Date: Oct 2008
Location: Harrison
Posts: 385
Mine is doing the exact same thing! Only thing is, now I have no cold air coming out anymore.

I think my freon has leaked out somewhere since having it refilled. Probably the dreaded evaporator!! I have read somewhere that when it cycles a lot it is because the freon is low.

phmaris is offline  
Sponsored Links
Advertisement
 
post #62 of 71 Old 08-30-2010, 08:16 PM
john NC
Registered User
 
john NC's Avatar
2000 XJ Cherokee 
 
Join Date: Apr 2007
Location: Corolla
Posts: 1,417
Quote:
Originally Posted by dagr8tim View Post
My 97 XJ did the same thing, and stopped after a top off of freon.
gave it maybe 10 seconds worth of freon and it's now running like a champ

i have some pictures of my own i'll post when i get them off my camera

really easy job, took MAYBE half an hour
john NC is offline  
post #63 of 71 Old 09-02-2010, 04:37 PM
tommy69z
Registered User
 
Join Date: Sep 2010
Location: Muscle Shoals
Posts: 1
I just LOVE the internet and google....I had done decided the clutch was weak and anew or used compressor was the fix...Thanks guys!!!!
tommy69z is offline  
 
post #64 of 71 Old 09-08-2010, 03:56 PM
john NC
Registered User
 
john NC's Avatar
2000 XJ Cherokee 
 
Join Date: Apr 2007
Location: Corolla
Posts: 1,417
ehhhh definitely a leak somewhere. compressor cycling again. i'm gonna have to have a shop test for leaks and evacuate it and refill the system. i'm not putting any more r134 in there, especially since i know the compressor's not shot
john NC is offline  
post #65 of 71 Old 09-08-2010, 06:54 PM
dagr8tim
Web Wheeler
 
dagr8tim's Avatar
1997 XJ Cherokee 
 
Join Date: May 2008
Location: Galloway
Posts: 3,165
Garage
Quote:
Originally Posted by john NC View Post
ehhhh definitely a leak somewhere. compressor cycling again. i'm gonna have to have a shop test for leaks and evacuate it and refill the system. i'm not putting any more r134 in there, especially since i know the compressor's not shot
If the compressor's good and there of the system is shot. Me thinks this is a good time for OBA.

Jeeping - The art of getting dirty & going broke while slowly heading nowhere, and taking all day to do it.

97 XJ SE - The War Wagon
98 TJ SE - Mall Crawler/Light Trail Rig
06 KJ Sport - Basic Transportation
dagr8tim is offline  
post #66 of 71 Old 09-10-2010, 01:21 PM
john NC
Registered User
 
john NC's Avatar
2000 XJ Cherokee 
 
Join Date: Apr 2007
Location: Corolla
Posts: 1,417
i would except i'm building/repairing this xj for my dad and he says he's "too old not to have ac" lol
john NC is offline  
post #67 of 71 Old 08-19-2011, 06:56 AM
kevhenn
Registered User
 
Join Date: Jul 2010
Location: bluffton sc
Posts: 2
I just took apart as you said and I only find one shim? Could the other two have been removed or buried in the Plate? I guess put it back with no shims?
kevhenn is offline  
post #68 of 71 Old 07-20-2014, 04:40 PM
gomezgee
Registered User
2001 WJ 
 
Join Date: Jan 2014
Posts: 12
sorry to reopen quite an old thread but I have searched high and low and cant seem to find the answers I need, so I hope someone can help!

I have a 2001 Grand Cherokee Laredo 4.0, a/c stopped blowing cold the other day, now only blows warm to hot air, bought a can of AC Pro refrigerant thinking that may be the issue, its one that says it stops leaks and has a gauge as well.

Following the directions on the can I checked the system through the low pressure port, while car was on and a/c was on full blast cold setting, pressure was low and I noticed that the compressor was not engaging, as I started filling the system up to the maximum point as guided by the gauge settings, the compressor now engages however it is not on constantly, it starts and stops spinning consistently though, is that normal, or should it be spinning the whole time while the a/c is on?
gomezgee is offline  
post #69 of 71 Old 07-31-2014, 03:47 PM
Double E
Web Wheeler
 
Double E's Avatar
2004 WJ 
 
Join Date: Oct 2003
Location: Raleigh, NC
Posts: 6,313
A bump for you gomez... who has the best knowledge on this?

'04 Freedom Edition HO & '04 Overland HO (previous '00 Laredo 4.7)
Double E is offline  
post #70 of 71 Old 07-31-2014, 08:15 PM
AZ Jeff
Web Wheeler
2014 JK Wrangler 
 
Join Date: Sep 2005
Location: San Tan Valley Arizona
Posts: 7,698
Compressors can and will cycle depending on charge level, outside air temp, and cabin temp.

AZ-Jeff
I don't own an XJ any longer, but I still think they are the best of all the Jeep products ever made. My XJ was my favorite vehicle in my 50+ years of driving.
So...I stick around and give advice.
AZ Jeff is offline  
post #71 of 71 Old 02-24-2015, 07:50 PM
Emz
Registered User
 
Join Date: Feb 2015
Location: Philadelphia
Posts: 1
Hey all;;

I recently noticed that my serpentine belt is just slipping over my compressor pulley. It's not seized as I can spin it with my hand it just is not engaging.

Am I really messing up my serpentine belt this way? How dangerous is this?

It's winter so I haven't used and won't need the a/c for a few more months so it's not an immediate concern of mine unless it's unsafe or damaging my belt.

I should be able to drive it down to my buddy's place and have him look at it soon but-- is it ok to drive it like this? Everything else is in working order and the engine temp is regular even at a steady 80mph... unless my temp gauge is broken haha.

Thanks for the help I know I'm receiving this topic from the dead probably.
Emz is offline  
Reply

Tags
air conditioning , compressor , ac , engage

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
A/C compressor not engaging? No voltage? nrpalmer32 XJ Cherokee Technical Forum 8 06-10-2010 02:08 PM
Air Conditioner compressor not engaging xeroOTG XJ Cherokee Technical Forum 2 04-03-2010 06:28 PM
AC compressor not engaging/fan not running dz1087 XJ Cherokee Technical Forum 6 07-20-2009 02:19 PM
AC compressor not engaging Powellae XJ Cherokee Technical Forum 5 05-05-2009 04:20 PM
Ac compressor not engaging Rollin XJ Cherokee Technical Forum 5 08-01-2008 04:57 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome