95 XJ - Messed with distributor, now won't start - JeepForum.com
 
LinkBack Thread Tools
post #1 of 3 Old 05-21-2012, 06:07 AM Thread Starter
mbardeen
Registered User
1995 XJ Cherokee 
 
Join Date: Sep 2011
Location: Talca
Posts: 80
95 XJ - Messed with distributor, now won't start

I've been having some problems with one cylinder misfiring. In the hunt for the cause, I thought I'd check the timing. So I pulled the distributor, dialed the engine into what I thought was TDC, put it all back together and cranked the engine a few times. No start.

So I pulled it apart again and realized that I had aligned the distributor wrong (using the 4cyl hole) and didn't even have TDC (looking at the wrong marks)

I've now corrected both issues, made sure that I had the TDC on the compression stroke but the Jeep still won't start. The best it does is kind of a "puh puh puh" once in a while.

I thought it was possible I flooded the engine, and when I pulled the plugs they were rather wet. However, trying to start it with my foot to the floor and leaving it overnight both resulted in failure.


It's got new plugs, new wires, new fuel & filter, and just replaced the injector O-rings day before yesterday.

What am I missing?

mbardeen is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 05-21-2012, 11:10 AM
buildin1XJ
Registered User
1999 XJ Cherokee 
 
Join Date: Oct 2011
Location: Knoxville
Posts: 1,589
Tdc ?

Are you sure that you are at TDC on the compression stroke? What method are you using to locate TDC? Also you can not adjust timing removing or rotating the distributor. Also did you index the cam position sensor with the distributor? Yhere is a 3/16 hole in the CPS that you need to align it with analignment hole in the distributor.
buildin1XJ is offline  
post #3 of 3 Old 05-21-2012, 12:27 PM Thread Starter
mbardeen
Registered User
1995 XJ Cherokee 
 
Join Date: Sep 2011
Location: Talca
Posts: 80
Nevermind... The cause was that I'm an idiot. I had it timed to TDC on the wrong stroke. Rotated the crank another turn, reinstalled the distributor correctly, and voila! All is well -- except for the misfire.. but that's for another thread.
mbardeen is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
4.0 - Noise from distributor on start-up?? TSTTZ32 XJ Cherokee Technical Forum 11 02-19-2014 07:02 PM
Hard to start and strange Distributor placement ckollenb XJ Cherokee Technical Forum 1 03-19-2012 02:25 PM
OK I think I might have messed up supernas XJ Cherokee Technical Forum 2 12-22-2011 03:40 PM
tried to start my jeep twice with the distributor unplugged....ooops RamboPants XJ Cherokee Technical Forum 10 03-18-2010 06:27 PM
New distributor, now won't even start jon88654 XJ Cherokee Technical Forum 2 07-25-2005 11:59 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome