90 XJ Wagoneer Ltd. stock alternator amperage? - JeepForum.com
 
LinkBack Thread Tools
post #1 of 2 Old 05-12-2015, 10:27 AM Thread Starter
seasoned_geek
Registered User
2002 WJ 
 
Join Date: Oct 2014
Location: Herscher
Posts: 35
90 XJ Wagoneer Ltd. stock alternator amperage?

I know one of you can confirm this from top of head so asking here.

Was the stock alternator for a 90 XJ Wagoneer Ltd. really only 60 Amp?

My recent mods to the cooling system have presented a minor problem. When raining (lights on wipers intermittent) with A/C on, fan set low to medium, I see my dash gauge pull down into the red. I know, they aren't accurate, best viewed as "adding to battery" or "draining battery." As a general rule though, they can be trusted when they say "draining battery" or at least should be listened to.

I _suspect_ the old factory circuit for the electric cooling fan was either trimming the voltage or fluctuating it based on temperature. The aftermarket one put on the hot side of the radiator just runs the fan flat out while temperature is within the set range. I know this because I can hear the fan way more than I did before. The fan is the same so...

The "red neck" solution would be to turn up the idle speed because once you start moving we are "back in black." I would rather fix the real problem though. I have heard the horror stories about these alternators, but, I have to say, I bought this Jeep off eBay back in 2004 and have never put an alternator in it. Engine yes, alternator no.

60 AMP would explain things.

30 AMP for cooling fan
12-15 AMP for engine
10-15 AMP for blower motor (notorious power sucking things)

Obviously not putting out peak juice at idle and needing 50+ AMP.

I did find a supposed 140 AMP upgrade alternator for this:

http://store.alternatorparts.com/cs1...lternator.aspx

But I'm thinking the sub $100 Autozone 100 AMP special will solve the woes.

Can anyone confirm 60 AMP really was "factory stock"?

seasoned_geek is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 05-12-2015, 07:38 PM
sAe23
Registered User
1995 XJ Cherokee 
 
Join Date: Apr 2009
Location: Los Angeles / SFV
Posts: 3,364
It APPEARS, according to all Google search results, that 60 amps was probably stock for the 1990 Wagoneer.
What *I* would do before changing the alternator is clean all the connections and/or upgrade the wires to 4AWG (or bigger?).
You probably have corroded cable ends and dirty ground connections.
But yeah, get a 100 amp alt.
sAe23 is offline  
Reply

Tags
90 , alternator , renix , stock amperage

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome