1994 XJ turn signals and side marker not working - JeepForum.com
 
LinkBack Thread Tools
post #1 of 2 Old 06-25-2019, 09:54 PM Thread Starter
Alex45506
Registered User
 
Join Date: May 2019
Posts: 4
1994 XJ turn signals and side marker not working

Hey guys! Here’s the scoop. 1994 XJ and I’m trying to trouble shoot the first steps in diagnosing the problem. The front turn signals do not work also. Checks the bulbs there not blown and also check the fuses. Headlights work, brake taillights work and hazards work all the way around. Would check grounds but don’t know where they are. Thanks for the help!

Alex45506 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 06-27-2019, 11:36 PM
S8NNG8
Registered User
 
S8NNG8's Avatar
1995 XJ Cherokee 
 
Join Date: Feb 2012
Location: Helena
Posts: 10,224
Two things I'd check:
In the drivers side rear quarter panel you'll have to pull the plastic piece thats behind your spare tire. There is wiring for the taillights loosely draped through there and they lose connection.
Or
Under your steering wheel is a white box box that kinda looks like a circuit breaker. This is the tranfer unit for the turn signals and it loses circuits, randomly in my experience.

D3<!L!>3D
S8NNG8 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome