Water and Electronics do not mix.... - JeepForum.com

 
LinkBack Thread Tools
post #1 of 3 Old 08-05-2008, 08:46 PM Thread Starter
Jeepster55
Registered User
 
Join Date: May 2007
Location: Indianapolis
Posts: 446
Water and Electronics do not mix....

has anyone had issues with all the 'idiot lights' flashing after driving through puddles of water?

this has happened to me twice. the first time about 3 months ago or so when we had a lot of flooding and i drove my Compass through water that was up past the bottom of the doors. the tailpipe was submerged to give you an idea how deep the water was. after about 30 minutes of driving, the passenger restraint light, air bags, turn signals, etc....all started flashing and chimes, chiming. drove me nuts. drove it to work immediately and showed the SA what it was doing. later, when the tech finally got to check it, NO FAULT FOUND of course. not even a 'code'. if the SA hadn't witnessed it, i'm sure they would have thought i had 'smoked' my lunch or something.

so, today it's raining and i drove through a few puddles. PUDDLES! no flooding. but again, the same scenario. that was this AM on the way into work. when i went to lunch, no problem.

any ideas? anyone else have this issue that was FIXED? just curious what if i can give our service dept any more info when i go in for my appointment on Friday.

oh, BTW, on our 'trek' through the "Badlands" in Attica Indiana a week or so ago, went through all sorts of HIGH WATER and NOT ONCE did this happen.....WTF?

Jeepster55 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 08-05-2008, 09:31 PM
Coasty161
Registered User
2008 JK Wrangler 
 
Join Date: Oct 2006
Location: Port Huron, MI
Posts: 393
been seeing any lil gremlins nawing on the wires? lol
Coasty161 is offline  
post #3 of 3 Old 08-06-2008, 12:52 PM
merlinTec
Registered User
 
merlinTec's Avatar
 
Join Date: Jul 2007
Location: England
Posts: 2,944
Hi
Had a similar case and are bring back bad memories for me. My one had all the dash shutting down just for a second or 2 then coming back on with all the warning lights and chimes with no faults codes. Finally got it to do it with star scan plugged in the TIPM was saying the ignition was being turn off so sending everything to sleep. It wasn’t water related so hope it’s not the same. Did the speedo all still work?

UK Chrysler Jeep Master Tec.
merlinTec is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Rear Dome Water Leak, Chryler But Back Jeepva Jeep Compass & Patriot Forum 3 05-03-2016 12:45 PM
Rear Dome Light Leaking Water - 07 Compass vegaelite Jeep Compass & Patriot Forum 4 12-19-2013 08:58 PM
Water "fording" polished_heckle Jeep Compass & Patriot Forum 11 07-11-2009 10:01 AM
Water leaking in my '07 Patriot? websurrfr Jeep Compass & Patriot Forum 6 02-20-2009 04:29 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome