turn signal blinks faster than the other with headlights on - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Compass & Patriot Forum > turn signal blinks faster than the other with headlights on

FS: 2007-2013 Jeep Wrangler "HALO" Angel Eye KitTHE NEW! VANCO DUAL MODE 15”/16″ Big Brake Kit w/BlaFS: Wranger BRIGHT License Plate LED! Just $3! Great value

Reply
Unread 11-11-2009, 04:47 PM   #1
VolunTold
Registered User
2009 MK Patriot 
 
Join Date: Nov 2009
Location: San Marcos, CA
Posts: 1
turn signal blinks faster than the other with headlights on

my 2009 patriot right turn signal blinks faster than the left only with the headlights on. blinks normal with headlights off. the car is brand new with only 4000 miles on it

VolunTold is offline   Reply With Quote
Unread 11-11-2009, 05:32 PM   #2
ArloGuthroJeep
Mr. Hyde!
 
ArloGuthroJeep's Avatar
2004 WJ 
 
Join Date: Mar 2005
Location: Boulder, CO
Posts: 23,079
VolunTold - I moved your post here from the Grand Cherokee forum to the Patriot Forum
__________________
'04 WJ, 6" Clayton LA's, 242 SYE, 35" BFG MT KM2's, 4.56 gears, & D44a locked
'14 WK2 Limited w/5.7L, ORAI, & Tow Package
ArloGuthroJeep is offline   Reply With Quote
Unread 11-13-2009, 04:03 AM   #3
Gramps
The Necessary Evil
 
Gramps's Avatar
2007 MK Compass 
 
Join Date: Aug 2006
Location: Madison/Janesville, Wisconsin
Posts: 5,623
I can't come up with a good answer for this other than "it's electrical", duh. Maybe your blinker fluid is low?

I could suggest re-seating all of your fuses - easy; and re-seating the connectors in the TIPM - a real PITA, and seeing what happens.

How fast is fast? 2x?
__________________
Bob

Artificial intelligence is no substitute for natural stupidity

MK Skid Plate fasteners for sale posts 68 & 69

Also visit me at Photobucket
'06 WK Grand Cherokee Limited Quadra-Drive II, 5.7
'07 MK Compass Limited 4X4, AutoStick
Gramps is offline   Reply With Quote
Unread 11-16-2009, 09:14 AM   #4
PurpleHayes
Registered User
2008 MK Compass 
 
Join Date: Nov 2009
Location: Pennsylvania
Posts: 12
Actually sounds like a grounding problem. I once had something similar going on along with several other electrical symptoms with an old Chevy Astro I had. It took the mechanic about 15 minutes to find it and no parts charge!
PurpleHayes is offline   Reply With Quote
Unread 11-16-2009, 09:15 AM   #5
PurpleHayes
Registered User
2008 MK Compass 
 
Join Date: Nov 2009
Location: Pennsylvania
Posts: 12
Ha! Blinker fluid...I'll be using that one. :-)
PurpleHayes is offline   Reply With Quote
Unread 11-16-2009, 04:10 PM   #6
Gramps
The Necessary Evil
 
Gramps's Avatar
2007 MK Compass 
 
Join Date: Aug 2006
Location: Madison/Janesville, Wisconsin
Posts: 5,623
True. I had a rusty socket that caused problems too. It's not an uncommon problem with boat trailers either. Not that you should be seeing much rust on a newer vehicle but it's all part of the ground that completes the circuit.
__________________
Bob

Artificial intelligence is no substitute for natural stupidity

MK Skid Plate fasteners for sale posts 68 & 69

Also visit me at Photobucket
'06 WK Grand Cherokee Limited Quadra-Drive II, 5.7
'07 MK Compass Limited 4X4, AutoStick
Gramps is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.