JeepForum.com

JeepForum.com (http://www.jeepforum.com/forum/)
-   Compass & Patriot Forum (http://www.jeepforum.com/forum/f98/)
-   -   transmission trouble (http://www.jeepforum.com/forum/f98/transmission-trouble-1544809/)

Mike199674 07-04-2013 09:22 AM

transmission trouble
 
Hi, new to forum. Been having trouble with cvt transmission, 61000 miles. It's jerking when I accelerate and is very annoying and frustrating... I've heard many solutions and I've heard it's normal so i don't know what to think... It's not overheating....low tranny fluid?? Computer module?? Any help would be appreciated!!

FujativeOCR 07-04-2013 10:52 AM

Theres been a software update out for a couple years, didn't help mine. And I think 60k is where the manual first suggests replacing cvt fluid. Other than that, sounds like normal cvt behavior to me.

aroundincircles 07-04-2013 11:19 AM

How long have you owned it? Is this new behavior?

NHPATRIOT 07-04-2013 01:20 PM

Jerking is not normal. My CVT is actually very smooth between gears and under acceleration. Have the fluid level checked for proper level( no dipstick - requires special tool )and to see if it is burned. The transmission is most likely due for service anyway with that mileage despite Chrysler saying the CVT fluid is 100K+ capable( BULL! ).

Make sure if you have a trans service done the correct fluid is used. ONLY use a CVTF+4 fluid( Nissan has one that is the same thing too ). The CVT uses a very special fluid so don't use regular MOPAR ATF+4 or other brands of regular trans fluid in it.

Mike199674 07-04-2013 03:08 PM

Ok thanks a lot!! I scheduled an appointment for tomorrow... Thanks for the advice


The time now is 12:27 AM.

Powered by vBulletin Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.