Temparature Display - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Compass & Patriot Forum > Temparature Display

New jk doors from steinjagerEliminate Hood Flutter!!!FS: Wrangler RGB Multicolor Fog Light LEDs: Awesome Effect

Reply
Unread 08-11-2012, 04:09 PM   #1
FujativeOCR
Registered User
2011 MK Patriot 
 
Join Date: Aug 2011
Location: Newfoundland, Center of the Universe
Posts: 878
Temparature Display

So....now that I've disconnected the battery for a couple hours to try and reprogram the computer to get better fuel economy, now my Temp Display on EVIC is reading about 10 degrees too low. For the first couple starts it only went up to 88 when it was actually 106 outside. Then on one start it went up to 98, and stayed there for a few more starts. It's currently 108 degrees outside and the car still shows 98.

Is this normal after a battery disconnect? Does it take time to calibrate somehow?

FujativeOCR is offline   Reply With Quote
Unread 08-11-2012, 05:06 PM   #2
FujativeOCR
Registered User
2011 MK Patriot 
 
Join Date: Aug 2011
Location: Newfoundland, Center of the Universe
Posts: 878
Disregard. I figured it out. I found via a Jeep Cherokee complaint somewhere, that that car had to be driven something like 25mph for over 3 minutes for the temp to update. So I drove down to the freeway, and sure enough after at least 1-2 minutes up to speed, it updated accurately. Guess they shut off while idling or going slow? Which makes sense. Sensor is up near the grill so probably gets all hot while idling.
FujativeOCR is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.