Shifting issue - Page 2 - JeepForum.com

Reply
 
LinkBack Thread Tools
post #16 of 18 Old 11-08-2011, 10:52 AM
FujativeOCR
Registered User
2011 MK Patriot 
 
Join Date: Aug 2011
Location: Newfoundland
Posts: 884
Yeah mine is definately 2,800 rpm at 65 and about 3,300 at 75. Is there something wrong with it?

FujativeOCR is offline  
Sponsored Links
Advertisement
 
post #17 of 18 Old 11-08-2011, 02:17 PM
WingedScapula
Registered User
2009 MK Compass 
 
Join Date: Oct 2011
Location: Pittsburgh
Posts: 62
I guess it's possible. What year is your Compass? Maybe they tweaked the CVT. Are the roads you're driving on flat? Is your engine 2.0 L or 2.4 L?

Edit: based on your other posts, I guess you're using a Patriot, not a Compass. I'm not sure if that should make a difference; based on what I can see, both vehicles are roughly the same weight (kind of surprising)...
WingedScapula is offline  
post #18 of 18 Old 11-09-2011, 06:54 AM
FujativeOCR
Registered User
2011 MK Patriot 
 
Join Date: Aug 2011
Location: Newfoundland
Posts: 884
Its a 2011 Latitude, 2.4 w/CVT. Driving in Central California, so flat.
FujativeOCR is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
clutch issue, no pressure ukjeepcompass Jeep Compass & Patriot Forum 0 06-13-2011 09:15 AM
Will backspacing solve the issue? tjwrangler99 Jeep Compass & Patriot Forum 3 01-22-2011 08:49 AM
Is there a way to turn off the fake "shifting" on the CVT? Dacaur Jeep Compass & Patriot Forum 2 01-19-2011 09:00 AM
Another acceleration issue... Elihawk Jeep Compass & Patriot Forum 9 06-10-2008 04:34 AM
Patriot Hood Issue Silkk19 Jeep Compass & Patriot Forum 6 03-01-2008 07:04 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome