No park lights / dash lights - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Compass & Patriot Forum > No park lights / dash lights

Rough Country Lift Kits and Parts!Ruffstuff Axle Simple Swap Kit!Don't forget the Jeep Forum discount, 10% off!

Reply
Unread 09-07-2013, 06:03 PM   #1
Oisact
Registered User
 
Join Date: Sep 2013
Location: Somewhere, Va
Posts: 2
No park lights / dash lights

Just bought a used 2007 Compass, and already have a potentially major problem. The park lights and dash lights (gauges, radio, heat controls) will not come on. The headlights work, as do the turn signals and backup lights. All bulbs are good. I replaced both brake / park light bulbs, and the front turn signals flash as they should.

I pulled and tested every single fuse and they are all good.

I don't think it's the switch itself because the headlights will come on. I couldn't find any other reports of a Compass with this problem after extensive searching.

No tow package or trailer wiring at all, so the problem wasn't caused by anything external.

Had diagnostic codes read just in case and nothing shows.

Any suggestions?

Oisact is offline   Reply With Quote
Unread 09-08-2013, 12:54 AM   #2
FujativeOCR
Registered User
2011 MK Patriot 
 
Join Date: Aug 2011
Location: Newfoundland, Center of the Universe
Posts: 878
Illumination wire maybe? If it ever had an aftermarket stereo in it, there would have been an illumination wire spliced into so the stereo knew when the headlights were on. Maybe somebody didnt hook it back up when the stereo was replaced back to factory?

Just a thought.
FujativeOCR is offline   Reply With Quote
Unread 09-09-2013, 04:45 PM   #3
Oisact
Registered User
 
Join Date: Sep 2013
Location: Somewhere, Va
Posts: 2
Here's an update in case anyone else has this problem. We took it to Advance Auto to have the diagnostic codes read, and their basic scanner would not report TIPM codes. So today we took it to a proper garage and they showed dozens of TIPM error codes, and in the process of trying to make sense of them they cleared the codes to see which would come back up. All the lights started working properly at that time. We had already disconnected the battery for several minutes to try and reset the TIPM but that apparently did not work.

So here's my theory on why this problem happened in the first place. The people we bought the car from seemed to be pretty bad about replacing blown bulbs. Both rear park lights, right rear brake, and front left fog light were all bad. I believe that both rear park lights burnt out at the same time caused too high of a resistance or too low of a current flow that caused the TIPM to go into a safe mode for that circuit. From what I could tell the only way to reset is have the codes read with a scanner.

Moral of the story is don't let a bunch of bulbs burn out at the same time. The problem could still be some other intermittent short (bare wire grounding out on occasion or something), but only time will tell. We've only had the car for a few days.
Oisact is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.