No bus???? - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Compass & Patriot Forum > No bus????

The Original 3/8" Ruffstuff Diff Cover!Safety Thimble FairleadsEngo winches available at www.rockridge4wd.com! Free shipp

Reply
Unread 05-15-2008, 06:02 PM   #1
gerty920
Registered User
2007 MK Compass 
 
Join Date: Feb 2008
Location: Canada
Posts: 9
No bus????

A few days ago the "check engine light" came on as I started my Compass to head home after work. on my arrival back home I went through the user's manual and this indicated the "check engine light" no major problem unless it was flashing. The user manual states further that if the light does not go out after a few driving cycles to then have the vehicle seen to.

The light went off yesterday so I assumed no big problems. Yeah right.

This afternoon the wife went to fetch our daughter at school. When she tried to start the Compass nothing happened and a "no bus" message appeared on trip/odometer. Nothing worked, not even the emergency indicators or the windows.

I contacted Jeep and they arranged to have the towed but shortly after I arrived to wait for the tow truck the emergency indicators started flashing and the "no bus" message disappeared but the "check engine light" is back.

I know most modern cars use CAN bus to send message and signals around the vehicle so I assume that the "no bus" indicates a problem with the CAN communications system.

I will have the vehicle at the dealer tomorrow as had an appointment to have the "check engine light" seen to.

My question is after this long story, has anybody had this problem before? Was it major time and money to have fixed? The Compass has 18000km on the clock and is not even a year old? Should I be worried?



gerty920 is offline   Reply With Quote Quick reply to this message
Unread 05-15-2008, 06:22 PM   #2
Shirai_Ryu
Registered User
 
Join Date: May 2008
Location: Jeep Service
Posts: 94
"no bus" usually indicates a loss of communication between the various modules (computers) on the car. Im not to saavy with the metric stystem, but I do believe that 18,000km puts you well within the Warranty terms, so whatever it is should be covered.

My guess would be the T.I.P.M (Totally Integrated Power Module), but the dealership will need to do some diagnostics to determine the failure.
Shirai_Ryu is offline   Reply With Quote Quick reply to this message
Unread 05-15-2008, 06:39 PM   #3
gerty920
Registered User
2007 MK Compass 
 
Join Date: Feb 2008
Location: Canada
Posts: 9
thanks for the info shirai.

something interesting about all of this, the first time the "check engine light appeared the Compass had been standing outside in the sun the whole day and it had been the warmest day of the season so far.

Today was again a pretty warm day and again the problem surfaced. maybe the temperature has something to do with it.....?
gerty920 is offline   Reply With Quote Quick reply to this message
Unread 05-15-2008, 07:42 PM   #4
Gramps
The Necessary Evil
 
Gramps's Avatar
2007 MK Compass 
 
Join Date: Aug 2006
Location: Madison/Janesville, Wisconsin
Posts: 5,623
Yes, just a bit over 11000 miles, the warranty will cover it. I did have my engine light come on at about the same mileage as you. Checked the gas cap several times, looked everything over really well, couldn't find anything so I took it to the dealer. They wanted to replace the intake manifold saying that maybe the bracket that held the throttle cable on was broken. They ordered in the intake, I drove my Compass home and took a look at it and there wasn't any sign of anything broken. I filled up the next day and the light went out and never came back on. I think that it may have been bad fuel, possibly water in the tank. I called the dealer back and told them that I wasn't going to need the work done. Your dealer should be able to read the codes.

It may be related to this TSB:
Intermittent Op. Of Elec. Components Due To Ignition IOD Fuse Not Seated

or

No Engine Crank Or No Engine Start Due To Elect. Lockup Of WCM / SKREEM

I had a friend at a car show that had is hood up and the sun beating down on his electronic control module caused a no start condition but with the hood closed on yours it shouldn't be that kind of problem. Also the under hood temps get pretty high just under normal driving conditions.
__________________
Bob

Artificial intelligence is no substitute for natural stupidity

MK Skid Plate fasteners for sale posts 68 & 69

Also visit me at Photobucket
'06 WK Grand Cherokee Limited Quadra-Drive II, 5.7
'07 MK Compass Limited 4X4, AutoStick
Gramps is offline   Reply With Quote Quick reply to this message
Unread 05-23-2008, 08:55 AM   #5
gerty920
Registered User
2007 MK Compass 
 
Join Date: Feb 2008
Location: Canada
Posts: 9
Some feedback on my problem. took the Compass in last week and the dealer did some diagnostics. Of course the problem could not be duplicated, Seems the "check engine" light was due to a problem with the TIPM. Dealer ordered a new one and was installed today under warranty.

Hopefully that was the only problem, let's see what happens!
gerty920 is offline   Reply With Quote Quick reply to this message
Unread 05-23-2008, 09:22 AM   #6
Gramps
The Necessary Evil
 
Gramps's Avatar
2007 MK Compass 
 
Join Date: Aug 2006
Location: Madison/Janesville, Wisconsin
Posts: 5,623
Thanks for the feedback! The wife's '03 Grand Check Engine light just came on 2 days ago. I pulled up a P0456 code so I'm trying to track down an Evaporate Emissions leak. It may be covered under her extended warranty.
__________________
Bob

Artificial intelligence is no substitute for natural stupidity

MK Skid Plate fasteners for sale posts 68 & 69

Also visit me at Photobucket
'06 WK Grand Cherokee Limited Quadra-Drive II, 5.7
'07 MK Compass Limited 4X4, AutoStick
Gramps is offline   Reply With Quote Quick reply to this message
Unread 05-23-2008, 11:46 AM   #7
jbjeepguy
Registered User
2007 MK Compass 
 
Join Date: Oct 2007
Location: West Coast
Posts: 92
Quote:
Originally Posted by Gramps View Post
.. so I'm trying to track down an Evaporate Emissions leak. It may be covered under her extended warranty.
Or the Federal Emissions warranty.
__________________
I bike therefore I work.

07 Compass, FDI, CVT
jbjeepguy is offline   Reply With Quote Quick reply to this message
Unread 10-05-2008, 10:28 AM   #8
VTEK1
Registered User
1999 XJ Cherokee 
 
Join Date: Sep 2008
Location: Worcester, Massachusetts
Posts: 635
no bus on my 99 XJ (cherokee) mine won't shift outta 1st gear unless I manually shift it and I don't have a tach or speedo at the moment. good luck I think I'm going to send mine to dealership and finally give up. I've been working on it for a month.
VTEK1 is offline   Reply With Quote Quick reply to this message
Unread 10-13-2008, 01:01 AM   #9
patrick3319
Registered User
2008 MK Compass 
 
Join Date: Feb 2008
Location: Hamilton ON
Posts: 96
tonight I filled up with gas...started the car...EVERY light on my dash was lit up, lights were on even tho I hadn't turned them to be on (have hids and fogs)....so shouldn't be on till I turn it...than I drove a bit shut it off and tried to restart...NOTHING...called some friends, (since I had no tools) undid the battery for 5-10 mins and put it back on everything was fine...had check engine light of course...and now its gone, so no way to figure out wtf happened!....:S....OI!
patrick3319 is offline   Reply With Quote Quick reply to this message
Unread 10-13-2009, 04:40 PM   #10
Mistyfate
Registered User
 
Join Date: Sep 2006
Location: New Jersey
Posts: 31
So my Compass just seemed to up and die on me the other day. I took it to the dealer and they said it is the TIPM and that I need a new one.

Is this a normal thing to "go" on cars? I feel like even though I've had the car since 07 that I've had a bunch of issues with it. The computer has been flashed on more than one occasion, the car has experienced some weird electrical bugs--the computer seemed to be shifting imporperly, various lights lit up on the dash, to the check engine light coming on.

This is the first BIG issue since my car has been out from under warrantee. I'm starting to wonder if it is even worth it at this point.

Has anyone else had issues with the TIPM?
Mistyfate is offline   Reply With Quote Quick reply to this message
Unread 01-26-2013, 01:27 PM   #11
Zero16hurley
Registered User
 
Join Date: Jan 2013
Location: Kenosha, Wi
Posts: 1
No bus...

My 2012 patriot reads no bus. 10k miles. I had a horrible grinding/rattling of metal noise coming from the steering column at highway speeds only. Could not recreate the noise at the shop. Pretty much was told to deal with it. I readjusted the steering wheel and the noise stopped. The next day my wipers and turn signals turned on by themselves and would stick randomly. A month later my vehicle won't start and read no bus. Since it's under a year I have 24hr assistance. It's at the dealership. Hopefully they can give me an answer. I've had nothing but problems. Struts and mounting were replaced at 1,800 miles. Shocks are next. Driver side door doesn't fully close and rattles. If this many things can go wrong in the first 10kmiles I can only imagine what I will be be forced to deal with in the future.
Zero16hurley is offline   Reply With Quote Quick reply to this message
Unread 01-27-2013, 09:58 AM   #12
Gramps
The Necessary Evil
 
Gramps's Avatar
2007 MK Compass 
 
Join Date: Aug 2006
Location: Madison/Janesville, Wisconsin
Posts: 5,623
Those are quite a few early problems. I hope the dealer takes care of them!
__________________
Bob

Artificial intelligence is no substitute for natural stupidity

MK Skid Plate fasteners for sale posts 68 & 69

Also visit me at Photobucket
'06 WK Grand Cherokee Limited Quadra-Drive II, 5.7
'07 MK Compass Limited 4X4, AutoStick
Gramps is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.