new patriot owner - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Compass & Patriot Forum > new patriot owner

Rugged Ridge Modular XHD Snorkel Now for both 3.8L and 3.6RIGID LED Light Blowout Sale - All Sizes, All Series, all Introducing MONSTALINER™ UV Permanent DIY Roll On Bed Line

Reply
Unread 01-01-2013, 09:23 AM   #1
lanark
Registered User
2005 TJ Wrangler 
 
Join Date: Jan 2010
Location: columbus ga
Posts: 43
new patriot owner

just bought daughter a 2011 patriot was just wondering how well everyone likes them ? Also are there anythings that we should be aware of, like up keep or problems to look for? thanks oh by the way son has a tj 2005.

lanark is offline   Reply With Quote Quick reply to this message
Unread 01-01-2013, 01:22 PM   #2
FujativeOCR
Registered User
2011 MK Patriot 
 
Join Date: Aug 2011
Location: Newfoundland, Center of the Universe
Posts: 878
The suspension parts wear out prematurely. Like 35k. Watch for tie rod ends and lower control arm bushings. Rotate tires on time probly helps.

Cvt is love it or hate it. I'm the latter.
FujativeOCR is offline   Reply With Quote Quick reply to this message
Unread 01-01-2013, 04:32 PM   #3
pitrcer3
Registered User
2011 MK Patriot 
 
Join Date: Aug 2011
Location: Harrisburg, PA
Posts: 31
Are they replacing those parts under warranty do you know? I have a 2011 model with 39k on it right now and havent really noticed too many issues just yet but there are some creaks here and there when turning. I would agree with you the CVT is love it or hate it. The gas mileage is nice for sure but I know I'll never buy a CVT again I am beginning to tire of it quickly.
pitrcer3 is offline   Reply With Quote Quick reply to this message
Unread 01-01-2013, 08:27 PM   #4
FujativeOCR
Registered User
2011 MK Patriot 
 
Join Date: Aug 2011
Location: Newfoundland, Center of the Universe
Posts: 878
Mine has 15,000. Ive hated the cvt and its gas
Mileage the whole time. 16 mpg city doesnt cut it.
FujativeOCR is offline   Reply With Quote Quick reply to this message
Unread 01-02-2013, 05:29 AM   #5
Wmillonig
Registered User
2012 MK Compass 
 
Join Date: May 2012
Location: Arlington, Va
Posts: 45
Been very happy with my Compass so far. Does your PAT have DRL's? Biggest safety issue I've seen is that you forget to turn them on at night b/c the headlights are pretty bright in DRL mode. If not, the only other safety concern is the visibility. You can lose pedestrians (or even a car) behind the rather thick A Pillar if you don't clear an intersection well. Make sure your daughter pays careful attention approaching intersections and she should be fine. Since you're not driving it, you probably aren't worried about the CVT performance but IMO it's fine. It's not the most responsive and it doesn't help the noise when mated to the 2.4L, but I actually like it on the highway...with such a small engine, you don't feel constantly downshifting when it hits a hill.
Wmillonig is offline   Reply With Quote Quick reply to this message
Unread 01-02-2013, 09:13 AM   #6
lanark
Registered User
2005 TJ Wrangler 
 
Join Date: Jan 2010
Location: columbus ga
Posts: 43
thanks for the responses the car has 30000 miles on it and the dealer supposedly did a 125 piont inspection on it but who knows. I ll have to keep a eye out for the front end. The little I drove it the cvt didnt seem all that bad it was however a little lacken in power for me. Any body hear of problems with them cutting off while driving, did a search and found some article on a possible recall for that. thanks again for the replies!
lanark is offline   Reply With Quote Quick reply to this message
Unread 01-02-2013, 11:43 AM   #7
pitrcer3
Registered User
2011 MK Patriot 
 
Join Date: Aug 2011
Location: Harrisburg, PA
Posts: 31
I have had an issue with my CVT on multiple occasions where I would be driving and the CVT completely cuts out and I have no power, it simply would rev up the tachometer as if it had slipped into a false neutral. I luckily was able to safely pull off the road each time and put it in park and then back into Drive and it was find. It's happened about 3-5 times in the year and a half i've had the vehicle. I have taken to the dealer where I purchased the vehicle and they flashed and updated the TCM and it was good for awhile and happened twice since that point over the summer of 2012.
pitrcer3 is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.