New and need major help - JeepForum.com

 
LinkBack Thread Tools
post #1 of 3 Old 04-03-2012, 11:06 PM Thread Starter
mjp121212
Registered User
2007 MK Compass 
 
Join Date: Apr 2012
Location: Huntington
Posts: 1
New and need major help

Hey everyone! I'm new and my 2007 Jeep Compass is my first Jeep. I love it dearly. It's a Jeep Limited 4x4. I hadn't had any problems, other than a pcm update. Last oil change they even commented on how clean the oil was and how it looked as if it hadn't even been ran through the engine. A few weeks ago I began to have a pretty bad vibration in the front of the car. Alignment is good, tires are new and great, I figured it had to be maybe a belt in the tire or thrown off balance when I hit a pot hole. 4 nights ago we heard a whiney/wheezy sound. Both issues happen when the car warms up, about 10mins after starting and upon hitting 50-55ish. This sound remained even when the car was in park if the accelerator was depressed. It was time for another oil change anyway so I had the guys there take a listen and they heard it missing and some knocking as well. When they went to work on the oil the oil was low, very low, by about 2qts (It had just been checked a few days before) and there are no leaks at all. The oil was black and there are metal shavings in it as well. I NEVER had a check engine light register, or any light for that matter!

mjp121212 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 04-05-2012, 09:05 AM
Gramps
The Necessary Evil
 
Gramps's Avatar
2007 MK Compass 
 
Join Date: Aug 2006
Location: Madison/Janesville
Posts: 5,623
Could the whiny/wheezing sound be coming from a the belt or pulley?

Did the put the right amount of oil in it on the previous change?

Bob

Artificial intelligence is no substitute for natural stupidity

MK Skid Plate fasteners for sale posts 68 & 69

Also visit me at Photobucket
'06 WK Grand Cherokee Limited Quadra-Drive II, 5.7
'07 MK Compass Limited 4X4, AutoStick
Gramps is offline  
post #3 of 3 Old 04-05-2012, 10:00 AM
Busmaster2
Registered User
 
Join Date: Nov 2011
Posts: 83
I would think from the remark about the oil looking like it hadn't been used I'd that it never had! That there was something keeping it from flowing through the engine, thus explaining the metal filings when the oil did finally flow. In short, I hope you have a warranty on the car as I think you'll be needing a new engine.
Busmaster2 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
UK Patriot Overland and Major Facelift spencernj Jeep Compass & Patriot Forum 0 07-06-2010 04:18 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome