Knocking sound in the undercarriage [solved] - JeepForum.com
 
LinkBack Thread Tools
post #1 of 5 Old 01-26-2009, 02:11 AM Thread Starter
Tony1911
Registered User
2007 MK Patriot 
 
Join Date: Nov 2007
Location: Helsinki
Posts: 266
Knocking sound in the undercarriage [solved]

Just a heads up to people in case this helps someone in the future:

I've been dealing with a metallic, knocking sound that sounded like it came from under the vehicle for some time now. This sound happened when driving over something in a manner which lifts or lowers one wheel on an axle first (like driving over a hole in the ground, over a speed bump / similar diagonally).

Sound started out very intermittent. It became more frequent when temperatures dropped to around -10C, but at this point it was still temperature related. Dealership was unable to locate fault. In the end, the sound became constant when driving over any kind of uneven terrain. At this point, dealership was able to find the fault: a broken "dog's bone" (not sure if that is anywhere near the proper English term) - that is, the part that connects to the anti-roll bar.

(I do hope my description of the problem and its solution are clear - I seem to be having trouble expressing my thoughts clearly this morning, especially in English.)

Tony1911 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 01-26-2009, 09:05 AM
flipperCompass
Registered User
2008 MK Compass 
 
Join Date: Jul 2008
Location: Montreal
Posts: 23
Does it sound like it's coming from the back? When it's cold (-15 C) and I'm driving on uneven road or over ice bumps or holes, I can hear a strange metallic knocking sound, like if it was coming from the liftgate, inside the plastic panel. I could never figure-out what it is. I guess it could be coming from under the Jeep.

Anyone else with this problem?

Thanks.

FliPPeR
---------------------
2008 Jeep Compass
North Edition 4x4 5spd
Bright Silver PS2

Last edited by flipperCompass; 01-26-2009 at 09:23 AM.
flipperCompass is offline  
post #3 of 5 Old 01-26-2009, 11:48 AM
Knightfallzx2
Registered User
2008 MK Compass 
 
Join Date: Feb 2008
Location: Winnipeg, MB, Canada
Posts: 227
Yeah, it's pretty loud in the back. I always assumed it was ice in the hatch. (been -30C to -15C in the last month.) I really don't think it's the same problem as the OP had.

2008 Jeep Compass North 4x4
Black Crystal Pearlcoat, 5-speed
View my iPod integration kit tutorial.
Read my Blog on Jeepspace
Knightfallzx2 is offline  
post #4 of 5 Old 01-26-2009, 12:29 PM
makoman
Registered User
2006 TJ Wrangler 
 
Join Date: Jan 2009
Location: Moyock
Posts: 36
Broken shock

I too had the same/similar sounds that you guys are describing and took it to the dealer and it turned out to be a broken shock. No idea how that happened.
makoman is offline  
post #5 of 5 Old 01-27-2009, 05:23 AM Thread Starter
Tony1911
Registered User
2007 MK Patriot 
 
Join Date: Nov 2007
Location: Helsinki
Posts: 266
Quote:
Originally Posted by flipperCompass View Post
Does it sound like it's coming from the back?
No, from the front. But it can be a bit difficult to locate the sound, especially if you have to concentrate on surrounding traffic at the same time...
Tony1911 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Loud knocking cold startup caseydog Jeep Compass & Patriot Forum 2 03-21-2009 10:17 PM
Pat 09 Sport - w/ 24E, Sun/Sound, CVT - 19,750 OTD? cdwmobile Jeep Compass & Patriot Forum 3 11-15-2008 01:23 PM
Ticking sound from speakers cuemark8 Jeep Compass & Patriot Forum 0 11-08-2008 08:25 AM
Issue with sound and how to rewire plunderisley Jeep Compass & Patriot Forum 0 10-13-2008 01:21 PM
07 Compass with BA sound...jvc HU problems.. evillilsf Jeep Compass & Patriot Forum 8 03-17-2008 05:28 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome