ESP traction control - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Compass & Patriot Forum > ESP traction control

FS: Wrangler RGB Multicolor Fog Light LEDs: Awesome EffectRockridge 4WD IS Taking Zone Offroad Suspension Lift Kits Rough Country Lift Kits and Parts!

Reply
Unread 07-25-2007, 04:44 PM   #1
goofy
Registered User
 
Join Date: Apr 2007
Location: St Peters, MO
Posts: 2
ESP traction control

Is anyone having problems with there ESP traction coming on when it is not needed. Mine has recently been doing that and I just wanted to know if anyone else is having the same troubles.

goofy is offline   Reply With Quote Quick reply to this message
Unread 07-25-2007, 05:29 PM   #2
merlinTec
Registered User
 
Join Date: Jul 2007
Location: England
Posts: 2,944
Hi
There is a T.S.B 08-010-07 for a fault with the steering angle sensor software that will put on the ESP light. That could well fix your fault.
merlinTec is offline   Reply With Quote Quick reply to this message
Unread 07-25-2007, 06:17 PM   #3
Gramps
The Necessary Evil
 
Gramps's Avatar
2007 MK Compass 
 
Join Date: Aug 2006
Location: Madison/Janesville, Wisconsin
Posts: 5,623
Here's the pdf on it.

http://www.wkjeeps.com/misc/KA/TSB/T...ro_0801007.pdf
__________________
Bob

Artificial intelligence is no substitute for natural stupidity

MK Skid Plate fasteners for sale posts 68 & 69

Also visit me at Photobucket
'06 WK Grand Cherokee Limited Quadra-Drive II, 5.7
'07 MK Compass Limited 4X4, AutoStick
Gramps is offline   Reply With Quote Quick reply to this message
Unread 07-25-2007, 09:50 PM   #4
tabcounter
Registered User
 
Join Date: Oct 2006
Location: maryland
Posts: 6
Hey, mine just started doing this the last 2 weeks. it has done it 3 times. got oil changed las t week but idiot dealer says i need an appt for this. thx gramps i am printing out the pdf and will take it with me when i go in to the dealer.
__________________
07 Compass,4x4,Limited, Black,18" Wheels,9 Speakers
00 Wrangler TJ, Green, Black Top
tabcounter is offline   Reply With Quote Quick reply to this message
Unread 07-26-2007, 08:18 AM   #5
Gramps
The Necessary Evil
 
Gramps's Avatar
2007 MK Compass 
 
Join Date: Aug 2006
Location: Madison/Janesville, Wisconsin
Posts: 5,623
Cheers to merlinTec for pointing it out!
__________________
Bob

Artificial intelligence is no substitute for natural stupidity

MK Skid Plate fasteners for sale posts 68 & 69

Also visit me at Photobucket
'06 WK Grand Cherokee Limited Quadra-Drive II, 5.7
'07 MK Compass Limited 4X4, AutoStick
Gramps is offline   Reply With Quote Quick reply to this message
Unread 07-26-2007, 09:46 PM   #6
unibus
Registered User
2007 MK Compass 
 
Join Date: Dec 2006
Location: Pennsylvania
Posts: 90
I had this problem..... took three trips to the dealer to get it fixed. They installed a new "clockspring" ( I know goofy name but it's called that in the parts manual ) in the steering column, and installed the TSB mentioned above. Did seem to actually fix it though, I haven't had the light come on for no reason since.
unibus is offline   Reply With Quote Quick reply to this message
Unread 07-27-2007, 01:40 PM   #7
BuzzDog
Registered User
 
Join Date: Dec 2006
Location: Rogers, AR
Posts: 91
Thanks, guys! Mine has done this twice in the past month, but it quickly went away both times. Now I have something to show to the dealer when I bring it in for my next service.
BuzzDog is offline   Reply With Quote Quick reply to this message
Unread 07-28-2007, 08:33 AM   #8
unibus
Registered User
2007 MK Compass 
 
Join Date: Dec 2006
Location: Pennsylvania
Posts: 90
Quote:
Originally Posted by unibus
I had this problem..... took three trips to the dealer to get it fixed. They installed a new "clockspring" ( I know goofy name but it's called that in the parts manual ) in the steering column, and installed the TSB mentioned above. Did seem to actually fix it though, I haven't had the light come on for no reason since.

Perhaps to clarify this.... my issue was that while driving the ESP/BAS light would come on and the chime would ring, the light would then stay on until the car was shut off. The next time the car was started the light would come on and the chime would ring and then extinguish after 30 seconds or so of driving. Sometimes it would happen several time a day other times it was weeks between occurances.
unibus is offline   Reply With Quote Quick reply to this message
Unread 07-28-2007, 03:53 PM   #9
goofy
Registered User
 
Join Date: Apr 2007
Location: St Peters, MO
Posts: 2
yes unibus that is exactly what has been happening to me. I am going to make an appointment at the dealer to have them take a look at it.
goofy is offline   Reply With Quote Quick reply to this message
Unread 01-29-2008, 06:36 PM   #10
Laloggia
Registered User
2010 JK Wrangler 
 
Join Date: Aug 2007
Location: NY
Posts: 136
ESP BAS light problem

Something strange happened today. Started the Compass, put it in reverse to back out of a parking spot, and i hear a long beep. I look at the dash and the BAS ESP light and the light next to it with the "slippery when wet" car come on. No check engine light. Car runs perfectly with lights on. I drive it to another parking spot a few rows over and put her in park, turn off the jeep, and wait 30 seconds.

After starting it up again, the lights stay on and i hear the beep again for a few seconds....then, they go off.

I drove it around the rest of the day putting about 60 miles on it and had no issues and no lights.

Anyone else have this problem???? Should i be concerned????

I am starting to not like this Jeep
__________________
2010 Wrangler Islander
2005 Chrysler Crossfire
2010 Honda Crosstour
2007 Honda Civic Coupe
Laloggia is offline   Reply With Quote Quick reply to this message
Unread 01-29-2008, 07:22 PM   #11
Gramps
The Necessary Evil
 
Gramps's Avatar
2007 MK Compass 
 
Join Date: Aug 2006
Location: Madison/Janesville, Wisconsin
Posts: 5,623
I would have the dealer run a diagnostic on the brake system. I couldn't find anything on it in the SM and was going to ask if something could have frozen over night, but I've seen -20 last year and -15 this year and no problems like that.

Maybe this TSB is involved?

http://www.wkjeeps.com/misc/Caliber/...er_0801007.pdf

or this recall?

http://www.wkjeeps.com/misc/Caliber/...er_RCF5007.pdf
__________________
Bob

Artificial intelligence is no substitute for natural stupidity

MK Skid Plate fasteners for sale posts 68 & 69

Also visit me at Photobucket
'06 WK Grand Cherokee Limited Quadra-Drive II, 5.7
'07 MK Compass Limited 4X4, AutoStick
Gramps is offline   Reply With Quote Quick reply to this message
Unread 01-30-2008, 06:55 PM   #12
unibus
Registered User
2007 MK Compass 
 
Join Date: Dec 2006
Location: Pennsylvania
Posts: 90
Quote:
Originally Posted by Laloggia
Something strange happened today. Started the Compass, put it in reverse to back out of a parking spot, and i hear a long beep. I look at the dash and the BAS ESP light and the light next to it with the "slippery when wet" car come on. No check engine light. Car runs perfectly with lights on. I drive it to another parking spot a few rows over and put her in park, turn off the jeep, and wait 30 seconds.

After starting it up again, the lights stay on and i hear the beep again for a few seconds....then, they go off.

I drove it around the rest of the day putting about 60 miles on it and had no issues and no lights.

Anyone else have this problem???? Should i be concerned????

I am starting to not like this Jeep

This sounds exactly like the problem I had with mine, There is a thread in this forum somewhere. But on mine they replace a component in the steering wheel (clockspring... I know strange name for a car part) and applied the TSB that Gramps was referring to and the problem hasn't come back. I really think the TSB fixed it.
unibus is offline   Reply With Quote Quick reply to this message
Unread 01-30-2008, 07:10 PM   #13
Gramps
The Necessary Evil
 
Gramps's Avatar
2007 MK Compass 
 
Join Date: Aug 2006
Location: Madison/Janesville, Wisconsin
Posts: 5,623
Quote:
Originally Posted by unibus
This sounds exactly like the problem I had with mine, There is a thread in this forum somewhere. But on mine they replace a component in the steering wheel (clockspring... I know strange name for a car part) and applied the TSB that Gramps was referring to and the problem hasn't come back. I really think the TSB fixed it.
Thanks unibus! I tracked down the thread: merged, go back to post #1
__________________
Bob

Artificial intelligence is no substitute for natural stupidity

MK Skid Plate fasteners for sale posts 68 & 69

Also visit me at Photobucket
'06 WK Grand Cherokee Limited Quadra-Drive II, 5.7
'07 MK Compass Limited 4X4, AutoStick
Gramps is offline   Reply With Quote Quick reply to this message
Unread 02-02-2008, 10:16 AM   #14
snood
Registered User
2007 MK Compass 
 
Join Date: May 2007
Location: New York
Posts: 127
I am having ESP problems when I take off...it will kick on and it make you feel like your car is going to die, then you get a jump of acceleration. Went to the dealer, they checked the software and that was all. Before I leave sometimes I will turn the esp off by holding the button until is says esp off and it is fine.
__________________
'07 Compass -> I apologize to the next owner.
snood is offline   Reply With Quote Quick reply to this message
Unread 02-02-2008, 10:29 AM   #15
Jeepster55
Registered User
 
Join Date: May 2007
Location: Indianapolis
Posts: 446
Quote:
Originally Posted by Laloggia
I am starting to not like this Jeep
don't do THAT! all vehicles will have some little quirks. just be grateful that yours didn't leave you stranded somewhere. a Pontiac G6 i had a couple years ago had the electric-assist power steering and every once in a while the steering wheel would LOCK UP while driving!!! this is NOT a good thing and certainly NOT a 'little quirk'. while i loved the car, GM kept denying there was a problem, even though i found many complaints of the same issue on the G6 forum and others. after about 6 months of this 'denial' from the manufacturer, i dumped the G6 (at a heavy cost to ME) and bought my Jeep Unlimited. i see where GM is STILL denying they have a problem with it, but i also see now where a couple people have claimed that accidents they had were the result of this 'steering lockup' issue.

so i would just keep on top of this ESP concern and keep in touch with your dealer should it happen again. like anythng else, Jeeps are still 'man made' and 'man' CAN make mistakes......
Jeepster55 is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.