Creaking noise from rear suspension after lift - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Compass & Patriot Forum > Creaking noise from rear suspension after lift

FS: Wrangler RGB Multicolor Fog Light LEDs: Awesome EffectSavvy Aluminum Gas Tank SkidFS: 2007-2013 Jeep Wrangler "HALO" Angel Eye Kit

Reply
Unread 06-30-2008, 05:55 AM   #1
AussiePat
Registered User
 
Join Date: Jun 2008
Location: Perth
Posts: 9
Creaking noise from rear suspension after lift

Hi Guy's,

I have installed the RRO lift on the Pat.
The front end is quiet as but the rear end makes some noises.

Symptoms are as follows:

1. While reversing out of the drive way or pulling into a drive way and when one wheel is higher than the other the back end creaks.
2. Going over larger bumps in the road the back end makes noises.
If at a stand still I open the tail gate and push the end up and down all is quiet.
3. When I go over changes in road and go over a crease in the road it feels as if the back skips over the bump instead of rolling over the crease in the road.

Man it really echoes from the back to the front.

I have lubed all joints at the back a few times now and its still there.

I'm wondering if the springs need to settle now a bit after things being lifted and that the Pat needs a few k's to settle down.
The front end is all fine.
I've called ARB who installed the lift for me have booked it in after lunch on Fri for them to look at.

Just wondering is anyone else had any probs after install such as this and then it settled down some what?


Last edited by AussiePat; 06-30-2008 at 06:15 AM..
AussiePat is offline   Reply With Quote
Unread 06-30-2008, 06:46 AM   #2
Gramps
The Necessary Evil
 
Gramps's Avatar
2007 MK Compass 
 
Join Date: Aug 2006
Location: Madison/Janesville, Wisconsin
Posts: 5,623
Same thing here for about 2-3 weeks after install, then it went away. I think it's because the rear shocks are not centered in the springs and they have to kind of re-seat or re-position themselves.
__________________
Bob

Artificial intelligence is no substitute for natural stupidity

MK Skid Plate fasteners for sale posts 68 & 69

Also visit me at Photobucket
'06 WK Grand Cherokee Limited Quadra-Drive II, 5.7
'07 MK Compass Limited 4X4, AutoStick
Gramps is offline   Reply With Quote
Unread 06-30-2008, 03:39 PM   #3
Coasty161
Registered User
2008 JK Wrangler 
 
Join Date: Oct 2006
Location: Port Huron, MI
Posts: 393
x2 as well
Coasty161 is offline   Reply With Quote
Unread 06-30-2008, 04:05 PM   #4
AussiePat
Registered User
 
Join Date: Jun 2008
Location: Perth
Posts: 9
Many thanks Jeepers for your feed back.
AussiePat is offline   Reply With Quote
Unread 07-04-2008, 03:03 AM   #5
AussiePat
Registered User
 
Join Date: Jun 2008
Location: Perth
Posts: 9
Hi Guy's,

I just wanted to give you an update.
Well after a week I thought it was getting better. Day after day.
But still there. So I took the Pat back into ARB and explained to them what the deal was.
They gresed up the bushings on the new control arms which they did not the 1st time and boy presto. The result was immediate. Drove home approx 30km's and whisper quiet. Here and there you get a slight creak but 100% improvement from before. So I'll keep an eye on it and let things settle down now.
But I thought I'd share the info incase someone else has the same prob and can see where maybe to investgate 1st.
__________________
Jeep Green Crd Limited, RRO Lifted, TX3400 & Coopers.
It's a Patriot thing, you wouldn't understand.
AussiePat is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.