Anyone here with transmission problem? I have a CVT2 - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Compass & Patriot Forum > Anyone here with transmission problem? I have a CVT2

End of Summer Sale, 20% OFF!2007 - 2011 Jeep JK Long Arm Lift KitsIntroducing MONSTALINER™ UV Permanent DIY Roll On Bed Line

Reply
Unread 04-29-2009, 08:58 PM   #1
Beware
Registered User
2007 MK Compass 
 
Join Date: Apr 2009
Location: Singapore
Posts: 63
Anyone here with transmission problem? I have a CVT2

Sometimes when i start and move off the vehicle, it'll be very very slow and i'll be stuck at 1500rpm no matter how hard i pump on the accelerator... had to shut the vehicle completely and start the engine again to correct this problem.


Anyone with same problem?

Thanks

Beware is offline   Reply With Quote
Unread 04-30-2009, 05:23 AM   #2
Gramps
The Necessary Evil
 
Gramps's Avatar
2007 MK Compass 
 
Join Date: Aug 2006
Location: Madison/Janesville, Wisconsin
Posts: 5,623
It sounds like you need a trip back to the dealer. It may be in the programming but I'll hazard a guess at it being the Throttle Position Sensor.
__________________
Bob

Artificial intelligence is no substitute for natural stupidity

MK Skid Plate fasteners for sale posts 68 & 69

Also visit me at Photobucket
'06 WK Grand Cherokee Limited Quadra-Drive II, 5.7
'07 MK Compass Limited 4X4, AutoStick
Gramps is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.