ABS, ESP BAS, Traction control, 4WD lights on - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Compass & Patriot Forum > ABS, ESP BAS, Traction control, 4WD lights on

Jeep Grand Cherokee Mirror - Side ViewJeep Grand Cherokee Header PanelTJ 5.25" Speaker Adapters - NalinMFG

Reply
Unread 09-04-2011, 01:41 PM   #1
nightcrawlermc
Registered User
2007 MK Patriot 
 
Join Date: Jan 2011
Location: Lynch Station, Virginia
Posts: 17
ABS, ESP BAS, Traction control, 4WD lights on

2007 Jeep Patriot 2.4L 4WD. I have been having a problem the past couple of weeks with these lights coming on. When the traction control light started blinking intermittently and reducing my speed I had it checked out after I couldn't find anything. The ball joints were about to come out and so I got them replaced. He's a good mechanic so I know he did it right and they were bad. I thought it would solve the problem but didn't. He pulled the codes and got several, we just thought they were probably stored from before so he cleared them. I told him I'd just try to figure it out if they came back on. Lights are still coming on. I unbolted the wheel sensors and cleaned all the dirt and corrosion off, unplugged them cleaned that connection and the problem went away for about 10 miles. Now the lights are back on. ABS, ESP BAS, Traction almost all of the time, 4WD sometimes. Got it scanned at Advance and got B1042, B101F. Looked them up in service manual and it pointed to right speed sensor, checked tire pressure and cleaned it one more time. Still get the lights. The next thing I'm thinking of doing is replacing the sensor, but I've read about wiring problems on these vehicles. Any other suggestions? Any help is greatly appreciated.

nightcrawlermc is offline   Reply With Quote
Unread 09-04-2011, 04:14 PM   #2
Gramps
The Necessary Evil
 
Gramps's Avatar
2007 MK Compass 
 
Join Date: Aug 2006
Location: Madison/Janesville, Wisconsin
Posts: 5,623
After doing the ball joints did you align it? The steering angle sensor is connected to all of the fault lights that you've mentioned and that sensor will be misaligned after doing ball joints and tie rods. Try stopping and cranking the steering wheel all the way left, then right. If it goes off temporarily then comes back on then it's more than likely an alignment issue.
__________________
Bob

Artificial intelligence is no substitute for natural stupidity

MK Skid Plate fasteners for sale posts 68 & 69

Also visit me at Photobucket
'06 WK Grand Cherokee Limited Quadra-Drive II, 5.7
'07 MK Compass Limited 4X4, AutoStick
Gramps is offline   Reply With Quote
Unread 09-04-2011, 07:51 PM   #3
nightcrawlermc
Registered User
2007 MK Patriot 
 
Join Date: Jan 2011
Location: Lynch Station, Virginia
Posts: 17
Yeah, I got it aligned. The guy that did the alignment and ball joints said everything in the suspension was good. I tried turning the steering back and forth and the lights stayed on. I drove it a little this afternoon. The lights stayed on most of the time, they did turn off for a minute then back on, then off for 5 seconds then back on. Every now and then when the lights are off and I brake the pedal pulsates a little like the power brakes are not working, then I let off and back on and they're fine. I'm going to try a wheel speed sensor and hope that does it. Might have to take it to the dealer after that, I don't know much about wiring and that seem like the only thing left.
nightcrawlermc is offline   Reply With Quote
Unread 09-13-2011, 11:11 AM   #4
Karen63ca
Registered User
2007 MK Compass 
 
Join Date: Aug 2009
Location: Luskville,Quebec
Posts: 4
Hay 2007 MK I have a 2007 Compass and it did the same exact thing and I brought it back to the dealer and it was the censor and they had to replace it once that was done the issue has never re-surfaced so I think you will have to replace the censor For me it was a bit costly as I also get a few other things done but I do beleive it was around $100 .. Good Luck ( Unsatisfiied Jeep Compass Owner as I now have to replace the computer and I have 160000KM on it not even 5yrs old)
Karen63ca is offline   Reply With Quote
Unread 09-13-2011, 12:16 PM   #5
Gramps
The Necessary Evil
 
Gramps's Avatar
2007 MK Compass 
 
Join Date: Aug 2006
Location: Madison/Janesville, Wisconsin
Posts: 5,623
Electronics being unpredictable will be a problem with all modern vehicles. Someone has to be on the bottom end of longevity curve. That doesn't mean that I don't empathise.
__________________
Bob

Artificial intelligence is no substitute for natural stupidity

MK Skid Plate fasteners for sale posts 68 & 69

Also visit me at Photobucket
'06 WK Grand Cherokee Limited Quadra-Drive II, 5.7
'07 MK Compass Limited 4X4, AutoStick
Gramps is offline   Reply With Quote
Unread 09-14-2011, 07:46 PM   #6
nightcrawlermc
Registered User
2007 MK Patriot 
 
Join Date: Jan 2011
Location: Lynch Station, Virginia
Posts: 17
It looks like it was the wheel speed sensor. I replaced it on Saturday and the lights went out and they have not come on since. I ordered it online and it was a Mopar. It only cost me $28 including shipping. It was very easy to replace myself, just take out a bolt, unplug a plug, take it out and run the new one back through. The wheel speed sensor and ball joints are the only problems I've had out of the Patriot so I don't have any complaints, it has 63000 miles on it and I bought it brand new. I love it, it will go anywhere as long as it has clearance.
nightcrawlermc is offline   Reply With Quote
Unread 09-15-2011, 08:22 AM   #7
Gramps
The Necessary Evil
 
Gramps's Avatar
2007 MK Compass 
 
Join Date: Aug 2006
Location: Madison/Janesville, Wisconsin
Posts: 5,623
Congrats on finding the fix and getting back to us with it!
__________________
Bob

Artificial intelligence is no substitute for natural stupidity

MK Skid Plate fasteners for sale posts 68 & 69

Also visit me at Photobucket
'06 WK Grand Cherokee Limited Quadra-Drive II, 5.7
'07 MK Compass Limited 4X4, AutoStick
Gramps is offline   Reply With Quote
Unread 07-05-2012, 09:48 PM   #8
Palvati
Registered User
 
Join Date: Jul 2012
Location: Fords, NJ
Posts: 1
I'm having the exact same issue on my 2008 Jeep Patroit, can you tell me in more details on how to fix it?
Palvati is offline   Reply With Quote
Unread 04-23-2013, 09:17 AM   #9
Maddogpearce
Registered User
 
Join Date: Apr 2013
Location: clovis, NM
Posts: 1
2009 Jeep Compass

Everything I read about the speed sensor says the same thing. I think crysler from 2007 to 2011 is having the same problem. The only problem I am having is that all I can find online and all Auto Zone can find is the back right sensor. Is that sensor interchangable on all four wheels or is there a sensor for each wheel and I just havent found it yet?
Maddogpearce is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.