ABS,ESP/BAS and TCS lights all came on! - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Compass & Patriot Forum > ABS,ESP/BAS and TCS lights all came on!

Jeep Wrangler Wheel Bearing & Hub - FrontJeep Grand Cherokee Window RegulatorComponent speaker deal for your dash - NalinMFG

Reply
Unread 02-12-2013, 06:55 PM   #1
groo
Registered User
 
Join Date: Apr 2004
Posts: 7
ABS,ESP/BAS and TCS lights all came on!

I have a 2009 jeep patriot. Today the ABS,ESP/BAS and TCS lights all came on.
This is the third time this has happened, to the day... Feb 11, 2011; Feb 11, 2012, and now Feb 12, 2013..... The first two time it was taken to the dealer and they changed the ABS sensor in both instances. But now it happened for a third time and I'm shore it wil not be covered under warranty, being that it has about 41000 miles...

Has the ABS sensor been a problem with these jeeps?
My sister in law has the same jeep and year, and has had the same problem!

All comments welcome

groo is offline   Reply With Quote
Unread 02-12-2013, 07:28 PM   #2
FujativeOCR
Registered User
2011 MK Patriot 
 
Join Date: Aug 2011
Location: Newfoundland, Center of the Universe
Posts: 878
When my Grand Am used to do that it was a wheel speed sensor. Located in the hub.
FujativeOCR is offline   Reply With Quote
Unread 02-13-2013, 05:58 AM   #3
Gramps
The Necessary Evil
 
Gramps's Avatar
2007 MK Compass 
 
Join Date: Aug 2006
Location: Madison/Janesville, Wisconsin
Posts: 5,623
I had a similar problem on my '07 that turned out to be the Steering Angle Sensor (it was out of alignment due to ball joints and tie rod ends). A quick check is to turn the steering wheel full left/right/left and see if the reset fixes it and then go from there.
__________________
Bob

Artificial intelligence is no substitute for natural stupidity

MK Skid Plate fasteners for sale posts 68 & 69

Also visit me at Photobucket
'06 WK Grand Cherokee Limited Quadra-Drive II, 5.7
'07 MK Compass Limited 4X4, AutoStick
Gramps is offline   Reply With Quote
Unread 02-13-2013, 06:50 AM   #4
groo
Registered User
 
Join Date: Apr 2004
Posts: 7
Thanks, i will try that.
groo is offline   Reply With Quote
Unread 02-14-2013, 05:10 AM   #5
groo
Registered User
 
Join Date: Apr 2004
Posts: 7
Nope, still the same taking it to the dealer this weekend....... not happy with this item!
groo is offline   Reply With Quote
Unread 02-20-2013, 01:16 AM   #6
Amis
Registered User
2008 MK Patriot 
 
Join Date: Feb 2013
Location: Rapid City, MI
Posts: 1
My pat had same problem

My pat had the same thing happen and it was the speed sensor in the rear. They were easy to change and only $15 each side. Just changed both sides.
Amis is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.