2010 Compass TCS Light - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Compass & Patriot Forum > 2010 Compass TCS Light

XT (ExtremeTerrain.com) has Barricade Off-Road Armor!ROCKRIDGE4WD Introduces a NEW Jeep Wrangler JK *led* tail Nitro Gear Packages Now Available at Rockridge 4wd

Reply
Unread 03-20-2015, 09:01 PM   #1
BlackTuxCA
Registered User
 
Join Date: Mar 2015
Posts: 6
2010 Compass TCS Light

Hello all, I just picked up a 2010 Compass with 80k miles on it from a dealership 4 days ago, Ive put on about 80 miles now and today on the highway in traffic the ETC light came on followed by the esp/tcs light. The car started to run slow and would only go about 15 miles per hour. I Pulled over and shut the car off and when i turned it back on the ETC light was off but the ESP/TCS light still comes on and the jeep still crawls. I need to get it to the shop but dont have the money to tow it.

The manual says dont turn off ESP. Can i turn it off to get to the dealership? I also read a couple tips on here? Someone said turn full left and then full right. Another said to try switching to 1st or 2nd gear and then back to drive? Add water to the battery lol? Is there anything else I can try? The dealership is maybe 15 minutes away. Do I just need to clear the codes?

Thanks for any help you can provide


Last edited by BlackTuxCA; 03-20-2015 at 09:43 PM..
BlackTuxCA is offline   Reply With Quote Quick reply to this message
Unread 03-21-2015, 04:21 AM   #2
Sdsjeep2008
Registered User
2008 MK Compass 
 
Join Date: Jan 2015
Location: Montpelier, Vermont
Posts: 29
Quote:
Originally Posted by BlackTuxCA View Post
Hello all, I just picked up a 2010 Compass with 80k miles on it from a dealership 4 days ago, Ive put on about 80 miles now and today on the highway in traffic the ETC light came on followed by the esp/tcs light. The car started to run slow and would only go about 15 miles per hour. I Pulled over and shut the car off and when i turned it back on the ETC light was off but the ESP/TCS light still comes on and the jeep still crawls. I need to get it to the shop but dont have the money to tow it.

The manual says dont turn off ESP. Can i turn it off to get to the dealership? I also read a couple tips on here? Someone said turn full left and then full right. Another said to try switching to 1st or 2nd gear and then back to drive? Add water to the battery lol? Is there anything else I can try? The dealership is maybe 15 minutes away. Do I just need to clear the codes?

Thanks for any help you can provide
I'm new to this myself and have only had it happen once with it being resolved for now with simply turning the engine off for a few minutes.

Have you tried disconnecting the negative battery terminal for an hour or so?
Sdsjeep2008 is offline   Reply With Quote Quick reply to this message
Unread 03-21-2015, 06:00 AM   #3
BlackTuxCA
Registered User
 
Join Date: Mar 2015
Posts: 6
Thanks for the reply

I let the jeep sit for 10 minutes maybe, im pretty impatient and was stressing out so it might have been shorter. It was still limp. It has sat overnight and I will go give it another shot here thismorning. Will try disconnecting the negative from the battery also.
BlackTuxCA is offline   Reply With Quote Quick reply to this message
Unread 03-21-2015, 10:46 AM   #4
BlackTuxCA
Registered User
 
Join Date: Mar 2015
Posts: 6
So I got to the jeep and turned the wheel left and right, tapped my belly 3 times and nodded and the car still limped. I took the battery cover off and noticed how it wasnt sitting engine shroud properly. With the battery cover off i tried the gas and it was still limp. The battery water level was fine except on the 2 outside holes, and the leads were corroded. i shut down put the battery cover back on, walked to a mechanic across the street to see if he could look, and the thing started to ride normally.

Im confused. Im starting to wonder if it had to do with the throttle body, the battery cover shovels air towards the engine and its not connecting to the engine shroud(maybe thats the throttle body) properly. Anywho, going to call the dealer who i bought the jeep from 4 days ago and get them to look at it and try to cancel within 30 days if i can. Maybe i can get a free battery from the dealership
BlackTuxCA is offline   Reply With Quote Quick reply to this message
Unread 03-22-2015, 03:58 AM   #5
Sdsjeep2008
Registered User
2008 MK Compass 
 
Join Date: Jan 2015
Location: Montpelier, Vermont
Posts: 29
I think it was probably just random chance that it cleared itself. If it's true what I've read from other people's posts and a bad battery can cause the ETC issue, then having two dry or low cells and corroded leads could be the culprit. I would at the very least replace the battery and clean those leads. Now that I think about it, I believe I changed my battery which I believe was the original one after my one time getting the ETC and it hasn't happened since and it's been about 1000 miles.
Sdsjeep2008 is offline   Reply With Quote Quick reply to this message
Unread 03-24-2015, 09:35 AM   #6
BlackTuxCA
Registered User
 
Join Date: Mar 2015
Posts: 6
When I got the Jeep the salesman had a henchmen go get gas. The guy left for like 40 minutes and when he came back he was driving slow. It just hit me now that the jeep was limp right then. A mechanic ran up to the car before he dropped it off to me and had something in his hand. Its hitting me now that the guy cleared the code and then gave the jeep over to me. I havent used an ODBII scanner in a long time, does it record day/time of the alarm/alert? Id love to see if the guy cleared the code and then just handed it over to me like that. The ODBII port is on the drive side near gas pedal right?
BlackTuxCA is offline   Reply With Quote Quick reply to this message
Unread 03-25-2015, 02:48 AM   #7
Sdsjeep2008
Registered User
2008 MK Compass 
 
Join Date: Jan 2015
Location: Montpelier, Vermont
Posts: 29
Yes, that is where the ODBII port is located. I believe it is actually an ODBII CAD for this jeep as I was not able to use my standard OBDII reader on mine. You can get codes by running the key on/off three times.
Not sure what he had for a scanner so I can't say if it stored the time and date of the events or not.
Not sure why they would just clear the code like that without at least telling you what they were doing unless it was to try to get out of warranty work but since you already have reported the problem, it still should be covered later.
Sdsjeep2008 is offline   Reply With Quote Quick reply to this message
Unread 03-25-2015, 02:01 PM   #8
JeepCares
Registered User
 
Join Date: Jan 2012
Location: MOPAR World Headquarters
Posts: 2,686
Quote:
Originally Posted by BlackTuxCA View Post
When I got the Jeep the salesman had a henchmen go get gas. The guy left for like 40 minutes and when he came back he was driving slow. It just hit me now that the jeep was limp right then. A mechanic ran up to the car before he dropped it off to me and had something in his hand. Its hitting me now that the guy cleared the code and then gave the jeep over to me. I havent used an ODBII scanner in a long time, does it record day/time of the alarm/alert? Id love to see if the guy cleared the code and then just handed it over to me like that. The ODBII port is on the drive side near gas pedal right?
Hey BlackTuxCA,
Sorry you are having issues with your Compass. Have you had the vehicle inspected at an FCA certified dealership yet?
__________________
Andrea
Jeep Social Care Specialist
JeepCares is offline   Reply With Quote Quick reply to this message
Unread 03-25-2015, 03:08 PM   #9
BlackTuxCA
Registered User
 
Join Date: Mar 2015
Posts: 6
It passed inspection a month ago (done by the dealership i purchased it at) but that doesnt mean much.

I took it by the dealership and to my surprise they told me that it was the gas cap. I figured they were blowing me off, but sure enough the gas cap is iffy and keyed weird and possibly faulty and really only goes in one way. The other times its just sitting there and looks like its in all the way. The code they found was a mass flow air sensor. I was experiencing a performance issue, low power, but didnt really realize it because it was a new ride for me. Going to take her for a long ride this weekend but I think that might have actually been the issue. Little embarrassed that leaving a gas cap off caused my car to break down 3 times lately.

going to look for a odbII reader so i can try to catch a code if it happens again
BlackTuxCA is offline   Reply With Quote Quick reply to this message
Unread 03-26-2015, 06:02 AM   #10
Sdsjeep2008
Registered User
2008 MK Compass 
 
Join Date: Jan 2015
Location: Montpelier, Vermont
Posts: 29
Thats weird! I thought these had a "loose gas cap" light that came on when that happens. I know the gas cap is kind of weird and doesnt seem like it screws in all the way. Hopefully, that was it. My Compass has been almost 1500 miles since it happened to me with no issues. But mine cleared out OK after I shut it off for a few minutes.
Sdsjeep2008 is offline   Reply With Quote Quick reply to this message
Unread 03-26-2015, 09:46 AM   #11
JerryGNYC
Registered User
2015 MK Patriot 
 
Join Date: Dec 2014
Location: Flushing, NY
Posts: 64
According to the manual (mine's a 2015), the odometer should display "gASCAP" if -

"If the vehicle diagnostic system determines that the fuel filler cap is loose, improperly installed, or damaged,“gASCAP” message will display in the odometer display area. Tighten the fuel filler cap properly and press TRIP ODOMETER button to turn off the message. If problem continues, the message will appear the next time the vehicle is started."

I'm wondering if there's a bad sensor somewhere, causing you not to see this error message...
__________________
- Common sense is on perpetual backorder.
JerryGNYC is offline   Reply With Quote Quick reply to this message
Unread 03-26-2015, 11:21 AM   #12
Sdsjeep2008
Registered User
2008 MK Compass 
 
Join Date: Jan 2015
Location: Montpelier, Vermont
Posts: 29
Exacty, JerryGNYC! My point is that I don't think a loose or even a missing gas cap would cause the ETC and other codes and issues.
Sdsjeep2008 is offline   Reply With Quote Quick reply to this message
Unread 03-27-2015, 10:39 AM   #13
JeepCares
Registered User
 
Join Date: Jan 2012
Location: MOPAR World Headquarters
Posts: 2,686
Quote:
Originally Posted by BlackTuxCA View Post
It passed inspection a month ago (done by the dealership i purchased it at) but that doesnt mean much.

I took it by the dealership and to my surprise they told me that it was the gas cap. I figured they were blowing me off, but sure enough the gas cap is iffy and keyed weird and possibly faulty and really only goes in one way. The other times its just sitting there and looks like its in all the way. The code they found was a mass flow air sensor. I was experiencing a performance issue, low power, but didnt really realize it because it was a new ride for me. Going to take her for a long ride this weekend but I think that might have actually been the issue. Little embarrassed that leaving a gas cap off caused my car to break down 3 times lately.

going to look for a odbII reader so i can try to catch a code if it happens again
Glad your issue has been resolved. If you have additional questions, let me know!
__________________
Andrea
Jeep Social Care Specialist
JeepCares is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.