2008 Patriot - brake/traction light stays on...bad braking - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Compass & Patriot Forum > 2008 Patriot - brake/traction light stays on...bad braking

Introducing MONSTALINER™ UV Permanent DIY Roll On Bed LineThe Solution to Radius Arm Bind - Meet Lock-N-LoadFS: Jeep Fog Light LED Bulbs! Several Brightness Options!

Reply
Unread 09-23-2012, 10:35 PM   #1
TXST8tj
Registered User
2001 TJ Wrangler 
 
Join Date: Oct 2004
Location: Katy, Texas
Posts: 3,321
2008 Patriot - brake/traction light stays on...bad braking

My sister has a 2008 Patriot. The brake assist/traction control light constantly comes on the dash. While the light is on, the braking is...spongy. Maybe a bad descriptor, but the braking is poor.

She thought it was the actual brakes, so I checked them and rotors and pads are perfectly fine, as well as fluid.

Is this something that just requires a reset, or is there something more wrong?

TXST8tj is offline   Reply With Quote Quick reply to this message
Unread 09-23-2012, 10:44 PM   #2
FujativeOCR
Registered User
2011 MK Patriot 
 
Join Date: Aug 2011
Location: Newfoundland, Center of the Universe
Posts: 878
Sounds like another bad wheel speed sensor. Seen a few of those on here lately. There are sensors in the hubs that measure how fast each wheel spins. If one slows down or stops in relation to the rest, the traction control or ABS will compensate as it calculates necessary. Maybe with a bad sensor it thinks you are skidding, and releases the brakes, which it thinks will get the wheels spinning again.
FujativeOCR is offline   Reply With Quote Quick reply to this message
Unread 09-27-2012, 03:34 PM   #3
TXST8tj
Registered User
2001 TJ Wrangler 
 
Join Date: Oct 2004
Location: Katy, Texas
Posts: 3,321
Has anyone done a writeup on replacing these?
Is there anyway to tell which one(s) it is?
It makes sense that it could be the problem.
TXST8tj is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.