2007 Compass shuddering! - JeepForum.com

 
LinkBack Thread Tools
post #1 of 7 Old 12-25-2013, 07:18 PM Thread Starter
sunni16200
Registered User
 
Join Date: Dec 2013
Posts: 1
2007 Compass shuddering!

My Compass has been shuddering when I'm idle or when I accelerate. Have had this issue happen more often in the past few weeks. A mechanic who happens to be a customer in our store suggested a changing of the transmission fluid. Would this sound like it would solve the problem?

sunni16200 is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old 12-27-2013, 09:43 AM
aroundincircles
Registered User
1989 XJ Cherokee 
 
Join Date: Nov 2011
Location: Chandler
Posts: 1,656
Check transmission fluid, but it sounds more like a broken motor mount to me.
aroundincircles is online now  
post #3 of 7 Old 12-27-2013, 11:37 AM
LKWJEEPER
Registered User
2009 KK Liberty 
 
Join Date: Nov 2012
Location: Clover
Posts: 1,060
Do you have any issues accelerating? I recently had a bad ignition coil on my Liberty and it shook the heck out of my Liberty. Then on acceleration the chugging was terrible.

It all started out as a terrible shudder at idle and acceleration.
LKWJEEPER is offline  
post #4 of 7 Old 12-28-2013, 05:15 PM
TigerKK
Registered User
 
Join Date: Dec 2013
Posts: 19
Could it be the fuel filter needs changing? Recently did this to resolve a shuddering issue on our Patriot CRD (07 model) that caused jerking at low and high speed.
TigerKK is offline  
post #5 of 7 Old 03-29-2014, 10:50 AM
juandon123
Registered User
2007 MK Compass 
 
Join Date: Oct 2012
Location: Savoy
Posts: 8
Quote:
Originally Posted by TigerKK View Post
Could it be the fuel filter needs changing? Recently did this to resolve a shuddering issue on our Patriot CRD (07 model) that caused jerking at low and high speed.
Do you mean you replaced the fuel pump? Is the filter a serviceable part?
juandon123 is offline  
post #6 of 7 Old 04-02-2014, 08:25 AM
aroundincircles
Registered User
1989 XJ Cherokee 
 
Join Date: Nov 2011
Location: Chandler
Posts: 1,656
aroundincircles is online now  
post #7 of 7 Old 07-23-2014, 07:42 PM
juandon123
Registered User
2007 MK Compass 
 
Join Date: Oct 2012
Location: Savoy
Posts: 8
Did you resolve the issue? Were you also having problems with engine shuddering on deceleration? I've checked plugs, leaks, treated the gas, replaced air filters, and I still have hesitation on acceleration and deceleration when the car's cold. When it warms up, however, it goes away.

Thanks for sharing your solution!
juandon123 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome