Winsheild washer pump - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Wrangler Forums > JK Wrangler Technical Forum > Winsheild washer pump

ZONE 4.25" combo lift for TJ available at Rockridge4wSPARTAN LOCKERS are on sale BIG TIME at ROCKRIDGE 4WD!NEW JK WRANGLER GRAB BARS NOW at ROCKRIDGE4WD

Reply
Unread 07-13-2009, 06:17 PM   #1
Slenny
Registered User
2007 JK Wrangler 
 
Join Date: Jul 2007
Location: US
Posts: 885
Winsheild washer pump

Whenever I used the windsheild washer it was like a powerwasher shooting out. Today it trickles out. Right behind the container that holds the washer fluid it looks like it's the pump. Is it or has anybody had this same problem? It eill fall under warrantee for me but i would like to help the service guy diagnose the problem so they don't have my Jeep for a week trying to figure what's wrong.

Slenny is offline   Reply With Quote
Unread 07-13-2009, 06:38 PM   #2
Rakkasan
Registered User
2009 JK Wrangler 
 
Join Date: Jul 2008
Location: PA
Posts: 2
Might not help but after the dealership put on my new hardtop my pressure up front just drooled out. The back was fine. Since it worked before they had it I just took it back to them to fix. Got it back and they said it was a pinched hose.
Rakkasan is offline   Reply With Quote
Unread 07-13-2009, 06:43 PM   #3
Slenny
Registered User
2007 JK Wrangler 
 
Join Date: Jul 2007
Location: US
Posts: 885
Quote:
Originally Posted by Rakkasan View Post
Might not help but after the dealership put on my new hardtop my pressure up front just drooled out. The back was fine. Since it worked before they had it I just took it back to them to fix. Got it back and they said it was a pinched hose.
I checked hoses and I could'nt find any. It acted the same when the hood was up.
Slenny is offline   Reply With Quote
Unread 07-13-2009, 09:26 PM   #4
1222
Make mine a Jeep!
 
1222's Avatar
2012 JK Wrangler 
 
Join Date: Jul 2007
Location: Henderson, Nevada
Posts: 11,627
I donít have an answer, but just to say that my pump quit altogether. It happened a couple of months ago. So far Iíve been too lazy to get it fixed. I do miss it though.
__________________
1222 is offline   Reply With Quote
Unread 07-14-2009, 04:00 PM   #5
Slenny
Registered User
2007 JK Wrangler 
 
Join Date: Jul 2007
Location: US
Posts: 885
After further investigation I pulled the pump and looked at the bottom with a flashlight and it was covered with brown slime. I took a rag and wiped it off, flushed the container with clean water, washed the bottom of the pump. Now it works like a charm, not sure where the brown slime came from because I go through a lot of washer fluid.
Slenny is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.