weird engine pop after shutting it off - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Wrangler Forums > JK Wrangler Technical Forum > weird engine pop after shutting it off

Cess Recovery Gear Snatch Tow Strap OffRoad @ ROCKRIDGE4WDYukon Ultimate 35 axle kit for c/clip axles with Yukon ZipArtec Flash Sale - 15% off and Free Shipping over $300

Reply
Unread 01-05-2014, 02:20 PM   #1
jeepwrnglr92
Registered User
2013 JK Wrangler 
 
Join Date: Feb 2007
Location: WPB FL
Posts: 1,905
weird engine pop after shutting it off

I have been working on the Jeep on and on and have disconnected and reconnected the battery a few times. Left it over night with no batter etc.

Now when I start the Jeep is runs fine and seems to drive fine...

BUT!!!
when I shut the engine off it seems to pop like the old cars with carbs.
I took it for a 6 mile drive down the road and sure enough it still does it.

My question is this... Does the computer need to relearn something? No codes .
it never did this before. only 1400 miles on it.

Ill call the dlr tomorrow too but just wanted to see if anyone else had this happen.

I made no changes to anything under the hood.
I just added a power outlet to the dash.

__________________
2013 Jeep Wrangler Sport
2002 Avalanche: To many mods to list
jeepwrnglr92 is offline   Reply With Quote
Unread 01-05-2014, 06:37 PM   #2
jeepwrnglr92
Registered User
2013 JK Wrangler 
 
Join Date: Feb 2007
Location: WPB FL
Posts: 1,905
I guess I am lucky one with this issue. I'll be calling dlr tomorrow.
__________________
2013 Jeep Wrangler Sport
2002 Avalanche: To many mods to list
jeepwrnglr92 is offline   Reply With Quote
Unread 01-05-2014, 08:36 PM   #3
number40Fan
Registered User
2014 JK Wrangler 
 
Join Date: Oct 2013
Posts: 278
Keep us informed.

Does it sound like a back fire? Pow! Or just a poof?
number40Fan is offline   Reply With Quote
Unread 01-06-2014, 04:57 AM   #4
jeepwrnglr92
Registered User
2013 JK Wrangler 
 
Join Date: Feb 2007
Location: WPB FL
Posts: 1,905
Quote:
Originally Posted by number40Fan View Post
Keep us informed.

Does it sound like a back fire? Pow! Or just a poof?
poof no bang
__________________
2013 Jeep Wrangler Sport
2002 Avalanche: To many mods to list
jeepwrnglr92 is offline   Reply With Quote
Unread 01-07-2014, 05:10 AM   #5
jeepwrnglr92
Registered User
2013 JK Wrangler 
 
Join Date: Feb 2007
Location: WPB FL
Posts: 1,905
well the dlr never called me back yesterday. i may just drive over there on Friday.

Took the Jeep to the beach about 6 miles round trip. Seemed OK. Ill check it again today when i get home. Maybe it just needed more diving time after resetting? Still not convinced yet.

Never had a car do this since my 1974 454 big block vette years ago. Miss those big blocks. hmm 454 Jeep
__________________
2013 Jeep Wrangler Sport
2002 Avalanche: To many mods to list
jeepwrnglr92 is offline   Reply With Quote
Unread 01-21-2014, 07:04 AM   #6
jeepwrnglr92
Registered User
2013 JK Wrangler 
 
Join Date: Feb 2007
Location: WPB FL
Posts: 1,905
The Jeep stopped making this sound after a few times of taking it out. I took it to the dlr and no codes and nothing appears to be wrong.
I may need to disconnect the battery in the future so I will see if it happens again.
But what ever it is the computer seems to have resolved the issues now. Self healing
__________________
2013 Jeep Wrangler Sport
2002 Avalanche: To many mods to list
jeepwrnglr92 is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.