Tanimal's 2008 2D JK Build Thread - Page 11 - JeepForum.com

Reply
 
LinkBack Thread Tools
post #151 of 409 Old 02-20-2013, 07:58 PM Thread Starter
Tanimal
Registered User
2008 JK Wrangler 
 
Join Date: Jan 2012
Location: Bartlett
Posts: 1,449
Started up the Jeep and my "electronic throttle control light" came on along with the "check engine light". Turned the Jeep off and restarted and the electrical throttle control light cleared but not the check engine light. Was driving and I was up at 3/4 of the way to overheating. Pulled into Autozone and grabbed some coolant and topped off my overflow tank which was down at "minimum". Turned the Jeep back over and the check engine light was gone but I was still 3/4 way to overheating. Haven't been through mud recently and didn't see any leaks coming from my water pump. Thinking it is the thermostat, other suggestions? Thanks

Tanimal is offline  
Sponsored Links
Advertisement
 
post #152 of 409 Old 02-20-2013, 09:40 PM
mrwhipple
Registered User
2012 JK Wrangler 
 
Join Date: Oct 2010
Location: LA
Posts: 832
probably a sticky thermostat.
is the coolant fairly clean in the radiator? sometimes a flush might help, but thermostats are cheap enough to replace.

silver jkur
mrwhipple is offline  
post #153 of 409 Old 02-20-2013, 09:44 PM Thread Starter
Tanimal
Registered User
2008 JK Wrangler 
 
Join Date: Jan 2012
Location: Bartlett
Posts: 1,449
Quote:
Originally Posted by mrwhipple View Post
probably a sticky thermostat.
is the coolant fairly clean in the radiator? sometimes a flush might help, but thermostats are cheap enough to replace.
Yes coolant was fairly clean and I'm going to guess a thermostat also. Went outside after the jeep sat there for 1+ hour in 20 degrees and it still was showing halfway on the gauge which I thought was very incorrect since the heat was blowing cold from the inside.

Thanks for the response.
Tanimal is offline  
post #154 of 409 Old 02-21-2013, 12:38 PM Thread Starter
Tanimal
Registered User
2008 JK Wrangler 
 
Join Date: Jan 2012
Location: Bartlett
Posts: 1,449
Went to go fire my Jeep up this morning to go get a new thermostat and it wouldn't start! I checked all the fuses, reset my computer back to "stock tune" with superchips and tried to pull any codes and there were none. Disconnected the battery and reset the "PCM adaptive memory". No leaking water pump. Tried shifting it from Park to Neutral and starting it with no success and battery was fine. Was at a loss so the Jeep has to take a ride....


Not happy about having to take it to the shop but it's beyond my minor mechanical abilities. Snow storm is coming tonight and I don't get to play now but I'll keep updates on this thread in case someone else has similar issues.
Tanimal is offline  
post #155 of 409 Old 02-21-2013, 01:22 PM
442Wrangler
In like Flynn.
 
442Wrangler's Avatar
2008 JK Wrangler 
 
Join Date: Dec 2008
Location: Little Lamplight
Posts: 2,278
Did the Jeep come on when turning the keys or was it completely dead? Did the starter click or did nothing happen? Did you disconnect any wires during the thermostat change?

Just trying to get a better picture.

2008 JK Rubicon
-255/80/17 BFG KM2s, 16/59 JKU springs, 2013 Rubi rims, RC stubby hybrid front bumper, XRC8 winch with synthetic line, RR evap skid, and more to come

1959 Willys Wagon
-Going to be restored and painted Plantation White and Presidential Red


"I would rather wake up in the middle of nowhere than in any city on earth."
-Steve McQueen
442Wrangler is offline  
post #156 of 409 Old 02-21-2013, 01:32 PM Thread Starter
Tanimal
Registered User
2008 JK Wrangler 
 
Join Date: Jan 2012
Location: Bartlett
Posts: 1,449
Quote:
Originally Posted by 442Wrangler View Post
Did the Jeep come on when turning the keys or was it completely dead? Did the starter click or did nothing happen? Did you disconnect any wires during the thermostat change?

Just trying to get a better picture.
Everything came on when turning the key and it was cranking over and over and over without firing, started wasn't just clicking it (def not dead battery). I didn't get around to changing the thermostat because when I got outside to go get the part the Jeep wouldn't kick over.

No problem, thanks for the concern
Tanimal is offline  
post #157 of 409 Old 02-21-2013, 01:38 PM
442Wrangler
In like Flynn.
 
442Wrangler's Avatar
2008 JK Wrangler 
 
Join Date: Dec 2008
Location: Little Lamplight
Posts: 2,278
Quote:
Originally Posted by Tanimal View Post
Everything came on when turning the key and it was cranking over and over and over without firing, started wasn't just clicking it (def not dead battery). I didn't get around to changing the thermostat because when I got outside to go get the part the Jeep wouldn't kick over.

No problem, thanks for the concern
Ok well my first instinct was a dead starter because I didn't know all the answers to my questions but now I'm thinking you have a bad sensor (if the engine is getting gas, would have to check the fuel rail check valve, and spark). I'm thinking it relates to the code thrown earlier that just went away.

Edit: You never said it was gone, just the throttle control sensor light. And if you didn't know, you can always have autozone run the check engine light for free. I don't know if you did, but once again just trying to help.

2008 JK Rubicon
-255/80/17 BFG KM2s, 16/59 JKU springs, 2013 Rubi rims, RC stubby hybrid front bumper, XRC8 winch with synthetic line, RR evap skid, and more to come

1959 Willys Wagon
-Going to be restored and painted Plantation White and Presidential Red


"I would rather wake up in the middle of nowhere than in any city on earth."
-Steve McQueen
442Wrangler is offline  
post #158 of 409 Old 02-21-2013, 04:19 PM
Filthy-Beast
Registered User
2006 LJ Wrangler 
 
Join Date: Aug 2009
Location: Palatine
Posts: 2,332
Quote:
Originally Posted by Tanimal View Post
Not happy about having to take it to the shop but it's beyond my minor mechanical abilities. Snow storm is coming tonight and I don't get to play now but I'll keep updates on this thread in case someone else has similar issues.
That sucks! hope it's simple and you're back on the road soon.

13 JKUR Build thread

For Sale: 2013 4dr JK Painted black Hard Top JKUR 18/59 springs and shocks

97 TJ: daughter 1 - 2.5L, Auto, 2" BB, 31" GY Duratrac
98 TJ: Daugher 2 - 4.0L, 5spd, D44 rear
06 LJ Rubicon: mine - Rokmen full up-armor, 8 adjustable CAs, front bumper, sliders, corners, Shrockworks rear bumper, 3" AEV/BDS lift, Currie HD stearing and Antirock, MT/r - k 35x12.5, SuperWinch, MC Overlines, York OBA
13 JKU Rubicon: Wife's for now, Ace Rock rails & rear bumper tire carrier, Truck Lites, MC Game changer 3.5 lift, RR skids, PSC Brawler front bumper, Warn 9.5cti-s, 35" GY MTRs
Filthy-Beast is offline  
post #159 of 409 Old 02-22-2013, 01:33 PM Thread Starter
Tanimal
Registered User
2008 JK Wrangler 
 
Join Date: Jan 2012
Location: Bartlett
Posts: 1,449
Quote:
Originally Posted by 442Wrangler View Post
Ok well my first instinct was a dead starter because I didn't know all the answers to my questions but now I'm thinking you have a bad sensor (if the engine is getting gas, would have to check the fuel rail check valve, and spark). I'm thinking it relates to the code thrown earlier that just went away.

Edit: You never said it was gone, just the throttle control sensor light. And if you didn't know, you can always have autozone run the check engine light for free. I don't know if you did, but once again just trying to help.
Quote:
Originally Posted by Filthy-Beast View Post
That sucks! hope it's simple and you're back on the road soon.
So far the problem seemed to be a coolant temperature sensor. Would make sense, Jeep wouldn't start because it thought it was 1 billion degrees. Hopefully this is the fix. Very mad at myself because it's a 10 dollar part....
Tanimal is offline  
post #160 of 409 Old 02-22-2013, 05:05 PM
TheBoss
Registered User
2012 JK Wrangler 
 
Join Date: May 2010
Posts: 1,949
Hopefully you get it back before the snow melts.
TheBoss is offline  
post #161 of 409 Old 02-22-2013, 09:04 PM
awinski
Registered User
2012 JK Wrangler 
 
Join Date: Feb 2012
Location: Gap
Posts: 2,961
hope it fixes it!

The ONLY chlorophyll JK
one more horse power than the average pentastar; http://www.jeepforum.com/forum/f22/p...-build-2157673
twitter/IG - @Becauseracejeep
awinski is offline  
post #162 of 409 Old 02-23-2013, 09:48 AM Thread Starter
Tanimal
Registered User
2008 JK Wrangler 
 
Join Date: Jan 2012
Location: Bartlett
Posts: 1,449
Quote:
Originally Posted by TheBoss View Post
Hopefully you get it back before the snow melts.
Quote:
Originally Posted by awinski View Post
hope it fixes it!
Seems to have fixed it. Unfortunately didn't get to play in the snow but that's ok.
Tanimal is offline  
post #163 of 409 Old 02-23-2013, 01:05 PM
mrwhipple
Registered User
2012 JK Wrangler 
 
Join Date: Oct 2010
Location: LA
Posts: 832
awesome. down time always sucks.

silver jkur
mrwhipple is offline  
post #164 of 409 Old 02-26-2013, 06:35 AM
BigBlue7
Registered User
2010 JK Wrangler 
 
Join Date: Dec 2011
Location: Huntsville
Posts: 2,033
It's always the simple problems that cause the most grief. Glad to hear your up and running!

Rock Krawler | TeraFlex | Synergy | Fox | Poison Spyder | Genright | Nemesis |Beer
BigBlue7 is offline  
post #165 of 409 Old 02-28-2013, 03:21 PM Thread Starter
Tanimal
Registered User
2008 JK Wrangler 
 
Join Date: Jan 2012
Location: Bartlett
Posts: 1,449
Was running into 7-11 really quick and saw an opportunity to goof around a bit so I climbed the hill and stuffed my rear wheel all the way into the wheel well. Made me realize I need flat fenders, I don't need to cut my pinch seam and people really need to get out more. Had a couple people come out from 7-11 asking if it was my Jeep and started taking pictures, since they thought it was so cool I snapped a couple and decided to share



Tanimal is offline  
Reply

Tags
monstaliner , poison spyder , rock krawler , rugged ridge snorkel , teraflex tire carrier

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
More of a Tinkering Thread than a Build Thread (smcutter) smcutter JK Wrangler Technical Forum 204 01-05-2016 11:54 AM
Joe's 2008 Rubicon Unlimited Build Thread DiscoBayJoe JK Wrangler Technical Forum 17 08-25-2014 02:54 AM
2008 jeep wrangler unlimited build lift and customization garettt520 JK Wrangler Technical Forum 10 07-23-2012 02:54 PM
2008 3.8 l engine build code location herath JK Wrangler Technical Forum 2 03-16-2011 06:22 PM
2008 Jeep JK Rubicon Unlimited build Thread VegasJeep JK Wrangler Technical Forum 23 07-01-2008 12:51 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome