She's drainging batteries! - JeepForum.com

 
LinkBack Thread Tools
post #1 of 6 Old 06-21-2013, 10:03 AM Thread Starter
SassySimone
Registered User
2008 JK Wrangler 
 
Join Date: Jun 2013
Location: Owings
Posts: 2
She's drainging batteries!

I bought my 2008 JK in July 2011. Since then i have replaced the battery probably 4 times. They last an average of about 6 month, then the car doesn't start and they come up as dead cells. At times she won't start, doesn't have anything to do with weather, time of day, how long since last start, anything. You can try and start it 11 times and it wont start, try once more and it starts up like nothing is wrong. One working theory is that the battery cables have a short in them somewhere, but i work close to 60 hours a week, putting the truck in for a week of diagnostic and repair screws me!

I few weeks ago when she didn't start, i turned off everything, stereo, unplugged the phone charger (nothing was plugged into it), and waited 3 mins and it started right up.

I just don't know what else to do, the different mechanics just tell me "the batteries dead" well duh! i need to know WHY the battery is dead! i'd rather spend the money to get it fixed once then to keep buying batteries.

Any suggestions would be wonderful! Thank you!

SassySimone is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 06-21-2013, 11:47 AM
NCSahara
Registered User
2006 KJ Liberty 
 
Join Date: Apr 2013
Location: FRANKLINTON
Posts: 39
Check engine light?
NCSahara is offline  
post #3 of 6 Old 06-21-2013, 11:53 AM Thread Starter
SassySimone
Registered User
2008 JK Wrangler 
 
Join Date: Jun 2013
Location: Owings
Posts: 2
Nope, no light on.
SassySimone is offline  
post #4 of 6 Old 06-21-2013, 12:31 PM
Waltjason
Registered User
2011 JK Wrangler 
 
Join Date: Dec 2010
Location: Waynesville
Posts: 194
I would check the alternator and the cables.
Waltjason is offline  
post #5 of 6 Old 06-21-2013, 12:32 PM
NCSahara
Registered User
2006 KJ Liberty 
 
Join Date: Apr 2013
Location: FRANKLINTON
Posts: 39
What is after market?lights,radio etc.. Something is drawing current or not grounded properly.
NCSahara is offline  
post #6 of 6 Old 06-21-2013, 12:58 PM
jwmbishop
Accidental Obfuscator
 
jwmbishop's Avatar
2011 JK Wrangler 
 
Join Date: May 2011
Location: Corsicana, TX
Posts: 6,792
check all cables. Bad grounds, corrosion etc can do this.

J Wm Bishop EA, ASADE
The wagon should, of course, be as light as possible, but strength should not be sacrificed to lightness, for on any but the regularly traveled roads, the wagon will get many a
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
...
jwmbishop is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome