Rad cap not holding pressure - JeepForum.com

LinkBack Thread Tools
post #1 of 3 Old 06-15-2013, 02:46 PM Thread Starter
Registered User
2010 JK Wrangler 
Join Date: Oct 2012
Location: Edmonton
Posts: 155
Rad cap not holding pressure

So had a check up at the dealer. I pop in every 25-30k just to make sure everything is ok cause I'm far from perfect.
But to cut to the chase they sad my rad cap wasn't holding pressure causing me to lose precious rad fluid. Has anyone else had this happen?

Gane35 is offline  
Sponsored Links
post #2 of 3 Old 06-15-2013, 03:38 PM
Registered User
Join Date: Feb 2012
Location: morgantown
Posts: 64
it happened to me. i went to advanced auto parts or autozone and bought a new one for less then 20.00 bucks. just make sure you read what the cap states for PSI. also conform with the parts store. The guy at advanced tried to give me the wrong part and i had to take him outside to show him what the cap said.
tonka_yellow is offline  
post #3 of 3 Old 06-16-2013, 04:09 AM Thread Starter
Registered User
2010 JK Wrangler 
Join Date: Oct 2012
Location: Edmonton
Posts: 155
Yeah that's what I did. Ran it for a good 400km nothing leaked. I'll keep an eye on it see what happens
Gane35 is offline  

Quick Reply

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome