Passenger door doesn't trigger interior light. - JeepForum.com

 
LinkBack Thread Tools
post #1 of 11 Old 01-21-2013, 11:33 AM Thread Starter
jdrames
Registered User
 
Join Date: Jan 2013
Location: Hancock
Posts: 6
Passenger door doesn't trigger interior light.

I tried searching this forum and google but couldn't seem to find anything matching my situation.

I have a 2011 JK Unlimited Sport and the passenger side door will not trigger the interior light when opened. It also will not unlock automatically. However the lock button for unlocking and locking all the doors thats located on the passenger door works fine as does the power windows. I've disconnected and reconnected the socket under the dash thinking perhaps it wasn't seated correctly. But that didn't fix anything. I'm wondering if there is a connector in the door that might be causing an issue? Something that controls the actual electronic locking mechanism in the door and also the interior light switch.

But wanted to see if that was even possible before I went tearing my door apart in search of said things.

jdrames is offline  
Sponsored Links
Advertisement
 
post #2 of 11 Old 01-21-2013, 11:43 AM
ronjenx
Web Wheeler
 
ronjenx's Avatar
2008 JK Wrangler 
 
Join Date: Jan 2009
Location: Maine
Posts: 4,654
When you say " However the lock button for unlocking and locking all the doors thats located on the passenger door works fine", do you mean the passenger door does, or does not, unlock when using the button on the passenger's door?

Does it lock with the rest of them?
ronjenx is offline  
post #3 of 11 Old 01-21-2013, 11:53 AM
coptered
Registered User
2011 JK Wrangler 
 
Join Date: Dec 2004
Location: Harvest
Posts: 25
I had a broken wire in the disconnect plug that caused that on my 2011 Rubicon. The dealer tried to say it was the wiring for my windshield lights, but after 4 trips to the dealer I found a schematic online and I believe it was the purple wire in the connector was broken and when I was checking the pins that one just pulled out of the plug. The dealer replaced the harness when I took it back to them.

2011 Flame Red Rubicon Unlimited
coptered is offline  
post #4 of 11 Old 01-21-2013, 11:58 AM Thread Starter
jdrames
Registered User
 
Join Date: Jan 2013
Location: Hancock
Posts: 6
There is the (a)manual lock for the door itself by the handle to open the door and then there is (b)the power lock button that is used to lock/unlock all the doors.

I am talking about (b), this will unlock/lock all the doors except obviously the passenger door. No electronic/automatic method works for unlocking the passenger door. So I have to either reach across the center console and unlock it using the (a) manual lock switch or unlock it using the key at the door.
jdrames is offline  
post #5 of 11 Old 01-21-2013, 12:08 PM Thread Starter
jdrames
Registered User
 
Join Date: Jan 2013
Location: Hancock
Posts: 6
Quote:
Originally Posted by coptered View Post
I had a broken wire in the disconnect plug that caused that on my 2011 Rubicon. The dealer tried to say it was the wiring for my windshield lights, but after 4 trips to the dealer I found a schematic online and I believe it was the purple wire in the connector was broken and when I was checking the pins that one just pulled out of the plug. The dealer replaced the harness when I took it back to them.
Was that on the door connector portion or the connector under the dash?
jdrames is offline  
post #6 of 11 Old 01-21-2013, 04:42 PM Thread Starter
jdrames
Registered User
 
Join Date: Jan 2013
Location: Hancock
Posts: 6
Checked the pins on the connector at the door and they all seem to be fine. So back to wondering if there is a harness inside.

Also as a side note:
1) the door ajar light does not come on for that door.
2) the dome light does not turn on when the door is opened.
3) When the handle is used to open the door it doesn't unlock all the rest of the doors like when it is functioning normally.
jdrames is offline  
post #7 of 11 Old 01-21-2013, 04:49 PM
ronjenx
Web Wheeler
 
ronjenx's Avatar
2008 JK Wrangler 
 
Join Date: Jan 2009
Location: Maine
Posts: 4,654
Quote:
Originally Posted by jdrames View Post
Checked the pins on the connector at the door and they all seem to be fine. So back to wondering if there is a harness inside.

Also as a side note:
1) the door ajar light does not come on for that door.
2) the dome light does not turn on when the door is opened.
3) When the handle is used to open the door it doesn't unlock all the rest of the doors like when it is functioning normally.
There is a harness connector on the lock mechanism inside the door.
The connector has 4 pins for the door ajar switch, and the lock/unlock actuator.

Position Number and Wire Color:
1 TAN/BROWN - PASSENGER DOOR LOCK DRIVER
2 LIGHT GRAY/GRAY - PASSENGER DOOR UNLOCK DRIVER
3 VIOLET/WHITE - PASSENGER DOOR AJAR SWITCH SENSE
4 BLACK/WHITE - GROUND
ronjenx is offline  
post #8 of 11 Old 01-21-2013, 05:04 PM Thread Starter
jdrames
Registered User
 
Join Date: Jan 2013
Location: Hancock
Posts: 6
Thanks ronjenx. Looks like I'll be pulling the door off and working in the shop tonight to see if that connector has some how disconnected or if the wires inside the door have got frayed.
jdrames is offline  
post #9 of 11 Old 01-22-2013, 01:49 PM
COLOUXJ
Registered User
2010 JK Wrangler 
 
Join Date: Mar 2009
Location: Colorado Springs
Posts: 2,046
I have this same problem with my driver door, only difference is that it is only the door ajar switch that is not responding. I have swapped doors with someone else and that did not fix the problem. Does anyone else have information on the harness replacement?


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
COLOUXJ is offline  
post #10 of 11 Old 01-28-2013, 11:44 AM Thread Starter
jdrames
Registered User
 
Join Date: Jan 2013
Location: Hancock
Posts: 6
It was indeed the interior wire harness. The harness wasn't even routed through the opening to the latch at all. I'm thinking this was a something that got half-a$$ed when I had my door replaced a year ago after offroading and didn't notice until now.

Thanks ronjenx for the information.
jdrames is offline  
post #11 of 11 Old 01-28-2013, 11:50 AM
ronjenx
Web Wheeler
 
ronjenx's Avatar
2008 JK Wrangler 
 
Join Date: Jan 2009
Location: Maine
Posts: 4,654
Quote:
Originally Posted by jdrames View Post
It was indeed the interior wire harness. The harness wasn't even routed through the opening to the latch at all. I'm thinking this was a something that got half-a$$ed when I had my door replaced a year ago after offroading and didn't notice until now.

Thanks ronjenx for the information.
Glad you got it fixed.

How hard was it to get to the point you could see what was wrong?
I have always dreaded working on vehicle doors.
ronjenx is offline  
Reply

Tags
door , light , lock mechanism

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome