Reply
 
LinkBack Thread Tools
post #1 of Old 01-16-2008, 07:38 PM Thread Starter
rayzordee
Registered User
 
rayzordee's Avatar
2008 JK Wrangler 
 
Join Date: Aug 2007
Location: Washington, CT
Posts: 532
Only 2400 miles and computer says "Change Oil"

Has anyone had the computer throw the "change oil" indicator this soon?
Seems like it's early.


Sahara 4dr, Jeep Green
Loaded...the Jeep not me.
rayzordee is offline  
post #2 of Old 01-16-2008, 07:42 PM
Prot
Web Wheeler
 
Prot's Avatar
2014 JK Wrangler 
 
Join Date: Feb 2007
Location: Lafayette
Posts: 7,914
Do you have stock tires and gears?

2014 JKU Copperhead Pearl
Too many mods to list. Too awesome to sell.
Prot is offline  
post #3 of Old 01-17-2008, 12:00 AM
Mr.Unlimited
Registered User
2015 JK Wrangler 
 
Join Date: Jul 2007
Location: Windsor
Posts: 345
Quote:
Originally Posted by rayzordee
Has anyone had the computer throw the "change oil" indicator this soon?
Seems like it's early.
Yes, mine has done this twice. That means 2 oil changes already. I was told it was driving habits. The manual service states changing oil every 10000 km or in your case every 6000 miles. It actually doubled the service schedule. My driving habits are always the same or at least the wifes is too. I just had my oil done 2 days ago but the indicator told me to do it 600 km ago. I just ignored the stupid thing at start-ups for a while. It isn't going to hurt anything. I still will take it in no matter what and have them change the oil evry 5000km/3000miles. To me, its a pain in the @ss. This new feature is new on a all 08 chrysler/Jeep/ Dodge vehicles. GM has had this feature for a while now, so I am told.

2015 Sah.Unl. 3.73 gears Ultra Gauntlet black wheels,
1 1/2 spacers, Hercules Trail Digger M/T
Mr.Unlimited is offline  
post #4 of Old 01-17-2008, 02:58 AM
08blkrubi
Registered User
2008 JK Wrangler 
 
Join Date: Aug 2007
Location: pa
Posts: 96
Yup, mine just flashed on today. I also plan to do my changes every 3000....

08 Black Rubicon, 2-Door, Auto, Soft-Top, 24R, 6-Disc, Deep Tint, Pwr Conv.

3" Black Diamomd, 315/75r-16 Goodyear MT/R's, 16" AEV Bridger, Hanson Frt armor / Fab Four rear armor, WARN 9.0/Rc, Shrockworks Side Armor, Tom Woods Drive Shafts, Bilstein 5100 Shocks
08blkrubi is offline  
post #5 of Old 01-17-2008, 05:53 AM
JMcA
Registered User
2008 JK Wrangler 
 
Join Date: Oct 2007
Location: Louisville, KY
Posts: 13
Quote:
Originally Posted by rayzordee
Has anyone had the computer throw the "change oil" indicator this soon?
Seems like it's early.
Man...mine came up the first time at just over 6000km, what type of driving do you do in yours?

My driving habits may be close to perfect for stretching the time between oil changes. I have about a 50 mile round-trip to work that's almost completely inter-state driving.

Jeff
JMcA is offline  
post #6 of Old 01-17-2008, 06:07 AM
RobMac216
Registered User
 
Join Date: Oct 2007
Location: Boston
Posts: 13
mine came on the other day at 2500 miles....i already had an appointment for the 24th so i didn't care....i will hit the 3 month mark before mileage....and my oil changes are free from the dealer, so it doesn't affect me to get it done early....oh and they are going to attempt to fix the leak in the freedom top....we will see about that
RobMac216 is offline  
post #7 of Old 01-17-2008, 07:35 AM
ARTSBEST
Registered User
 
Join Date: Oct 2007
Location: NAPERVILLE
Posts: 205
I'd change it every 2K anyway. I've done this with every new vehicle I've ever had and thel ALL ran to 200K. Oil changes are cheap to do and take very little time.
ARTSBEST is offline  
post #8 of Old 01-17-2008, 08:15 AM
Racer83L
Registered User
2014 WK 
 
Join Date: Sep 2007
Location: Long Island, NY
Posts: 255
my change oil light came on for the first time ever at 5,800 miles..

The oil in it was changed at 3,450, and I since changed it again at 6,045.

I do believe it is gauged by driving habit, Im 90% highway and took the JK offroad only about 7 times. Maybe pressed the pedal to the floor twice so far.

Current- 14 White Altitude, 5.2 ZJ, past - 08 JKU lifted gears etc, 91 YJ lifted etc
Racer83L is offline  
post #9 of Old 01-17-2008, 08:48 AM
webhannet
Registered User
2008 JK Wrangler 
 
Join Date: Nov 2007
Location: Maine/Florida
Posts: 79
2500 miles here. Fine by me - I had been meaning to do it. I always change at 3000.
webhannet is offline  
post #10 of Old 01-17-2008, 12:00 PM
MiamiPaco
Registered User
2007 JK Wrangler 
 
Join Date: Dec 2007
Location: Miami, Fl
Posts: 366
There are enough threads here in re when to change and what to use filter and oil-wise. Do as you feel, but keep in mind your warranty. That said, to get rid of the idiot light: Turn key to "On" position (don't start jeep), within 10 seconds apply gas pedal 3 times, not super fast or slow, you have 10 seconds, turn key to off. Try it now, light should be gone. If not, try again. If after 4th try it hasn't worked, run 3x around car naked at exactly 3:13pm on a Sunday while muttering curses under your breath. Your neighbors will have you Baker-Acted and you won't have to worry about the light anymore..
MiamiPaco is offline  
post #11 of Old 01-17-2008, 01:59 PM
Sammer
Registered User
 
Join Date: Dec 2006
Location: North Wales, PA
Posts: 94
Mine came on at 2500 miles. I just figured that they programmed it that way at the factory. My Nissan Murano allows you to set different intervals for this alarm to pop up.

2008 Rescue Green 2 Door X
'95 YJ - SOLD
Sammer is offline  
post #12 of Old 01-17-2008, 02:26 PM
ARTSBEST
Registered User
 
Join Date: Oct 2007
Location: NAPERVILLE
Posts: 205
MiamiPaco. Good one.
ARTSBEST is offline  
post #13 of Old 01-17-2008, 06:17 PM
JMcA
Registered User
2008 JK Wrangler 
 
Join Date: Oct 2007
Location: Louisville, KY
Posts: 13
Quote:
Originally Posted by JMcA
Man...mine came up the first time at just over 6000km, what type of driving do you do in yours?

My driving habits may be close to perfect for stretching the time between oil changes. I have about a 50 mile round-trip to work that's almost completely inter-state driving.

Jeff
Gah...where I come out with the "km"? I meant, miles.

Jeff
JMcA is offline  
post #14 of Old 01-17-2008, 06:22 PM
releve
Registered User
 
releve's Avatar
2007 JK Wrangler 
 
Join Date: Nov 2007
Location: Miami, FL
Posts: 155
i guess mine isn't working. I have changed my oil twic at 3,000 mile intervals and the thing hasn't said a thing once.

Is it possible that it has been disabled?

Rey
Miami, Florida


2007 Wrangler Unltd X 4x2 Four Door Soft Top ║ Detonator Yellow ║ 3.8 V6 ║ 6 speed transmission ║ Skyjacker 2.5" Lift ║ 17" Eagle Alloy Series 1378 Sim Beadlock ║ MT Baja MTZ 35x12 5R17 ║ Bushwacker Pocket Fender Flairs ║Volant CAI ║ Borla Cat Back Dual Exhaust ║ Fab Four Front Bumper ║
releve is offline  
post #15 of Old 01-17-2008, 06:41 PM
08blkrubi
Registered User
2008 JK Wrangler 
 
Join Date: Aug 2007
Location: pa
Posts: 96
Quote:
Originally Posted by releve
i guess mine isn't working. I have changed my oil twic at 3,000 mile intervals and the thing hasn't said a thing once.

Is it possible that it has been disabled?
new on 08.....yes

08 Black Rubicon, 2-Door, Auto, Soft-Top, 24R, 6-Disc, Deep Tint, Pwr Conv.

3" Black Diamomd, 315/75r-16 Goodyear MT/R's, 16" AEV Bridger, Hanson Frt armor / Fab Four rear armor, WARN 9.0/Rc, Shrockworks Side Armor, Tom Woods Drive Shafts, Bilstein 5100 Shocks
08blkrubi is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
"Engine Malfunction" light at 1005 miles! k-n-j's jk JK Wrangler Technical Forum 10 02-13-2008 11:13 PM
Resetting "Miles to service" Indicator? thommo41 TJ Wrangler Technical Forum 2 04-17-2006 08:41 AM
Engine still "breaking in" at 24,000 miles? RAAB3485 TJ Wrangler Technical Forum 8 02-14-2006 12:39 AM
Feel "clunk" through steering column when you change from Accel to Decel or opposite Mark_ZZ3 YJ Wrangler Technical Forum 5 04-13-2005 08:04 AM
2002 tj with 10 miles has water leak "update" THEKNEEBITER TJ Wrangler Technical Forum 2 04-28-2002 08:07 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome