MyGIG Radio is frozen...please help. - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Wrangler Forums > JK Wrangler Technical Forum > MyGIG Radio is frozen...please help.

Cess Recovery Gear Snatch Tow Strap OffRoad @ ROCKRIDGE4WDGEARSHADE Pocket Tops in stock and available at ROCKRIDGE Engo winches available at www.rockridge4wd.com! Free shipp

Reply
Unread 01-28-2012, 04:07 PM   #1
J90210
Registered User
2008 JK Wrangler 
 
Join Date: Jan 2012
Location: Westfield, NJ
Posts: 9
MyGIG Radio is frozen...please help.

Hello,

MyGIG radio is stuck. On the screen is the screen saver that says JEEP. It goes on and off. I can't turn the radio, nav, or anything on. I was thinking of pulling the fuse but couldn't tell which one to pull. I also tried resetting the system by holding down a combo of the hard keys. Nothing is working....please help. Thanks!

J90210 is offline   Reply With Quote
Unread 01-28-2012, 04:08 PM   #2
jwmbishop
Registered User
2011 JK Wrangler 
 
Join Date: May 2011
Location: corsicana, tx
Posts: 3,122
Disconnect the battery for a few minutes (5 is usually enough to discharge all capacitors).
__________________
J Wm Bishop EA, ASADE
How to start an online argument - express opinion - wait.
jwmbishop is offline   Reply With Quote
Unread 01-28-2012, 04:35 PM   #3
J90210
Registered User
2008 JK Wrangler 
 
Join Date: Jan 2012
Location: Westfield, NJ
Posts: 9
Thanks man, I will give it a shot!
J90210 is offline   Reply With Quote
Unread 01-29-2012, 03:21 PM   #4
J90210
Registered User
2008 JK Wrangler 
 
Join Date: Jan 2012
Location: Westfield, NJ
Posts: 9
MyGig Radio/NAV still frozen

I went and bought a new battery and replaced the old one and it didn't reset anything. My radio is still flashing the Jeep screensaver periodically. I can't use the NAV, the radio, CD, nothing. So annoying. I have checked the fuses, tried all the reset strategies by pressing various hard keys and still nothing. If anyone has any other ideas I would love to hear them. Thanks!
J90210 is offline   Reply With Quote
Unread 02-01-2012, 11:51 AM   #5
J90210
Registered User
2008 JK Wrangler 
 
Join Date: Jan 2012
Location: Westfield, NJ
Posts: 9
So I went to two dealers and they say I will just have to get a new radio. For them to look at it is $120. I disconnected the battery for one hour today and I thought that would reset it. Still nothing. I feel like maybe there is just a loose wire or connection behind the radio? Maybe I can just pull it out and check? Does anyone know if that is difficult to do? Any help is greatly appreciated. Thank you.
J90210 is offline   Reply With Quote
Unread 02-01-2012, 12:49 PM   #6
g3cko
Registered User
2011 JK Wrangler 
 
Join Date: Dec 2006
Location: Exit 55
Posts: 134
When did it all start?
g3cko is offline   Reply With Quote
Unread 02-01-2012, 02:23 PM   #7
Spank
Registered User
2012 JK Wrangler 
 
Join Date: Jul 2007
Location: Colorado
Posts: 993
Are you leaving the MyGig on for a while? If it's a software issue, the MyGig usually does an excellent job of repairing itself, although it does take some time.

If it's a hardware issue or power, you may actually have a dying battery. My RER on my '07 used to flicker on and off and sometimes hang on the Jeep logo for a good month or so before I realized my battery was toast. After replacing the battery, the problems with the RER disappeared.
__________________
'12 Wrangler Unlimited Rubicon
Spank is offline   Reply With Quote
Unread 02-01-2012, 06:39 PM   #8
J90210
Registered User
2008 JK Wrangler 
 
Join Date: Jan 2012
Location: Westfield, NJ
Posts: 9
MyGiG Radio/NAV still frozen

This all started about 3 weeks ago. I am running out of ideas. The employees at the dealers are totally clueless. They don't want to mess with figuring out the problem but rather have me buy a new one. They want me to pay $120 just to tell me I need a new one. The deal is I built my own Rubicon in July 07 and ordered the 08. It took forever to come in because they said they were having problems installing the Mygig. After waiting several months they said they had one on their lot that is what I ordered without the Mygig but said they can order one and put it in later. I took the one on the lot and they eventually installed the myGig which worked for about 6 months and then the knob broke off. I thought they would just replace the knob but they said they will replace the entire Mygig. Anyway, they did and it's been working fine. I never updated the software. Three weeks ago I turned on the truck and the Jeep screensaver was there and would stay on for awhile and then go off and then on.....even when I turned it off and locked it up. I started taking the entire Mygig out today and I stopped because I was afraid I may break something. If anyone has any advice I would love to hear it. As I said, I replaced the battery 3 days ago as I thought that may have been the problem. I even disconnected the battery today for an hour and a half to discharge the capacitors. Nothing resets and nothing works. I have tried all the tips in the forum. I never get into engineering mode or anything....just the Jeep screen saver. Please help me. The dealer said it was 3000.00 for a new MyGig. I want to fix mine......I feel it's a simple fix but can't figure it out. Please help me.....also if anyone knows of a place to take it in Jersey besides the dealer would be wonderful. Thanks for all the help!
J90210 is offline   Reply With Quote
Unread 03-24-2012, 04:23 PM   #9
BigBlackJeepMP
Registered User
 
Join Date: Oct 2008
Location: Worcester,Ma
Posts: 1
Dont really have any advice besides that it happened to my Gf 08 Liberty and i pulled the fuse for about 20 to 60 mins and it seemed to reset it... If you have any luck with this please let me know I am dreading bringing this to the Stealership
BigBlackJeepMP is offline   Reply With Quote
Unread 03-24-2012, 04:59 PM   #10
BigNunz6
Registered User
2012 WK 
 
Join Date: Dec 2006
Location: Brooklyn, NY
Posts: 235
I bet a 5 lb sledge would fix that screen....j/k hope you get it resolved
__________________
If you like it, buy it!!!!
BigNunz6 is offline   Reply With Quote
Unread 03-25-2012, 04:53 AM   #11
DavidJeep
Registered User
2012 JK Wrangler 
 
Join Date: May 2008
Location: , New Jersey
Posts: 156
Another New Jersey Jeep dealer saga I just can't understand why they just don't bring it in and at least look at it for you for free or update it for free ??? Talk about pissing off a past,present & future customer !!!!!!
DavidJeep is offline   Reply With Quote
Unread 03-25-2012, 07:38 AM   #12
Av8terZ06
Registered User
2012 JK Wrangler 
 
Join Date: Feb 2009
Location: Houston
Posts: 114
http://mofv.com/mygig/


you can go to this website and download the software and burn it to disc. You can also try and get into the engineer area and reformat the mygig which will reload it to factory specs again. Anyway, there is a lot of information on this site that should determine if its just a software issue or if its really fried.
__________________
2012 Jeep Wrangler Unlimited "Call Of Duty"
2007 Corvette Z06

2009 Jeep Wrangler Unlimited Sahara - Sold
1994 Jeep Wrangler Renegade - Sold
Av8terZ06 is offline   Reply With Quote
Unread 11-05-2012, 09:54 PM   #13
JudeAz
Registered User
1988 MJ Comanche 
 
Join Date: May 2012
Location: Paradise Valley, Az
Posts: 2
The same thing is happening to my 07 Sahara. I will try the website and let you know
JudeAz is offline   Reply With Quote
Unread 03-28-2014, 01:12 AM   #14
Jeepowner21404
Registered User
2008 YJ Wrangler 
 
Join Date: Mar 2014
Location: Twin Lakes, Wisconsin
Posts: 1
I am having the same problem with my Mygig RER 730N. I have tried everything except the battery replacement. But i ended up replaceing the Mygig with some other cheap aftermarket radio as i could not find a solution to this short of spending 3k at the dealer. I did the swap almost a year ago but have been trying to figure this out since. If anyone know anymore information on this or has any pointers it would be great. Basically the radio powers on and shows the Jeep logo then turns off. It does this over and over and over again the entire time the car is on. Even after a year it still infuriates me. Please Help.
Jeepowner21404 is offline   Reply With Quote
Unread 04-23-2014, 09:11 PM   #15
swbca
Registered User
 
Join Date: Jan 2013
Location: edina, mn
Posts: 6
Quote:
Originally Posted by Jeepowner21404 View Post
If anyone know anymore information on this or has any pointers it would be great. Basically the radio powers on and shows the Jeep logo then turns off. Please Help.
There is a diagnostic test you can do to find out if your hard drive is causing the reboot-loop or if its caused by corruption in your firmware. You have about a 50/50 chance of fixing it by replacing the hard drive. The test will tell you if the hard drive is causing the reboot loop.

This web site also has a replacement drive for $135.00 if the test proves that your hard drive is the problem.

This is page to the test - instructions included.

http://mygig-disk.com/loop-test.php

Last edited by swbca; 04-24-2014 at 07:15 AM..
swbca is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.