MyGig navigation not working - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Wrangler Forums > JK Wrangler Technical Forum > MyGig navigation not working

Savvy/Currie Aluminum Control ArmsROCK BOTTOM prices on LIFT KITS at Rockridge4wd!! WANT TO December Specials at Jeephut.com

Reply
Unread 07-15-2013, 06:05 PM   #1
calgonix
Registered User
2013 JK Wrangler 
 
Join Date: Apr 2005
Location: Plum, PA
Posts: 37
MyGig navigation not working

Hi all. I'm relatively new to my 2013 Jeep Wrangler. I've been in CJ's most of my life, but recently wanted something a little newer. But, that's not why I'm here.

My 2013 Sahara has the 430N/RHB. It has one troubling, random problem. For no apparent reason, when I try to use the Navigation sometimes, the screen stays black with only the "Hide Navi" button at the bottom of the screen and I can't access it. I also can't get Sirius Travel Link info to download (stuck in a "downloading local information" screen). The Sirius music is fine, and the rest of the radio works perfectly.

The worst part is the randomness. It doesn't seem to matter if it is in motion/stopped, doors are open/closed, parking brake on/off, or any other safety feature I can imagine. And it might work fine for today, screw up tomorrow, work fine on Wednesday morning, and then act up Wednesday afternoon.

I sort of want to restore to factory defaults in the menu, but I'm not sure if it may mess something up. I would also like to trouble shoot it myself if possible due to the distance I am from the dealer.

Any input or past experience with this? I've tried Google and searching here and not having much luck. I appreciate any thoughts on this, especially if I'm missing something.

calgonix is offline   Reply With Quote Quick reply to this message
Unread 02-10-2014, 09:10 AM   #2
jzjeep
Registered User
 
Join Date: Feb 2014
Posts: 3
I just bought a 2013 2 door wrangler Moab edition with less them 3000 miles and I am having this exact problem with my navigation, does anyone have any ideas?
jzjeep is offline   Reply With Quote Quick reply to this message
Unread 02-10-2014, 08:24 PM   #3
Goose346
Registered User
2010 JK Wrangler 
 
Join Date: Dec 2006
Location: N.E. Oakland County, Michigan
Posts: 270
There is a power issuer on the audio side that is not letting the nav system turn off properly prior to the vehicle shutting down. This could be a power issue caused by accessory draw or battery connection in delivery/assembly. See your dealer and have them order a warranty replacement.
Goose346 is offline   Reply With Quote Quick reply to this message
Unread 02-14-2014, 08:43 PM   #4
calgonix
Registered User
2013 JK Wrangler 
 
Join Date: Apr 2005
Location: Plum, PA
Posts: 37
Just as an FYI, mine was a faulty head unit. Had to be replaced at a dealer under warranty.
calgonix is offline   Reply With Quote Quick reply to this message
Unread 12-15-2014, 08:51 PM   #5
varnerme
Registered User
1995 YJ Wrangler 
 
Join Date: Dec 2006
Location: Goshen, IN
Posts: 64
Quote:
Originally Posted by calgonix
Just as an FYI, mine was a faulty head unit. Had to be replaced at a dealer under warranty.
Mine is doing the same thing. Hoping to get a resolution soon.
__________________
1995 YJ
2013 JKUR
varnerme is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.