JK heater controls - JeepForum.com
 
LinkBack Thread Tools
post #1 of 5 Old 11-05-2013, 08:01 PM Thread Starter
Raspy
Registered User
2013 JK Wrangler 
 
Join Date: Jan 2013
Location: Wellington
Posts: 6
JK heater controls

My heater controls have a mind of their own. Can't get heat to the floor or defrost without a lot of fiddling, little control over temp, always wants to blow through the dash vents.

Are any of you guys having proplems with this? What's up?

Raspy is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 11-05-2013, 08:06 PM
MikeHoncho88
Registered User
2015 JK Wrangler 
 
Join Date: Mar 2010
Location: San Diego
Posts: 360
Mine is not as bad as you describe, but it is definitely a little bit weird.

Mine randomly switches modes, or changes fan speed. But it does it so infrequent I can't get it to reproduce at the dealership.
MikeHoncho88 is offline  
post #3 of 5 Old 11-05-2013, 09:07 PM
Neo1130
Registered User
2015 JK Wrangler 
 
Join Date: Jun 2009
Location: Olympia
Posts: 1,252
You have the auto or manual controls?
Neo1130 is offline  
post #4 of 5 Old 11-06-2013, 06:40 AM
wilywillie
Web Wheeler
 
wilywillie's Avatar
2008 JK Wrangler 
 
Join Date: Jan 2009
Location: Richmond VA
Posts: 1,872
I need to turn the fan off before I switch modes. See if that helps??

I'm just here for the gasoline. --Max


http://i582.photobucket.com/albums/s...earthquake.jpg
wilywillie is offline  
post #5 of 5 Old 11-06-2013, 07:03 AM
aznjeep
Senior Member
 
aznjeep's Avatar
2014 WK 
 
Join Date: Apr 2005
Location: Albuquerque
Posts: 515
Same here.. didn't really notice during the summer months.. but now that it's cooler, I'll notice that it would blow cold air when it should be "warm" (Jeep was turned off for a few minutes--already warmed up). I noticed I have to turn the auto control knob to cold, then back to where it was for it to be warm again. This doesn't happen all the time, but will most likely happen if I leave the "air" on when turning the Jeep off. It has not happened to me if I remember to turn the fan off before turning the Jeep off (but then... what's the point of having remote start?)

*edit: as far as "direction/mode", that part hasn't happened to me as of yet...

-Ken
'96 XJ Sport
'14 WK2 Overland EcoDiesel
'13 JKUR 10A (sold) Build Thread
'10 JKUR (sold) Build Thread
'99 TJ (sold)
aznjeep is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome