How many have Pentastar engines that are OK? - Page 17 - JeepForum.com

 
LinkBack Thread Tools
post #241 of 516 Old 07-11-2013, 01:16 PM
73azbronco
Registered User
2013 JK Wrangler 
 
Join Date: Mar 2012
Location: scottsdale
Posts: 650
Quote:
Originally Posted by 970001zj View Post
how many of you with head issues do an actual warm up ?

you know getting it to operating temp before driving it

also i have no clue about these engines so dont flame me
Modern vehicles are designed and made to be driven once started, no need to warm-up as in days of old.

Anyone who has had the P0304 code thrown and had it reset, how long did it take to come back on? I'm on one week since reset and it has not returned.

73azbronco is offline  
Sponsored Links
Advertisement
 
post #242 of 516 Old 07-11-2013, 02:49 PM
REPPO
Registered User
2013 JK Wrangler 
 
Join Date: Apr 2013
Location: Ashburn
Posts: 78
Sorry but, where does the code show up?
REPPO is offline  
post #243 of 516 Old 07-11-2013, 03:00 PM
blackjeep05
Registered User
2008 JK Wrangler 
 
Join Date: Sep 2012
Location: mckinney
Posts: 1,456
2005 4.0L 103k no problems runs like a champ. Sold a 98 Sahara 4.0L a few months back 255k no engine work except a rear main seal at 200k. Both engines have more than enough torque and power and can actually stay in one piece but, the rest of the Jeep is marginal lol. When AMC made Jeep engines especially the inlines they were solid.

Soccer six in the mix.
blackjeep05 is offline  
post #244 of 516 Old 07-11-2013, 06:54 PM
snobank
Registered User
2012 JK Wrangler 
 
Join Date: Jun 2010
Location: Southeastern ma....
Posts: 137
My penstar is better than OK...its Greeeeaaaat!
snobank is offline  
post #245 of 516 Old 07-12-2013, 05:26 AM
bogleparsons
Registered User
2013 JK Wrangler 
 
Join Date: May 2011
Location: fayetteville
Posts: 1,960
1500 miles and hasn't blown up yet!

Actually love the power of this thing...

If it's not supposed to move and does use duct tape.
If it's supposed to move and doesn't use WD40
bogleparsons is offline  
post #246 of 516 Old 07-12-2013, 04:24 PM
NIUPonyBoy
Registered User
 
NIUPonyBoy's Avatar
2007 JK Wrangler 
 
Join Date: Oct 2003
Location: wausau
Posts: 940
****. Me.


'15 Expedition EL, '12 Outback,'07 JK, '06 Mustang GT, '05 PowerWagon,'05 Freestar, '02 Yamaha
NIUPonyBoy is offline  
post #247 of 516 Old 07-13-2013, 10:19 AM
970001zj
Registered User
1997 ZJ 
 
Join Date: Feb 2012
Posts: 2,738
Garage
Quote:
Originally Posted by 73azbronco View Post
Modern vehicles are designed and made to be driven once started, no need to warm-up as in days of old.
sure they are , .

ive got this sweet bridge in ...

97 zj orvis/04 wj ltd/02 lancer oz rally/85 rx7 gs
970001zj is online now  
post #248 of 516 Old 07-14-2013, 09:43 AM
wshearrer
Registered User
2012 JK Wrangler 
 
Join Date: May 2011
Location: wagoner
Posts: 12
I have 43000 on my 2012 jk. No codes only issue is water pump started squeaking about a week ago, the dealer confirmed and said it was part of the powertrain warranty they are on backorder they explained on the 2013 they are told to drain and replace coolant then replace pump if that fails. They must be having some issues with the pumps.
wshearrer is offline  
post #249 of 516 Old 07-14-2013, 09:59 AM
brianjw
Registered User
2012 JK Wrangler 
 
Join Date: Apr 2012
Location: Hillsboro
Posts: 1,366
Quote:
Originally Posted by wshearrer
I have 43000 on my 2012 jk. No codes only issue is water pump started squeaking about a week ago, the dealer confirmed and said it was part of the powertrain warranty they are on backorder they explained on the 2013 they are told to drain and replace coolant then replace pump if that fails. They must be having some issues with the pumps.
****ing jeep! Worthless customer care! So they're cheap water pump begins to have a bearing failure and they're going to change the coolant and send the customer down the road for impending failure. Sounds a little like them re flashing the ecu for bad cylinder heads only to prolong the inevitable and try to make it last through the warranty period.
brianjw is offline  
post #250 of 516 Old 07-15-2013, 01:50 AM
73azbronco
Registered User
2013 JK Wrangler 
 
Join Date: Mar 2012
Location: scottsdale
Posts: 650
Quote:
Originally Posted by wshearrer View Post
I have 43000 on my 2012 jk. No codes only issue is water pump started squeaking about a week ago, the dealer confirmed and said it was part of the powertrain warranty they are on backorder they explained on the 2013 they are told to drain and replace coolant then replace pump if that fails. They must be having some issues with the pumps.
I guess I was the first guy who had this last year, took them three almost four tries, after replacing everything on the front of the motor they finally replaced the water pump and quite again. Probably cost them 4 grand in parts and labor.

So, asked again, anyone who threw a code ever had it not return after it was reset?

Codes are read by the OBDII port with a handheld scanner, you can get them from autozone as a loaner for free. You'll first get a check engine light on the dash telling you to read the OBDII info.
73azbronco is offline  
post #251 of 516 Old 07-15-2013, 06:30 AM
hydrotechtx2
Registered User
 
hydrotechtx2's Avatar
1998 TJ Wrangler 
 
Join Date: Oct 2003
Location: Central Texas
Posts: 38
I have two 2012's. One built in mid 2011 with 19k miles and one in Aug 2012 with 9k miles and both have been good motors. Time will tell.

98 Sahara w/3.5 RE Superflex, RE adjustable control arms, 33x12.5x15 XTERRAINS, 15x10 Xtreme Alloys
2012 JK Rubicon Unlimited. 2012 JK Sport.
hydrotechtx2 is offline  
post #252 of 516 Old 07-15-2013, 09:32 AM
robplumm
Registered User
2012 JK Wrangler 
 
Join Date: May 2008
Location: Newport News, VA
Posts: 849
15k, Feb 2012 build JKUR.

No issues so far...
robplumm is offline  
post #253 of 516 Old 07-17-2013, 09:28 AM
Katmandu
Registered User
2013 JK Wrangler 
 
Join Date: Aug 2005
Location: Troy, Ohio
Posts: 408
I just bought a brand new 13 KJ Sport last night.

Has Jeep rectified this issue during production or what ?


.
Katmandu is offline  
post #254 of 516 Old 07-17-2013, 11:44 AM
Utah_Jay
Registered User
2007 JK Wrangler 
 
Join Date: Nov 2010
Location: Murray
Posts: 333
Quote:
Originally Posted by Katmandu View Post
I just bought a brand new 13 KJ Sport last night.

Has Jeep rectified this issue during production or what ?

.
They claim they have fixed the issue but nobody really knows at this point. The good thing is you bought your Jeep brand new you have a warranty that will cover any problems with it. Drive it and enjoy it.

2007 JKU Sport
Utah_Jay is offline  
post #255 of 516 Old 07-17-2013, 12:29 PM
Godholio
Registered User
2012 JK Wrangler 
 
Join Date: Jan 2007
Location: West Haven
Posts: 2,033
Has anyone with a '13 complained yet? I haven't seen one.

Utah Jeep Crew #148
No powerball here? How am I supposed to finance the mods?!?
'12 Sport...miss my YJ for all the wrong reasons though
Godholio is offline  
Closed Thread

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Pentastar Price? Terrain Twister JK Wrangler Technical Forum 16 02-06-2014 04:42 PM
RIPP Pentastar dwink JK Wrangler Technical Forum 1 02-08-2012 01:03 PM
JK Pentastar 3.6 in China thejdj JK Wrangler Technical Forum 5 07-01-2011 02:52 PM
No Wrangler Pentastar? ARTSBEST Wrangler General Discussion 12 04-10-2009 01:57 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome