HELP with (ETC) light and Temperature dropping on 08 wrangler - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Wrangler Forums > JK Wrangler Technical Forum > HELP with (ETC) light and Temperature dropping on 08 wrangler

Introducing MONSTALINER™ UV Permanent DIY Roll On Bed LineSavvy Aluminum BumpersThe RuffStuff "I can't go to EJS" Sale!

Reply
Unread 02-17-2011, 02:32 PM   #1
OneBadJeep08
Registered User
 
Join Date: Feb 2011
Location: Cedartown, Geargia
Posts: 2
HELP with (ETC) light and Temperature dropping on 08 wrangler

I'm having a problem with my 2008 jeep wrangler unlimited. It Has 42000 miles and my check engine light is on. My real problem is that in regards to the Engine light while driving my ETC (electronic throttle controll light) will come on and when that happens my temp gauge goes from the 1/2 mark to 0 and my heat starts to blow cool air (when it was previously hot) which at the same time the outside fan kick on and runs. If i shut the car off the light will go out and everything returns to normal. Had a new raidator, thermostat a few months back and a new temp sensor (throwing code P0116) 3 weeks ago and still having problem. Please help!!! no one seems to know what is going on and local dealership said that my head is possibly cracked? Any suggestions?

OneBadJeep08 is offline   Reply With Quote
Unread 02-17-2011, 04:27 PM   #2
tclaremont
Registered User
2009 JK Wrangler 
 
Join Date: Jul 2009
Location: Rochester, NY
Posts: 1,241
Is your coolant level going down? You don't "consume" coolant, so if the level differs from week to week, it is going somewhere that it is not supposed to.

If the computer is acting up, sometimes disconnecting the battery for a half hour or so will reset things. Give it a try since it is free.

When you hook up a code reader, what codes do you get?
__________________
-------------------------------------
Tim C.
Rochester, NY
-------------------------------------
tclaremont is offline   Reply With Quote
Unread 03-03-2011, 07:54 AM   #3
OneBadJeep08
Registered User
 
Join Date: Feb 2011
Location: Cedartown, Geargia
Posts: 2
Coolant level good. Tried the disconect and it reset all the lights for a short time but no help. Got the jeep in the shop this week to see what may be going on, so once i know something i will post! Thanks for the reply.
OneBadJeep08 is offline   Reply With Quote
Unread 03-03-2011, 03:56 PM   #4
wilywillie
Web Wheeler
 
wilywillie's Avatar
2008 JK Wrangler 
 
Join Date: Jan 2009
Location: Charlottesville VA
Posts: 1,809

Best of luck!
My worst fear is the computer crapping out......there's no wrench that'll fit it, y'know?
__________________
I'm just here for the gasoline. --Max


http://i582.photobucket.com/albums/s...earthquake.jpg
wilywillie is offline   Reply With Quote
Unread 10-08-2011, 02:32 PM   #5
bates5
Registered User
 
Join Date: Oct 2011
Location: lansdowne, PA
Posts: 1
I'm having the same problem now with the same model jeep. Did anyone get it resolved? Afraid to go far with it. Can't keep turning the car on and off to turn light off because it only lasts 3 miles. My lights came on a few hours after my husband changed the thermostat

Last edited by bates5; 10-08-2011 at 03:12 PM..
bates5 is offline   Reply With Quote
Unread 11-04-2013, 08:38 PM   #6
SilvRSpeedX3
Registered User
2008 JK Wrangler 
 
Join Date: Jun 2006
Location: conectycut
Posts: 303
Anyone ever find an answer or fix?
__________________
2k8 Black X unlimited
Black Jeep Society
SilvRSpeedX3 is offline   Reply With Quote
Unread 02-05-2014, 08:42 PM   #7
dan73
Registered User
2008 JK Wrangler 
 
Join Date: Jan 2014
Posts: 2
Did anybody get the answer to this issue with the ETC & temp gauge dropping....
dan73 is offline   Reply With Quote
Unread 02-19-2014, 10:49 PM   #8
dan73
Registered User
2008 JK Wrangler 
 
Join Date: Jan 2014
Posts: 2
I have the same issues as the first post, what I did was replace the termostat and replaced the coolant temperture sensor. it work problem solved. Also check to see if the two wire on the sensor aren't loose, crack or shorting out.
dan73 is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.