Ck engine light - JeepForum.com
Reply
 
LinkBack Thread Tools
post #1 of 17 Old 11-24-2013, 05:47 PM Thread Starter
moemoe88
Registered User
2013 JK Wrangler 
 
Join Date: Mar 2013
Location: green valley
Posts: 14
Ck engine light

Came on at 7000 miles on my 2013 Wrangler. Reset myself twice because I thought it was the gas cap, it started first start after fillup. Had to go the dealers they said it is my oil pressure sending unit. I asked if they were absolutely sure, they said yes. Had to order the part. Plenum needs to be pulled for that. I really don't like the idea of them pulling it apart. Any comments/suggestions will be appreciated.

moemoe88 is offline  
Sponsored Links
Advertisement
 
post #2 of 17 Old 11-24-2013, 06:30 PM
ronjenx
Web Wheeler
 
ronjenx's Avatar
2008 JK Wrangler 
 
Join Date: Jan 2009
Location: Maine
Posts: 4,576
What was the code it set?
ronjenx is offline  
post #3 of 17 Old 11-24-2013, 08:09 PM Thread Starter
moemoe88
Registered User
2013 JK Wrangler 
 
Join Date: Mar 2013
Location: green valley
Posts: 14
Let's see on my receipt it says cause 100 engine 141
Does that sound like it or I don't know and didn't ask.
moemoe88 is offline  
post #4 of 17 Old 11-24-2013, 08:20 PM
ronjenx
Web Wheeler
 
ronjenx's Avatar
2008 JK Wrangler 
 
Join Date: Jan 2009
Location: Maine
Posts: 4,576
It would be a P code, such as P06DD
ronjenx is offline  
post #5 of 17 Old 11-24-2013, 10:52 PM Thread Starter
moemoe88
Registered User
2013 JK Wrangler 
 
Join Date: Mar 2013
Location: green valley
Posts: 14
It's not anywhere on the receipt.
moemoe88 is offline  
post #6 of 17 Old 11-25-2013, 09:52 AM
COLOUXJ
Web Wheeler
2010 JK Wrangler 
 
Join Date: Mar 2009
Location: Colorado Springs
Posts: 2,038
Why are you worried about them fixing it? You will pay for someone else to do it.
COLOUXJ is offline  
post #7 of 17 Old 11-25-2013, 03:14 PM Thread Starter
moemoe88
Registered User
2013 JK Wrangler 
 
Join Date: Mar 2013
Location: green valley
Posts: 14
p0520 from AutoZone

Not real worried about them fixing it, more worried that it is the problem and not something else
moemoe88 is offline  
post #8 of 17 Old 11-25-2013, 03:22 PM
COLOUXJ
Web Wheeler
2010 JK Wrangler 
 
Join Date: Mar 2009
Location: Colorado Springs
Posts: 2,038
Do you mean P0522? Im not seeing a P0520
COLOUXJ is offline  
post #9 of 17 Old 11-25-2013, 03:40 PM
psychoteen101
Registered User
1996 XJ Cherokee 
 
Join Date: Feb 2010
Location: Gurnee
Posts: 661
2013 wrangler with less than 10,000 miles is under warranty. No sense in paying someone to diagnose it, dealer will fix it for free. Bring it back to them until its fixed.

1996 Jeep Cherokee- Project-- Rusty's 8in long arm, SYE kit, Teraflex driveshaft, Cragar soft 8's 15x10 with 33x12.5 Firestone Destination MT's, Eaton Tru Trac in the front
psychoteen101 is offline  
post #10 of 17 Old 11-25-2013, 03:42 PM
COLOUXJ
Web Wheeler
2010 JK Wrangler 
 
Join Date: Mar 2009
Location: Colorado Springs
Posts: 2,038
And if it is P0522 Then thats low oil pressure, which probably mean that the sending unit is bad or you're running low on oil.
COLOUXJ is offline  
post #11 of 17 Old 11-25-2013, 04:05 PM Thread Starter
moemoe88
Registered User
2013 JK Wrangler 
 
Join Date: Mar 2013
Location: green valley
Posts: 14
Yes AutoZone is general and has about 6 or 7 possibilities for the cause including the sensor, oil pressure, etc.
Of coarse I am having the dealer fix it under warranty, just bugs me that they have to take so much of it apart with it being so simple.
moemoe88 is offline  
post #12 of 17 Old 11-25-2013, 06:45 PM
ronjenx
Web Wheeler
 
ronjenx's Avatar
2008 JK Wrangler 
 
Join Date: Jan 2009
Location: Maine
Posts: 4,576
Quote:
Originally Posted by moemoe88 View Post
p0520 from AutoZone

Not real worried about them fixing it, more worried that it is the problem and not something else
P0520-ENGINE OIL PRESSURE SENSOR CIRCUIT


When Monitored: Ignition on, engine not running.

Set Condition: The Powertrain Control Module (PCM) senses the oil pressure is out of the calibrated range. One Trip fault.

NOTE: Make sure that the engine oil is at the proper level. Also, review the customers oil change history to ensure that the oil is being changed at the correct intervals and that the proper oil viscosity is being used.


Possible Causes

ENGINE OIL PRESSURE SENSOR SIGNAL CIRCUIT SHORTED TO VOLTAGE

EXCESSIVE RESISTANCE IN THE (G6) ENGINE OIL PRESSURE SIGNAL CIRCUIT

ENGINE OIL PRESSURE SIGNAL CIRCUIT SHORTED TO GROUND

EXCESSIVE RESISTANCE IN THE (F855) 5-VOLT SUPPLY CIRCUIT

5-VOLT SUPPLY SHORTED TO GROUND

EXCESSIVE RESISTANCE IN THE (K900) SENSOR GROUND CIRCUIT

ENGINE OIL PRESSURE SENSOR

POWERTRAIN CONTROL MODULE (PCM)
ronjenx is offline  
post #13 of 17 Old 11-26-2013, 07:51 AM Thread Starter
moemoe88
Registered User
2013 JK Wrangler 
 
Join Date: Mar 2013
Location: green valley
Posts: 14
I changed the oil at 6000 miles, put 5-30 in it. I guess it called for 5-20. Wonder if that is an issue. I have been checking the web and there seem to be some issues with this function, including the oil pump. That's the kind of stuff that worry's me.
moemoe88 is offline  
post #14 of 17 Old 11-26-2013, 11:08 AM
Jiblet
Registered User
2008 JK Wrangler 
 
Join Date: Dec 2008
Location: Boston, MA
Posts: 972
Quote:
Originally Posted by moemoe88
I changed the oil at 6000 miles, put 5-30 in it. I guess it called for 5-20. Wonder if that is an issue. I have been checking the web and there seem to be some issues with this function, including the oil pump. That's the kind of stuff that worry's me.
People run 0w-40 without problems.
Jiblet is offline  
post #15 of 17 Old 11-26-2013, 11:52 AM
psychoteen101
Registered User
1996 XJ Cherokee 
 
Join Date: Feb 2010
Location: Gurnee
Posts: 661
Bring it back to the dealer. If its still under warranty and you or another shop messes with it, they can void the warranty. Make sure they verify with a mechanical gauge the oil pressure is within specification.

1996 Jeep Cherokee- Project-- Rusty's 8in long arm, SYE kit, Teraflex driveshaft, Cragar soft 8's 15x10 with 33x12.5 Firestone Destination MT's, Eaton Tru Trac in the front
psychoteen101 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome