Check engine light will not reset. - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Wrangler Forums > JK Wrangler Technical Forum > Check engine light will not reset.

ROCK BOTTOM prices on LIFT KITS at Rockridge4wd!! WANT TO Savvy FREE SHIPPING!Year End Clearance Sale! Save 20%

Reply
Unread 01-06-2012, 11:09 AM   #1
08Titan
Registered User
2007 JK Wrangler 
 
Join Date: Aug 2010
Location: Orangeville, PA, Pennsylvania
Posts: 360
Check engine light will not reset.

I've searched on here and other sites on how to reset the check engine light on my 07 jku. Last week I was out trail riding and had a limb kick up underneath and rip the wire out of the back of the drivers side rear O2 sensor. On my way home (in limp mode, what fun being stuck in second gear) I picked up a new O2 sensor and changed it out. While I was changing it out I unhooked the neg battery cable to let it reset. No luck, check engine light came back on. Went to advance auto and after getting a run around I finally talked the guy into resetting the dtc code (they kept saying they're only allowed to read them, not reset them even though I just bought the O2 sensor from them and hour ago). Again no luck, light back on. Well after reading around I saw where it will reset after so many miles or cycles without another bad reading so I drove to work and back for a week (70 mile round trip) with it on. Yesterday I went out and unhooked the neg cable again and let it sit over night and when I just went out and hooked it back up and started it there the light was again! It keeps pulling code P0058 which is the drivers side rear O2 sensor. What is going on? Can anybody help with this. Also the code reader at advance said the same thing, rear drivers side O2 sensor.

__________________
2007 JK unlimited rubicon, red rock crystal pearlcoat, rc 2.5" spacer lift, 35x12.50 goodyear mtr/k mounted on black 15x8" mb72's. (Mine)

2005 WK Limited 4.7, QTII, Midnight blue pearlcoat. (Hers)
08Titan is offline   Reply With Quote Quick reply to this message
Unread 01-06-2012, 11:24 AM   #2
jstrubberg
Registered User
2009 JK Wrangler 
 
Join Date: Jul 2010
Location: Missouri
Posts: 2,124
Maybe it's not the sensor itself. You could have pulled the wire harness loose enough somewhere down the line that you are getting an open or ground that's tripping the code.
jstrubberg is offline   Reply With Quote Quick reply to this message
Unread 01-06-2012, 11:31 AM   #3
08Titan
Registered User
2007 JK Wrangler 
 
Join Date: Aug 2010
Location: Orangeville, PA, Pennsylvania
Posts: 360
The harness was still attached by the ziptie thing up by the tranny and everything seemed tight when I unplugged it.
__________________
2007 JK unlimited rubicon, red rock crystal pearlcoat, rc 2.5" spacer lift, 35x12.50 goodyear mtr/k mounted on black 15x8" mb72's. (Mine)

2005 WK Limited 4.7, QTII, Midnight blue pearlcoat. (Hers)
08Titan is offline   Reply With Quote Quick reply to this message
Unread 01-06-2012, 12:40 PM   #4
DrHolliday
Senior Member
 
DrHolliday's Avatar
2011 JK Wrangler 
 
Join Date: Oct 2011
Location: Gresham, OREGON
Posts: 678
Bad sensor off the shelf? I know its not likely but its been known to happen.
__________________
2011 JK Rubicon 2 door 6-speed manual, 3.5" Rock Krawler Suspension lift, 1.25" Daystar body lift, 40x13.50R17 Nitto Mud Grapplers


My build thread
DrHolliday is offline   Reply With Quote Quick reply to this message
Unread 01-06-2012, 02:43 PM   #5
08Titan
Registered User
2007 JK Wrangler 
 
Join Date: Aug 2010
Location: Orangeville, PA, Pennsylvania
Posts: 360
Thats a possibility. I may take it out and swap it out. It has a one year warranty. Are the O2 sensors different upstream and downstream? Maybe they have me the wrong one too. The plug was identical but I don't know if they all use the same plug our if they're interchangeable?
__________________
2007 JK unlimited rubicon, red rock crystal pearlcoat, rc 2.5" spacer lift, 35x12.50 goodyear mtr/k mounted on black 15x8" mb72's. (Mine)

2005 WK Limited 4.7, QTII, Midnight blue pearlcoat. (Hers)
08Titan is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.