post #46 of Old 08-02-2013, 11:17 AM
JeepCares
FCA Customer Care
 
JeepCares's Avatar
 
Join Date: Jan 2012
Location: MOPAR World Headquarters
Posts: 3,864
The second cause has been determined to be a cut or slit in the O-ring at the top of the
pick-up tube on the oil pump.
A bore scope can be used to view the top of the pick-up
tube to see if the O-ring is not seated all the way around the tube. The O-ring is blue in
color and it should not be visible if installed properly.

Attached Images
 
JeepCares is online now  
post #47 of Old 08-02-2013, 05:57 PM
mrdeezus
Registered User
2013 JK Wrangler 
 
Join Date: Apr 2012
Location: Fair Oaks
Posts: 187
Quote:
Originally Posted by JeepCares View Post
The second cause has been determined to be a cut or slit in the O-ring at the top of the
pick-up tube on the oil pump.
A bore scope can be used to view the top of the pick-up
tube to see if the O-ring is not seated all the way around the tube. The O-ring is blue in
color and it should not be visible if installed properly.
Thanks Lee, the pic really helps explain a lot. Luckily this is covered ender the 5yr/100k warranty.
mrdeezus is offline  
post #48 of Old 09-05-2013, 11:11 PM
HllywdJeep
Registered User
2014 JK Wrangler 
 
Join Date: Jan 2013
Location: Kennesaw
Posts: 19
Quote:
Originally Posted by Cooneys08JK View Post
Do you leave the jeep in 1st while parked? Surely you don't rely on just the parking brake to hold your Jeep in a sloped driveway??
I definitely do not anymore. However, I have never had a parking brake lever that would just randomly release itself. Jeep also found it faulty and replaced it.

Update on a different note...
Jeep DID confirm I had a lemon about two weeks ago and are currently building me a 2014 I should see in the next 4-6 weeks.

From the day I purchased the Jeep, October 29, 2012, to April 10, 2013, it spent 42 days in the shop for random warranty work.
HllywdJeep is offline  
post #49 of Old 11-08-2013, 09:57 AM
kolky
Registered User
2000 TJ Wrangler 
 
Join Date: Dec 2009
Location: St. Louis, MO
Posts: 452
Well this thread doesn't make me feel any better.

Wife just bought a 2012 JKU Rubi 5 days ago and the check engine light came on. Went into limp mode while driving. Took it up to the local Jeep dealer figuring it was a bad o2 sensor and they tell us the oil pump needs to be replaced and they are on back order.

Yellow Jeep Club #1224
kolky is offline  
post #50 of Old 01-17-2014, 01:48 PM
JKPaul
Registered User
2012 JK Wrangler 
 
Join Date: Jul 2012
Posts: 182
Just got mine back, diagnosis was "engine oil pressure control circuit stuck off". they replaced the oil pressure switch. Have to wait and see if it resolved the issue. Will post further as I rack up the miles........

O|||||O

"Clowns to the left of me, jokers to the right.......'!
JKPaul is offline  
post #51 of Old 02-23-2014, 08:24 AM
JKPaul
Registered User
2012 JK Wrangler 
 
Join Date: Jul 2012
Posts: 182
Quote:
Originally Posted by JKPaul View Post
Just got mine back, diagnosis was "engine oil pressure control circuit stuck off". they replaced the oil pressure switch. Have to wait and see if it resolved the issue. Will post further as I rack up the miles........
CEL on again, I got P06dd on my reader, same as last time. They say it needs 'O' ring and then they want to do further testing? Told them to keep it till it's fixed.

O|||||O

"Clowns to the left of me, jokers to the right.......'!
JKPaul is offline  
post #52 of Old 02-24-2014, 07:29 PM
HllywdJeep
Registered User
2014 JK Wrangler 
 
Join Date: Jan 2013
Location: Kennesaw
Posts: 19
Best of luck to you JKPaul! I'm currently loving my 2014 lemon replacement because of that stupid P06dd.
HllywdJeep is offline  
post #53 of Old 02-26-2014, 09:28 PM
JKPaul
Registered User
2012 JK Wrangler 
 
Join Date: Jul 2012
Posts: 182
Quote:
Originally Posted by HllywdJeep View Post
Best of luck to you JKPaul! I'm currently loving my 2014 lemon replacement because of that stupid P06dd.
Thanks. Dealer called, needs an oil pump, waiting on part, they say ok to drive until part comes in. Here we go loop dee loo..........

O|||||O

"Clowns to the left of me, jokers to the right.......'!
JKPaul is offline  
post #54 of Old 03-14-2014, 08:54 AM
JKPaul
Registered User
2012 JK Wrangler 
 
Join Date: Jul 2012
Posts: 182
Quote:
Originally Posted by JKPaul View Post
Thanks. Dealer called, needs an oil pump, waiting on part, they say ok to drive until part comes in. Here we go loop dee loo..........
Oil pump installed. Jeep was returned to me in the same shape I left it in. Checked it over before I even got in it. Need to put some mile on it now and see how she goes.
Attached Thumbnails
2014-03-13_20-48-59.jpg  

O|||||O

"Clowns to the left of me, jokers to the right.......'!
JKPaul is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Check Engine Light Before Startup and Check Guages monto TJ Wrangler Technical Forum 5 05-15-2012 12:58 PM
Check Engine Light/Check Gauges Light eastwood1972 TJ Wrangler Technical Forum 3 11-16-2010 05:06 PM
low oil pressure and check gauges light.... jurob TJ Wrangler Technical Forum 8 08-29-2010 03:52 PM
Check engine light-power steering pressure switch rudyyj TJ Wrangler Technical Forum 3 03-09-2009 08:17 AM
Newby needing help with Check engine light/check gauges/stalling DannyDuvall TJ Wrangler Technical Forum 2 08-23-2008 08:02 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome