Check engine light and on going problem questions. - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Wrangler Forums > JK Wrangler Technical Forum > Check engine light and on going problem questions.

JKS Flex Connect in Actions!Ring & Pinion's, Lockers, 4340 Axles, Install Kits, BaWarn, Smitybilt, Engo, Rugged Ridge Winches at CCOR

Reply
Unread 08-15-2015, 02:20 AM   #1
Dead-On
Registered User
2013 JK Wrangler 
 
Join Date: Apr 2011
Location: Ohiopyle/Pittsburgh, PA
Posts: 233
Check engine light and on going problem questions.

So here is my problem, forgive me if I'm not describing it well.

I have 43K on the Jeep and this issue has only happened the last 3 oil changes.

At around 3,500-4,000 miles after an oil change something is going on with my engine. There is a section of highway on the way to my house that is at the top of a 2 mile mountain. At around 3,400 RPM/60 mph my engine suddenly cuts power (governer?) and the check engine light comes on. The temp gauge is not peaked out but is a bit over the center. It usually is at the center at normal RPM's.

Just to add, I usually have to add somewhere between 1-2 quarts of oil between oil changes.

The first time this happened (three oil changes ago) was after I used a NAPA oil filter. I researched and read on this forum that those filters can clog and aren't made to Jeeps specs. I also pulled the codes and it refereed - to drive train - vacuum presure - something about oil... I had a picture of the code but I cant find it now. So I figured this was the problem and had my oil changed at the dealer and used an OEM filter. Well it has happened twice since then right around 4K after the oil change.

The dealer says they were unable to pull the same code since then. So they changed the oil a few months back (3,800 miles ago) and wanted me to come back for an oil consumption test. Well right after that I tore my quad tendon and herniated two discs in my back. So I haven't been able to do much of anything lately let alone try to check my oil.

Well today the same thing happened driving up the mountain. The check engine light came on and the engine cut to half power just before the crest like it has before. When I got home I tried the key/ignition DTC and it won't give me any codes. It won't even say -done- afterwards.

It's due for an oil change next month but I'm scheduling an apointment at the dealer before that as soon as I can for this problem and a recall on the power mirror.

As I mentioned earlier the dealer said there were no codes or problems the last two times this happened. Any clue as to what's going on? Any help or insight prior to me taking it to the dealer would be appreciated.

Dead-On is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.