Anyone have any gas cap sensor problems? - Page 2 - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Wrangler Forums > JK Wrangler Technical Forum > Anyone have any gas cap sensor problems?

New jk doors from steinjagerEliminate Hood Flutter!!!Thursday Savings Blast

Reply
Unread 07-01-2014, 09:14 AM   #16
ginalong1
Registered User
2009 YJ Wrangler 
 
Join Date: Jul 2014
Location: Anthem, AZ
Posts: 1
Sensor & gas cap

I have a 2009 Jeep Wrangler with 50k miles. My sensor came on Friday morning. The manual indicated it could be the gas cap or bad gas. I was down to about 1/2 tank of gas, so I had not just filled. I decided to try the gas cap. Bought a new gas cap from AutoZone on my lunch Friday. The sensor went off on Sunday, but then "gas cap" dinged at me. I pushed the trip to turn it off. On Monday I took it to get an oil change they hooked it to the diagnostic and it was the battery. Replaced the battery and everything is fine. Put my old gas cap on and no problems since. I guess I thought if it were the battery, the battery light would come on. But that was my fix. Good luck and have your battery checked if this happens to you.


Last edited by ginalong1; 07-01-2014 at 09:30 AM..
ginalong1 is offline   Reply With Quote Quick reply to this message
Unread 07-02-2014, 09:19 AM   #17
TBayTelemark
Registered User
2007 JK Wrangler 
 
Join Date: Sep 2013
Location: Thunder Bay, Ontario
Posts: 2
Yes. When my battery started leaking, my gascap light and occasionally my engine light would light up a couple of minutes after driving if it had been raining or was very humid. A new battery solved the problem.

(This being different from the time when my gascap light turning on was due to a squished and dried out O-ring on the gas cap and a bit at the top of the filler tube.)
TBayTelemark is offline   Reply With Quote Quick reply to this message
Unread 07-02-2014, 01:40 PM   #18
Rus03ty
Registered User
2010 JK Wrangler 
 
Join Date: Jun 2014
Location: Murphy, Texas
Posts: 35
that problem happens because of the gas tank
Rus03ty is offline   Reply With Quote Quick reply to this message
Unread 07-03-2014, 10:02 AM   #19
Marinerider
Registered User
2007 JK Wrangler 
 
Join Date: May 2004
Location: 29 Palms, Ca
Posts: 59
Awww!! This just happened to me this week. Gascap light came on and now check engine light is on.

What part was replaced and where on the evaporator canister?

Pete
Marinerider is offline   Reply With Quote Quick reply to this message
Unread 07-03-2014, 11:35 AM   #20
bayoumade
Registered User
2011 JK Wrangler 
 
Join Date: Feb 2014
Location: west monroe, la
Posts: 12
gas cap light.

i dont see how a battery has any affect on the emissions system or sensor. Mine has been on for months. we reset it it came back on. I bought an after market gas cap. they said after a few dozen starts the sensor would reset itself if the gas cap was the issue. It didnt reset. I said to hell with it cause we do not do emissions tests in La. but then I started to notice a 1 to 2 mile loss in my gas mileage! Now that sux cause its not that great on a good day. JS so as it happened my battery went dead. I put new battery in. this automatically reset the sensor. a week later the damn this is on again! so battery is ruled out. I also would like to know more on the evap cap and canister. Thanks.
bayoumade is offline   Reply With Quote Quick reply to this message
Unread 07-03-2014, 01:55 PM   #21
duneslider
Registered User
2007 JK Wrangler 
 
Join Date: Jun 2013
Location: Riverton, Utah
Posts: 748
The white thing attached to the evap is the leak detection pump. I guess it is possible for it to go bad and that would throw a code I would think but there is a little rubber seal between the leak detection pump and the evap and that seal does go bad and it will create a small leak. The dealer should have the seal and they are only like 2 bucks. The pump is only like 10 bucks.

If you have the gas cap warning I would think bad gas cap first then consider the seal on the pump.
duneslider is offline   Reply With Quote Quick reply to this message
Unread 07-04-2014, 09:08 PM   #22
bayoumade
Registered User
2011 JK Wrangler 
 
Join Date: Feb 2014
Location: west monroe, la
Posts: 12
Thank you.
bayoumade is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.