Anyone have any gas cap sensor problems? - Page 2 - JeepForum.com

Reply
 
LinkBack Thread Tools
post #16 of 22 Old 07-01-2014, 09:14 AM
ginalong1
Registered User
2009 YJ Wrangler 
 
Join Date: Jul 2014
Location: Anthem
Posts: 1
Sensor & gas cap

I have a 2009 Jeep Wrangler with 50k miles. My sensor came on Friday morning. The manual indicated it could be the gas cap or bad gas. I was down to about 1/2 tank of gas, so I had not just filled. I decided to try the gas cap. Bought a new gas cap from AutoZone on my lunch Friday. The sensor went off on Sunday, but then "gas cap" dinged at me. I pushed the trip to turn it off. On Monday I took it to get an oil change they hooked it to the diagnostic and it was the battery. Replaced the battery and everything is fine. Put my old gas cap on and no problems since. I guess I thought if it were the battery, the battery light would come on. But that was my fix. Good luck and have your battery checked if this happens to you.


Last edited by ginalong1; 07-01-2014 at 09:30 AM.
ginalong1 is offline  
Sponsored Links
Advertisement
 
post #17 of 22 Old 07-02-2014, 09:19 AM
TBayTelemark
Registered User
2007 JK Wrangler 
 
Join Date: Sep 2013
Location: Thunder Bay
Posts: 2
Yes. When my battery started leaking, my gascap light and occasionally my engine light would light up a couple of minutes after driving if it had been raining or was very humid. A new battery solved the problem.

(This being different from the time when my gascap light turning on was due to a squished and dried out O-ring on the gas cap and a bit at the top of the filler tube.)
TBayTelemark is offline  
post #18 of 22 Old 07-02-2014, 01:40 PM
Rus03ty
Registered User
2010 JK Wrangler 
 
Join Date: Jun 2014
Location: Murphy
Posts: 35
that problem happens because of the gas tank
Rus03ty is offline  
post #19 of 22 Old 07-03-2014, 10:02 AM
Marinerider
Registered User
2007 JK Wrangler 
 
Join Date: May 2004
Location: 29 Palms
Posts: 59
Awww!! This just happened to me this week. Gascap light came on and now check engine light is on.

What part was replaced and where on the evaporator canister?

Pete
Marinerider is offline  
post #20 of 22 Old 07-03-2014, 11:35 AM
bayoumade
Registered User
2011 JK Wrangler 
 
Join Date: Feb 2014
Location: west monroe
Posts: 12
gas cap light.

i dont see how a battery has any affect on the emissions system or sensor. Mine has been on for months. we reset it it came back on. I bought an after market gas cap. they said after a few dozen starts the sensor would reset itself if the gas cap was the issue. It didnt reset. I said to hell with it cause we do not do emissions tests in La. but then I started to notice a 1 to 2 mile loss in my gas mileage! Now that sux cause its not that great on a good day. JS so as it happened my battery went dead. I put new battery in. this automatically reset the sensor. a week later the damn this is on again! so battery is ruled out. I also would like to know more on the evap cap and canister. Thanks.
bayoumade is offline  
post #21 of 22 Old 07-03-2014, 01:55 PM
duneslider
Registered User
2007 JK Wrangler 
 
Join Date: Jun 2013
Location: Riverton
Posts: 1,864
The white thing attached to the evap is the leak detection pump. I guess it is possible for it to go bad and that would throw a code I would think but there is a little rubber seal between the leak detection pump and the evap and that seal does go bad and it will create a small leak. The dealer should have the seal and they are only like 2 bucks. The pump is only like 10 bucks.

If you have the gas cap warning I would think bad gas cap first then consider the seal on the pump.
duneslider is offline  
post #22 of 22 Old 07-04-2014, 09:08 PM
bayoumade
Registered User
2011 JK Wrangler 
 
Join Date: Feb 2014
Location: west monroe
Posts: 12
Thank you.
bayoumade is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
TPS sensor problems.. 4wheel4real TJ Wrangler Technical Forum 22 11-02-2008 02:50 PM
O2 Sensor Problems schoena TJ Wrangler Technical Forum 15 02-07-2007 06:46 PM
O2 Sensor Problems?? mattvino TJ Wrangler Technical Forum 1 01-04-2005 05:51 PM
sensor problems again William Burns TJ Wrangler Technical Forum 23 06-27-2004 01:28 PM
more O2 sensor problems... blakkbelt YJ Wrangler Technical Forum 0 05-15-2004 07:20 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome