post #1 of Old 05-19-2013, 05:21 PM Thread Starter
jehnmg
Registered User
2009 JK Wrangler 
 
Join Date: Oct 2008
Location: long island, ny
Posts: 344
Another Rough Idle Thread

Yup...you read it correctly. Despite the copious amounts of research that I have already done, I figured that it wouldn't hurt to post this anyway. There's a lot of brain power here and I could use some of it. Here goes:

I have an 09 Rubi with approx. 66K on it. About 6 months ago it started to idle roughly when stopped at a light, etc. I noticed that the rpm's would even sometimes fall below 500 , causing the Jeep to really twitch. Nonetheless, no codes were thrown, so I kept driving her anyway.

However, when I was at Rausch in March climbing a hill (not sure if this is important, but want to be as accurate as possible) when the throttle stopped being responsive. Immediately the electronic throttle control light (the red "lightning bolt") came on. I tried restarting the Jeep 3 times and it would always reappear and the throttle was no responsive. Finally, on the 4th restart, the light stayed off and I was able to drive 200 miles home.

I brought it to the dealership thereafter because the engine was still idling weird, to which they updated the software on the Jeep. Problem is, it is still idling very rough. I went a second time to the dealership, but they claimed that everything was fine, which clearly is not the case.

As per some background, the TB is clean, the plugs and wires were changed at 50K, I ran Techtron through, but nothing thus far has helped.

Any ideas?


Teraflex 2.5" Coil & Shock lift, fr. lower control arms,
Gdyr 35x12.5r15, P.Comp 1069's...

Skids- Sway Bar, c. arms, s.mounts, oil pan, evap. cannister, EVO C2 front axle Gussets...
jehnmg is offline  
post #2 of Old 05-19-2013, 08:40 PM
Jeepzeroone
Registered User
2008 JK Wrangler 
 
Join Date: Jan 2013
Location: Albuquerque
Posts: 20
MY 08 41k did the exact same thing.
New battery fixed it.
Jeepzeroone is offline  
post #3 of Old 05-20-2013, 04:05 AM Thread Starter
jehnmg
Registered User
2009 JK Wrangler 
 
Join Date: Oct 2008
Location: long island, ny
Posts: 344
Interesting....I read a response like this before. Problem is, how/why would an old battery only affect the electronic throttle response?

Teraflex 2.5" Coil & Shock lift, fr. lower control arms,
Gdyr 35x12.5r15, P.Comp 1069's...

Skids- Sway Bar, c. arms, s.mounts, oil pan, evap. cannister, EVO C2 front axle Gussets...
jehnmg is offline  
post #4 of Old 05-20-2013, 07:25 AM
Jiblet
Registered User
2008 JK Wrangler 
 
Join Date: Dec 2008
Location: Boston, MA
Posts: 972
Quote:
Originally Posted by jehnmg View Post
Interesting....I read a response like this before. Problem is, how/why would an old battery only affect the electronic throttle response?
For example, the new battery could be overcoming an issue (like a poorly grounded alternator) that the weaker battery could not.

but rough idle can be caused by a variety of issues. bad sensor(s), dirty TB, vacuum leak.

Any codes being thrown?
Jiblet is offline  
post #5 of Old 05-20-2013, 05:08 PM Thread Starter
jehnmg
Registered User
2009 JK Wrangler 
 
Join Date: Oct 2008
Location: long island, ny
Posts: 344
There was a code thrown, which I believe had to do with a faulty electronic throttle control light illuminating. That said, the dealership's response was to update the ECU, which has not worked.

Teraflex 2.5" Coil & Shock lift, fr. lower control arms,
Gdyr 35x12.5r15, P.Comp 1069's...

Skids- Sway Bar, c. arms, s.mounts, oil pan, evap. cannister, EVO C2 front axle Gussets...
jehnmg is offline  
post #6 of Old 06-02-2013, 04:21 AM Thread Starter
jehnmg
Registered User
2009 JK Wrangler 
 
Join Date: Oct 2008
Location: long island, ny
Posts: 344
Update

I put Sea foam in the oil and gas 3 tanks ago. Believe it or not, the engine knocking is virtually gone and the idle is also considerably smoother.
Just putting it out there, FWIW for anyone else who is having a similar issue

Teraflex 2.5" Coil & Shock lift, fr. lower control arms,
Gdyr 35x12.5r15, P.Comp 1069's...

Skids- Sway Bar, c. arms, s.mounts, oil pan, evap. cannister, EVO C2 front axle Gussets...
jehnmg is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome