Annoying service lights. Procal didn't fix it. - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Wrangler Forums > JK Wrangler Technical Forum > Annoying service lights. Procal didn't fix it.

Trick Tabs - NalinMFG.comWarn, Smitybilt, Engo, Rugged Ridge Winches at CCORClayton Off Road XJ Long Arm Suspension Systems!

Reply
Unread 04-21-2013, 07:53 AM   #1
GeorgiaJK07
Registered User
2007 JK Wrangler 
 
Join Date: Mar 2011
Location: Chattanooga, TN
Posts: 148
Annoying service lights. Procal didn't fix it.

So randomly my esp/bas, traction control, and abs lights came on the other day. I've tried removing the battery cable for 20 min, reset everything with my AEV procal module ( all worked except when I tried to reset DTC codes, the horn never blew to let me know it has been corrected ) I'm a little stumped at the moment. Just curious if anyone else has had this problem. Bad sensor in the tires? My traction control will randomly engage when I pull out of my driveway. Not wet or slick.

__________________
2007 JK Sahara
3.5" RC Suspension, Rugged ridge front bumper, Smittybilt rear bumper and rocker guards, Warn 9000lb wireless winch, AEM Brute Force Air Intake. Moto Metal 961 wheels, TOYO Open Country tires.
GeorgiaJK07 is offline   Reply With Quote
Unread 04-21-2013, 07:56 AM   #2
SoK66
Registered User
1976 CJ5 
 
Join Date: Jul 2011
Location: Durango, CO
Posts: 1,133
Do you have a lift? Is your steering wheel centered?
SoK66 is offline   Reply With Quote
Unread 04-22-2013, 07:55 AM   #3
GeorgiaJK07
Registered User
2007 JK Wrangler 
 
Join Date: Mar 2011
Location: Chattanooga, TN
Posts: 148
Yea 3.5 inch RC. I'm pretty sure the dealer did all of that before I got it. He gave me the procal module with the jeep. So I'm assuming they did all that. But I reset everything with the procal and then set the axle ( which is stock ), tire size and I tired to clear dtc codes but for some reason the horn never blows and it never corrects it.
__________________
2007 JK Sahara
3.5" RC Suspension, Rugged ridge front bumper, Smittybilt rear bumper and rocker guards, Warn 9000lb wireless winch, AEM Brute Force Air Intake. Moto Metal 961 wheels, TOYO Open Country tires.
GeorgiaJK07 is offline   Reply With Quote
Unread 04-22-2013, 09:06 AM   #4
SoK66
Registered User
1976 CJ5 
 
Join Date: Jul 2011
Location: Durango, CO
Posts: 1,133
If the horn doesn't blow the system isn't being programmed by the Procal. Be sure you're following the instructions to the letter. If it still isn't working either the Procal is defective, or it isn't the right one for that vehicle. Once they're used on a specific VIN they have to be reset to work with any other. I think they have to go back to AEV for ther eset, at least they used to.
SoK66 is offline   Reply With Quote
Unread 04-22-2013, 09:52 AM   #5
RockyClymer
RedRock4Wheeler
 
RockyClymer's Avatar
2008 JK Wrangler 
 
Join Date: Apr 2008
Location: Colorado
Posts: 4,401
Also, the Procal will only let you set one parameter at a time. Each time you must remove it from the port, turn the ignition off, wait a few minutes and start over for the next parameter...they do not tell you this in the instructions, but that is the way it works.
__________________
08 JK 23S - Colorado Jeep Club No. 204
Too much to list - see my profile for details on build
NRA Life member
"It takes a special kind of stupid to believe criminals will follow gun laws."
I do not consider myself a smartass. I point out the obvious, search for the truth, and speak fluent sarcasm. I am, by experience, an accomplished curmudgeon.
RockyClymer is offline   Reply With Quote
Unread 04-22-2013, 10:08 AM   #6
222Doc
Registered User
2012 JK Wrangler 
 
Join Date: Sep 2011
Location: Lake Havasu City, AZ
Posts: 4,487
Be sure you are setting Dip switches correctly. I have made that error, bad eyes, big fingers.
__________________
[URL=http://www.bullhead4wheelersinc.com[/URL]
222Doc is online now   Reply With Quote
Unread 04-23-2013, 09:16 AM   #7
Jeepjet
Registered User
2012 JK Wrangler 
 
Join Date: Sep 2009
Location: Mashpee, Mass, Mass
Posts: 228
Quote:
Originally Posted by GeorgiaJK07 View Post
So randomly my esp/bas, traction control, and abs lights came on the other day. I've tried removing the battery cable for 20 min, reset everything with my AEV procal module ( all worked except when I tried to reset DTC codes, the horn never blew to let me know it has been corrected ) I'm a little stumped at the moment. Just curious if anyone else has had this problem. Bad sensor in the tires? My traction control will randomly engage when I pull out of my driveway. Not wet or slick.
I would think resetting the lights/Procal would just remove the light not the reason for it coming on? Don't know about 2007 but on my 12 (auto)those lights came on and it was a sensor that oddly enough is mounted in the center console under the cup holders. The connection is VERY susceptible to spilled drinks. You could clean up the connector and try that, it worked on mine. Good luck.
__________________
2012 JK Sport, Deep Cherry Red , 3.6 Penastar, 5 spd. auto, 3:21's, 285/70x17 DuraTrac's , Teraflex leveling kit, U.S. Alloy 1.5 spacers, ACE rock sliders, Rugged Ridge front dif skid, quadratec mats, K&N element,+80 headlamps...
Jeepjet is offline   Reply With Quote
Unread 04-23-2013, 09:17 PM   #8
GeorgiaJK07
Registered User
2007 JK Wrangler 
 
Join Date: Mar 2011
Location: Chattanooga, TN
Posts: 148
Quote:
Originally Posted by RockyClymer View Post
Also, the Procal will only let you set one parameter at a time. Each time you must remove it from the port, turn the ignition off, wait a few minutes and start over for the next parameter...they do not tell you this in the instructions, but that is the way it works.
I understand how the procal works. The horn blows for everything else but the DTC correction as stated in the original post. I'm 100% positive I'm doing everything correctly as far as Procal goes. Other then that I don't know what else I can do to correct this issue. I don't have time, money or patience for the stealership.

Ill check under the cup holder and see what happens. Thanks!
__________________
2007 JK Sahara
3.5" RC Suspension, Rugged ridge front bumper, Smittybilt rear bumper and rocker guards, Warn 9000lb wireless winch, AEM Brute Force Air Intake. Moto Metal 961 wheels, TOYO Open Country tires.
GeorgiaJK07 is offline   Reply With Quote
Unread 04-23-2013, 09:19 PM   #9
GeorgiaJK07
Registered User
2007 JK Wrangler 
 
Join Date: Mar 2011
Location: Chattanooga, TN
Posts: 148
Quote:
Originally Posted by Jeepjet View Post
I would think resetting the lights/Procal would just remove the light not the reason for it coming on? Don't know about 2007 but on my 12 (auto)those lights came on and it was a sensor that oddly enough is mounted in the center console under the cup holders. The connection is VERY susceptible to spilled drinks. You could clean up the connector and try that, it worked on mine. Good luck.
Was your TC acting up at all when these lights were on?
__________________
2007 JK Sahara
3.5" RC Suspension, Rugged ridge front bumper, Smittybilt rear bumper and rocker guards, Warn 9000lb wireless winch, AEM Brute Force Air Intake. Moto Metal 961 wheels, TOYO Open Country tires.
GeorgiaJK07 is offline   Reply With Quote
Unread 04-23-2013, 11:19 PM   #10
joe002
Registered User
2008 JK Wrangler 
 
Join Date: Sep 2007
Location: Phoenix, AZ
Posts: 938
So is your steering wheel perfectly centered? You can use your ProCal to check if it's centered properly.
__________________
2008 Rubicon - 2 Door - Flame Red - Automatic - MyGIG - Power Group - Deep Tint.
AEV Pintlers, BFG KM2s 35x12.50x17, Bulldog Fab Stubby Bump, Currie F/R Adj Trac Bars, Daystar Upper Dash, FireStik FireFly antenna, Kilby Rear Shock Skids, LoD Sig Stubby Bump, Midland 75-822 CB, Mopar Filler Door & Locking Gas Cap, Rancho LCA Skids, Rancho Oil Pan Armor, Riddler Diff Covers, custom Rubi Sliders, Sylvania X-treme Headlights, TeraFlex 2.5" Spring Lift, Warn PowerPlant HD, Woods Evap Can Relo, Woods SS Relo, Yukon 5.38s
joe002 is offline   Reply With Quote
Unread 04-24-2013, 10:14 AM   #11
Walle
Soccer Mom and Jeep Hater
 
Walle's Avatar
2012 JK Wrangler 
 
Join Date: Feb 2012
Location: Albuquerque, NM
Posts: 1,039
I had the same issue. It is more than likely a wheel speed sensor. I had to replace two of mine. The dealership had to reset the ABS light. I could be wrong, but from what I understand...the Procal won't clear ABS codes.
__________________
Quote:
Originally Posted by Mol
Blame that on me...I'm not liked around here for not drinking the koolaide :laugh:
Walle is offline   Reply With Quote
Unread 04-24-2013, 03:45 PM   #12
SlyDawg64
Junior Member
 
SlyDawg64's Avatar
2014 JK Wrangler 
 
Join Date: Oct 2011
Location: GOODYEAR, ARIZONA
Posts: 66
I had the same problem after a week of running trails. I checked
the wiring at each wheel, feeling for loose connections/shorted wires.
Could not find anything wrong and started up the Jeep to check lights again and they were off.
If/when I get the lights again, I will check for lights after checking each wheel to narrow it down more.

__________________
__________________
New:
2014 JKU Rubicon, Copperhead Pearl, 3" TerraFlex lift, Toyo MT 35x12.5x18 tires, Warn Powerplant,

Old:
2010 JK Rubicon, 2 dr., 3" Terraflex lift and adjustable rear track bar, Toyo 35x12.5 tires, custom bumpers, Warn Powerplant, KC lights, B&M trans cooler, etc.
SlyDawg64 is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.