2012 wrangler headlights stopped working - JeepForum.com

 
LinkBack Thread Tools
post #1 of 6 Old 09-28-2013, 07:35 PM Thread Starter
poolboy93
Registered User
2012 JK Wrangler 
 
Join Date: May 2012
Location: Yarmouth
Posts: 124
2012 wrangler headlights stopped working

I have a 2012 jeep jk and I replaced my stock headlights with Hellas. I've had them in for a few days and tonight they just shut off when I was driving. I'm wondering if it's just a fuse or if anyone has any idea what it might be?

poolboy93 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 09-28-2013, 07:43 PM
Filthy-Beast
Registered User
2006 LJ Wrangler 
 
Join Date: Aug 2009
Location: Palatine
Posts: 2,332
could be a fuse, why didn't you check it as soon as it happened


Anyway when putting new fixtures in with normal type lamps instead of LEDs it's wise to run better wires directly from the battery. Use a relay wired to original harness to control it. Put a fuse in new wires.

13 JKUR Build thread

For Sale: 2013 4dr JK Painted black Hard Top JKUR 18/59 springs and shocks

97 TJ: daughter 1 - 2.5L, Auto, 2" BB, 31" GY Duratrac
98 TJ: Daugher 2 - 4.0L, 5spd, D44 rear
06 LJ Rubicon: mine - Rokmen full up-armor, 8 adjustable CAs, front bumper, sliders, corners, Shrockworks rear bumper, 3" AEV/BDS lift, Currie HD stearing and Antirock, MT/r - k 35x12.5, SuperWinch, MC Overlines, York OBA
13 JKU Rubicon: Wife's for now, Ace Rock rails & rear bumper tire carrier, Truck Lites, MC Game changer 3.5 lift, RR skids, PSC Brawler front bumper, Warn 9.5cti-s, 35" GY MTRs
Filthy-Beast is offline  
post #3 of 6 Old 09-28-2013, 07:50 PM
ronjenx
Web Wheeler
 
ronjenx's Avatar
2008 JK Wrangler 
 
Join Date: Jan 2009
Location: Maine
Posts: 4,599
Do the Hellas come with their own fuse? The OEM headlights have no fuse.
ronjenx is offline  
post #4 of 6 Old 09-28-2013, 07:58 PM Thread Starter
poolboy93
Registered User
2012 JK Wrangler 
 
Join Date: May 2012
Location: Yarmouth
Posts: 124
There are no fuses with the Hellas just plugged them in and put them in place
poolboy93 is offline  
post #5 of 6 Old 09-28-2013, 08:22 PM
ronjenx
Web Wheeler
 
ronjenx's Avatar
2008 JK Wrangler 
 
Join Date: Jan 2009
Location: Maine
Posts: 4,599
Quote:
Originally Posted by poolboy93 View Post
There are no fuses with the Hellas just plugged them in and put them in place
OK. That means there is no fuse to check.

What is the wattage of the new lights? If they are more than stock, the Totally Integrated Power Module (TIPM) may have shut them off to protect the wiring, thinking the extra amperage is a short.
ronjenx is offline  
post #6 of 6 Old 09-29-2013, 06:55 AM Thread Starter
poolboy93
Registered User
2012 JK Wrangler 
 
Join Date: May 2012
Location: Yarmouth
Posts: 124
The new lights I installed at 60/55w
poolboy93 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome