2008 Sahara electrical problem, I think. - JeepForum.com

LinkBack Thread Tools
post #1 of 1 Old 07-20-2012, 05:03 PM Thread Starter
Registered User
1989 YJ Wrangler 
Join Date: Jul 2011
Location: BEND
Posts: 12
2008 Sahara electrical problem, I think.

I hope someone has heard of this problem, and may have a solution. We have a 2008 Wrangler Sahara, over the last couple of months, maybe three or four times the MyGig/ Nav would not come on, along with the windows not working and a couple of other electical things not working.

I would pull out the key, re-insert the key and start the jeep and then everything worked fine. Two weeks ago, the same thing happened in the morning, in the afternoon my wife could not get the jeep to start. She was out of town, she got some help from a mechanic to get it started. All he did was jiggle the steering wheel, and jiggle the shifter, and bam it started and she drove it home. 100 mile drive, the Nav and windows did not work.

When she got home, I went out and tryed to start it, but no luck. I jigged the shifter and was supprised to find out that I could move it from park to reverse, netral, drive, anything I wanted to without even the key in it.

I was puting a new battery in the vehicle anyway, so I put it in that night and the jeep started right up. I thought I solved the problem, however two days later, it was the same thing again, won't start, we can move the shifter with out the key in the ignition.

Took it to the dealer, four days ago, they put in a 'module' that comunicates between the key and the vehicle. I was told there was no comunication so the computer is alowing these things to happen. $500.00 and four days later, it is back in the shop, they are trying to figure it out. They have talked to the factory, they say everyone is stumped.

They gave us a loaner car, so it is not an inconveniance for us, however the loaner is a PT Cruiser with there logos all over it. Any ideas out there? has anyone had or has heard of this happening? Please help, I am desterate, I can't drive a PT all weekend.


alpinevend is offline  

2008 jk , electrical issue , intermittent , shifter

Quick Reply

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page

Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
2008 X vs. Sahara jrmandryck JK Wrangler Technical Forum 8 10-16-2011 01:31 PM
2008 Sahara using oil bearcatrp JK Wrangler Technical Forum 9 09-22-2011 04:38 PM
'03 Sahara Edition. Electrical problem? Never seen this before ROFLsplash TJ Wrangler Technical Forum 1 09-12-2010 01:35 PM
2008 sahara newjk JK Wrangler Technical Forum 6 05-14-2010 09:00 PM
2008 Sahara tow kit YellowDuck JK Wrangler Technical Forum 1 03-07-2010 04:18 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome