first day with driver licences... - JeepForum.com

 
LinkBack Thread Tools
post #1 of 3 Old 07-01-2011, 06:43 PM Thread Starter
seb91xj
Registered User
 
Join Date: Jul 2011
Location: montréal
Posts: 1
first day with driver licences...

So yesterday when i was driving back home on the highway,rolling at 80km/h i heard a weird noise like if my radio was between the station so i turned it off, but this loud noise was still there so i slowed down and i tried to drive to a garage to see what was the problem....but when i was on the top of an overpass,the engine just deid.when i stopped,i looked under the truck and saw that my muffler was half on the groud and the engine oil started to leak when me and my father took it home we saw that a part of the engine wasnt there anymore...so i had to find another jeep and i found a 91 xj that works very well for 450 buck so im just gonna take my old axle and put it on my new one....the only thing that make me frustrated is why my muffler and engine brook almost at the same time beacause i never had big problem with it.

ps;sorry if my english isnt very good.

seb91xj is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 07-02-2011, 05:05 PM
jeepdavetj
Registered User
1991 XJ Cherokee 
 
Join Date: Jun 2008
Location: Campobello SC
Posts: 3,398
Ya english is better than half of the Americans here. Good price on that XJ, 91 is a good year! What exactly broke?Ya throw a rod?

I don't blame people for their mistakes, but I do expect they pay for them.




Ash from Army of Darkness
Quote:
Alright you Primitive Screwheads, listen up! You see this? This... is my boomstick! The twelve-gauge double-barreled Remington. S-Mart's top of the line. You can find this in the sporting goods department. That's right, this sweet baby was made in Grand Rapids, Michigan. Retails for about a hundred and nine, ninety five. It's got a walnut stock, cobalt blue steel, and a hair trigger. That's right. Shop smart. Shop S-Mart. You got that?
jeepdavetj is offline  
post #3 of 3 Old 07-03-2011, 07:58 AM
kavanji
Registered User
2002 TJ Wrangler 
 
Join Date: Sep 2006
Location: Windhoek, Namibia
Posts: 148
sounds like an electrical problem!

a rod probably took out your altenator

V51JP
http://up.picr.de/923897.jpg
Dirt, Rocks, Mud...Whatever
White Jeep Club Member #183
kavanji is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
prius driver mad at jeep driver TJCole General Discussion 51 01-23-2009 05:28 PM
my new daily driver mattman8706 General Discussion 1 09-15-2007 08:53 PM
WJ vs XJ, For daily driver and fun rig. Xride General Discussion 11 10-20-2005 05:08 PM
My new daily driver... Twisted General Discussion 18 05-04-2005 03:54 PM
According to Car and Driver... jasfro General Discussion 3 09-03-2004 05:16 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome