Winch problem - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Wrangler Forums > TJ Wrangler Technical Forum > Winch problem

FS: 2007-2013 Jeep Wrangler "HALO" Angel Eye KitRockridge 4WD IS Taking Zone Offroad Suspension Lift Kits End of Summer Sale, 20% OFF!

Reply
Unread 01-08-2014, 09:52 PM   #1
chasemclelland
Registered User
2006 TJ Wrangler 
 
Join Date: Jan 2014
Posts: 74
Winch problem

My rugged ridge winch is not getting power. I hooked it to battery to pos and neg for ground and the rest to the winch motor but still no power

image-3292877894.jpg

Any help please

chasemclelland is offline   Reply With Quote
Unread 01-09-2014, 06:19 AM   #2
durango-bob
Registered User
2000 TJ Wrangler 
 
Join Date: Jul 2008
Location: Sioux Falls, South Dakota
Posts: 2,784
Based on your picture, you didn't get it installed or hooked up yet. But if you have it installed and connected and it gets no power, then you must have a bad cable or didn't connect it right. If you do have power at the winch and it just doesn't work, then you have a different problem but that's not what you said you have.
durango-bob is online now   Reply With Quote
Unread 01-09-2014, 06:34 AM   #3
chasemclelland
Registered User
2006 TJ Wrangler 
 
Join Date: Jan 2014
Posts: 74
That was just showing what I was working with Haha but I Hooked it up red to red yellow to yellow thick black to black and thin black to motor and long black from the motor to negative and long red to positive
chasemclelland is offline   Reply With Quote
Unread 01-09-2014, 10:28 AM   #4
dayriesw
Web Wheeler
 
dayriesw's Avatar
2005 LJ Wrangler 
 
Join Date: Jul 2009
Location: Louisiana
Posts: 5,162
Make sure your neg goes to the neg post on the battery and not just to the frame or so.

Why has a mod not moved this thread yet?
__________________
Impact Orange LJ - DD...sitting low, flat bottomed, fully armored and locked on 37s
dayriesw is offline   Reply With Quote
Unread 01-09-2014, 10:34 AM   #5
chasemclelland
Registered User
2006 TJ Wrangler 
 
Join Date: Jan 2014
Posts: 74
Quote:
Originally Posted by dayriesw
Make sure your neg goes to the neg post on the battery and not just to the frame or so. Why has a mod not moved this thread yet?
It is idk what the problem is
chasemclelland is offline   Reply With Quote
Unread 01-09-2014, 10:37 AM   #6
robncar
We Got The Cup, AGAIN!!!
 
robncar's Avatar
2005 TJ Wrangler 
 
Join Date: Nov 2005
Location: La Verne, CA
Posts: 8,373
Do you have a test meter?
robncar is offline   Reply With Quote
Unread 01-09-2014, 10:47 AM   #7
chasemclelland
Registered User
2006 TJ Wrangler 
 
Join Date: Jan 2014
Posts: 74
No but I could borrow one for auto zone
chasemclelland is offline   Reply With Quote
Unread 01-09-2014, 12:07 PM   #8
robncar
We Got The Cup, AGAIN!!!
 
robncar's Avatar
2005 TJ Wrangler 
 
Join Date: Nov 2005
Location: La Verne, CA
Posts: 8,373
Quote:
Originally Posted by chasemclelland View Post
No but I could borrow one for auto zone
Might come in handy to identify what's going on...
robncar is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.