White Smoke Above Dash Drivers Side - JeepForum.com
 2Likes
Reply
 
LinkBack Thread Tools
post #1 of 21 Old 06-17-2017, 05:03 PM Thread Starter
Cjs89YJ
Registered User
1989 YJ Wrangler 
 
Join Date: Oct 2014
Location: Ottawa
Posts: 66
White Smoke Above Dash Drivers Side

Hi All,

2003 TJ, 4.0, 5 speed

So this problem has happened to me about 4 times now. Basically after driving somewhere occasionally I will notice some white smoke coming out from between the dashboard and windshield frame just above the drivers side vent.
1) My first thought was that I was burning the Clutch because it was after I had been sitting in some heavy traffic on a hill. But this was just 1/4 times, the other 3 times were normal driving conditions although a lot of stop and go.
2) Each time I believe I had vent knob on one of the AC settings, my AC however doesnt work I just leave the knob usually in the recycle position. After searching the forums, I saw some people suggest it was a freon leak, but I never got any odor.

About my AC, it didnt work when I bought the jeep so I decided to get a mechanic to top up the freon to see if I had a leak, but he said the system was already charged.From there I didn't really bother to look much further into the AC problem.

My real question is this something I should be worried about? I regularly check all the jeeps fluids and the jeep never overheats so I'm wondering what this occasional smoke is.

Any help is much appreciated.

cheers


89 YJ 4.2 5speed - 1" Spacers / 31" MT
93 YJ 4.0 Auto
03 TJ 4.0 5speed - 2.5" lift/ 31" AT

Last edited by Cjs89YJ; 06-17-2017 at 05:03 PM. Reason: forgot to put the jeep details
Cjs89YJ is offline  
Sponsored Links
Advertisement
 
post #2 of 21 Old 06-17-2017, 05:44 PM
biffgnar
Moderator
 
biffgnar's Avatar
2006 TJ Wrangler 
 
Join Date: May 2008
Location: Westchester, NY
Posts: 23,212
Are you sure its smoke and not steam? Was it humid and rainy when it did it?

On another note, your ac has R134 in it not freon and I think it is relatively odorless.
biffgnar is online now  
post #3 of 21 Old 06-17-2017, 07:11 PM Thread Starter
Cjs89YJ
Registered User
1989 YJ Wrangler 
 
Join Date: Oct 2014
Location: Ottawa
Posts: 66
Ok that makes a lot more sense, it was a somewhat humid day today because it had just finished raining. And I'm cant 100% remember but i'd say the earlier times might have been humid as well. And my mistake about the freon/r134 mix up that would also explain why i didn't smell anything.

Its supposed to rainy/humid out again tommorrow so I will look more closely but it might be steam, its just the amount of steam might have misled me to call it smoke. In any case would this steam/smoke be a result of whatever the broken part is on my ac?

89 YJ 4.2 5speed - 1" Spacers / 31" MT
93 YJ 4.0 Auto
03 TJ 4.0 5speed - 2.5" lift/ 31" AT
Cjs89YJ is offline  
 
post #4 of 21 Old 06-17-2017, 07:27 PM
biffgnar
Moderator
 
biffgnar's Avatar
2006 TJ Wrangler 
 
Join Date: May 2008
Location: Westchester, NY
Posts: 23,212
Quote:
Originally Posted by Cjs89YJ View Post
Ok that makes a lot more sense, it was a somewhat humid day today because it had just finished raining. And I'm cant 100% remember but i'd say the earlier times might have been humid as well. And my mistake about the freon/r134 mix up that would also explain why i didn't smell anything.

Its supposed to rainy/humid out again tommorrow so I will look more closely but it might be steam, its just the amount of steam might have misled me to call it smoke. In any case would this steam/smoke be a result of whatever the broken part is on my ac?
An a damp humid day a perfectly functioning hvac system can blow steam out the vents.
biffgnar is online now  
post #5 of 21 Old 06-17-2017, 07:45 PM Thread Starter
Cjs89YJ
Registered User
1989 YJ Wrangler 
 
Join Date: Oct 2014
Location: Ottawa
Posts: 66
Only thing that worried me was that it wasnt out of the vents, but above them from the dash. I understand what you mean it most likely is steam and Im just worrying over nothing hahahaha
Thanks for the reply!

89 YJ 4.2 5speed - 1" Spacers / 31" MT
93 YJ 4.0 Auto
03 TJ 4.0 5speed - 2.5" lift/ 31" AT
Cjs89YJ is offline  
post #6 of 21 Old 06-17-2017, 08:22 PM
JEK3
Web Wheeler
 
JEK3's Avatar
2006 LJ Wrangler 
 
Join Date: Jan 2010
Location: Fredericksburg
Posts: 3,047
Could it be possible that your A/C actually works, but something is broken in the ducting so it never actually gets to the vents?
JEK3 is offline  
post #7 of 21 Old 06-17-2017, 09:21 PM Thread Starter
Cjs89YJ
Registered User
1989 YJ Wrangler 
 
Join Date: Oct 2014
Location: Ottawa
Posts: 66
The vents themselves do blow air just not "cold". Given that the ac system is charged anything could be possible as to why it doesn't work.

89 YJ 4.2 5speed - 1" Spacers / 31" MT
93 YJ 4.0 Auto
03 TJ 4.0 5speed - 2.5" lift/ 31" AT
Cjs89YJ is offline  
post #8 of 21 Old 06-18-2017, 05:12 PM
Dodger60
Registered User
1997 TJ Wrangler 
 
Join Date: Apr 2012
Location: Greater Sudbury
Posts: 34
Keep an eye on your coolant level as the first sign of a failing heater core can be just such a white steam coming from the dash..it would smell a bit like antifreeze though so likely it isn't that..just be on the lookout...

Sent from my Nexus 5 using Tapatalk
prjohnson likes this.
Dodger60 is offline  
post #9 of 21 Old 06-19-2017, 04:39 PM Thread Starter
Cjs89YJ
Registered User
1989 YJ Wrangler 
 
Join Date: Oct 2014
Location: Ottawa
Posts: 66
OK. So today I went to work and it wasn't a humid day and I had the function knob turned to off. However there was still a bit of smoke, and I say smoke because I looked closer at it and it definitely was not steam. I also noticed my reverse lights had stopped working again. Then this idea sort of clicked into my head. Each time i saw this smoke was after I had finished driving and reversed into my parking spot (i always reverse in because other wise its tough in the morning). Now my reverse light and switch was replaced at the start of May, the reason it stopped working was unknown. Now less than 2 months later my reverse lights dont work and this smoke happens after reversing in. Could it be that something is shorting causing this smoke and my reverse lights to have blown again?
Dodger60 likes this.

89 YJ 4.2 5speed - 1" Spacers / 31" MT
93 YJ 4.0 Auto
03 TJ 4.0 5speed - 2.5" lift/ 31" AT
Cjs89YJ is offline  
post #10 of 21 Old 06-19-2017, 04:46 PM
Dodger60
Registered User
1997 TJ Wrangler 
 
Join Date: Apr 2012
Location: Greater Sudbury
Posts: 34
That does sound like a possibility..

Sent from my Nexus 5 using Tapatalk
Dodger60 is offline  
post #11 of 21 Old 06-19-2017, 04:54 PM
Jeep_Couple
Registered User
2017 JK Wrangler 
 
Join Date: Jun 2017
Location: Charleston
Posts: 5
Garage
I wouldnt worry to much about the AC but my opinon on the ac is you might have a clogged line and that is why he is saying it is charged becuase the line is clogged. I had this issue with one of my cars before and I just replaced all the hoses. That might work. I was having an issue with my clutch in my jeep and started smelling what seemed like something burnt and I thought it was the clutch but it was the car next to me. I have to remember to shift at 3000 rmps or I smell that.
Jeep_Couple is offline  
post #12 of 21 Old 06-19-2017, 05:00 PM
Raist11
Registered User
2000 TJ Wrangler 
 
Join Date: Oct 2014
Posts: 364
Does it smell? What does it smell like? What was wrong with the switch they replaced? Was it burned/melted? White smoke coming from dash is not a good thing.

Current: '00 TJ Sport
Past: '98 TJ Sport - lots of aftermarket
Raist11 is offline  
post #13 of 21 Old 06-19-2017, 05:42 PM
Jerry Bransford
Administrator
 
Jerry Bransford's Avatar
2004 TJ Wrangler 
 
Join Date: Jan 2003
Location: Escondido, California
Posts: 69,055
Is the carpeting damp under the passenger-side footwell? Maybe your heater core has sprung a leak, they do that.

When you have a choice, buy American made.
Jerry Bransford is online now  
post #14 of 21 Old 06-19-2017, 07:44 PM Thread Starter
Cjs89YJ
Registered User
1989 YJ Wrangler 
 
Join Date: Oct 2014
Location: Ottawa
Posts: 66
Quote:
Originally Posted by Dodger60 View Post
That does sound like a possibility..

Sent from my Nexus 5 using Tapatalk
Right now theres too many possibilities, I wish it was just steam

Quote:
Originally Posted by Jeep_Couple View Post
I wouldnt worry to much about the AC but my opinon on the ac is you might have a clogged line and that is why he is saying it is charged becuase the line is clogged. I had this issue with one of my cars before and I just replaced all the hoses. That might work. I was having an issue with my clutch in my jeep and started smelling what seemed like something burnt and I thought it was the clutch but it was the car next to me. I have to remember to shift at 3000 rmps or I smell that.
I agree the AC is not a huge worry of mine, but when I get home in September I will have some time to try replacing hoses and such. As for the clutch I agree, one rough day on a hill would not show effects this long. Nor did it smell like clutch that day or this.


Quote:
Originally Posted by Raist11 View Post
Does it smell? What does it smell like? What was wrong with the switch they replaced? Was it burned/melted? White smoke coming from dash is not a good thing.
Thats the thing, I didnt really get a burning smell just the smoke. And by smoke I dont want to exagerate it, its not a huge amount of smoke but still enough to be noticeable. Again I will try pick out anything I smell on my way tomorrow. As for the old switch, I was told it was burnt out and once it was replaced the reverse lights started working. And I agree the sooner I find out what this smoke is and stop it the better.

Quote:
Originally Posted by Jerry Bransford View Post
Is the carpeting damp under the passenger-side footwell? Maybe your heater core has sprung a leak, they do that.
I checked the passenger footwell, because my inital search led me to a thread about heater core / ac evap issues. This however does not seem to be the case the carpet is not damp nor does the foot well show any signs of water when I lifted it up.

My plan tomorrow is to take it to a mechanic before work because sadly until September when I go home the apartment lifestyle means the jeep stays parked 3 floors underground and I cant do any work on it while its there.

89 YJ 4.2 5speed - 1" Spacers / 31" MT
93 YJ 4.0 Auto
03 TJ 4.0 5speed - 2.5" lift/ 31" AT
Cjs89YJ is offline  
post #15 of 21 Old 06-20-2017, 05:51 AM Thread Starter
Cjs89YJ
Registered User
1989 YJ Wrangler 
 
Join Date: Oct 2014
Location: Ottawa
Posts: 66
OK took it to the mechanic just now. Today is a rainy humid day. Purposely reversed like 5 times to try and replicate the problem. Also had the knob set to recirculate. AND nothing!!!! Mechanic was no help because he said unless the problems visible he cant really diagnose which I agree completely. So here I am back to chasing a ghost....

89 YJ 4.2 5speed - 1" Spacers / 31" MT
93 YJ 4.0 Auto
03 TJ 4.0 5speed - 2.5" lift/ 31" AT
Cjs89YJ is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome