What did you do to your TJ today? - Page 6135 - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Wrangler Forums > TJ Wrangler Technical Forum > What did you do to your TJ today?

FS: Jeep Fog Light LED Bulbs! Several Brightness Options! Clayton Off Road JK Short Arm Suspension Kits~Artec JK 1 TON SWAP~

Reply
Unread 01-04-2014, 09:34 PM   #92011
lockedwheels
Registered User
1999 TJ Wrangler 
 
Join Date: Aug 2011
Location: Las Vegas, NV
Posts: 627
Had a blast today on the trail.. I ended up getting two cracks in my fuel cell, broke my center cap on my rear passenger rim, and sheared a bolt on my control arm which was fixed with a torx wrench and duct tap. My wife however is officially a bada$$ bought her JKUR last night at 6pm, we hit the trails at 1030am. She wheeled the snot out of it. She walked away with nothing but skid plate scrapes. I don't have any pics of the obstacles at this moment, I will share those later.






lockedwheels is offline   Reply With Quote
Unread 01-04-2014, 09:37 PM   #92012
lockedwheels
Registered User
1999 TJ Wrangler 
 
Join Date: Aug 2011
Location: Las Vegas, NV
Posts: 627
Ohh and I just got done pulling the fuel cell... It is heading off to a friend of a friend to get welded up tommorow morning... Wish my mig was setup for it.
lockedwheels is offline   Reply With Quote
Unread 01-04-2014, 10:09 PM   #92013
jtstj
Registered User
2006 TJ Wrangler 
 
Join Date: Jun 2004
Location: Beautiful Colorado Springs, Colorado, Colorado
Posts: 134
Installed a new battery and brand new cables. This after having purchased it from a used car dealer just days ago! ARG!!!
jtstj is offline   Reply With Quote
Unread 01-04-2014, 10:51 PM   #92014
glake
Registered User
2005 LJ Wrangler 
 
Join Date: Feb 2012
Location: Escondido, CA
Posts: 7
Hooked up my lights for flat towing and took off the ugly plastic bumper ends.
glake is offline   Reply With Quote
Unread 01-05-2014, 02:32 AM   #92015
686keydragon
Registered User
2002 TJ Wrangler 
 
Join Date: Jun 2012
Posts: 297
Replaced my broken transmission mount with one of these:
image-1554627007.jpg

Spun a nursert out when reinstalling the skid... Replaced it with one I had sitting around that I got from black magic brakes a while back.

Repainted the frame rail after grinding some rust off. While I waited for the paint to dry I took a look around...

Found out my d30 pinion seal is leaking... I have had vibes at ~50mph since I lifted the jeep and I have long since guessed that it was my pinion angle. I too the leaking seal as an indicator that I was probably right and removed my front driveshaft. Turns out it was, but I think it is my pinion angle causing it and not the ds being out of balance.

While removing the driveshaft I noticed that one of my front stock upper control arms is bent...

Re-greased my suspension and steering...

Found out one of my Johnny joints in my rear uppers had spit part of the urethane bushing out the side... Emailed Gerald at Savvy about the issue and about getting some adjustable front uppers to replace the bent one and fix the pinion angle. I sent the email at 1130pm central time and he got back to me in under 2 hours. He explained that that issue is normally caused by over greasing and said he'd toss one in my order for the front uppers. I can't say enough good things about Gerald and Savvy. Buy from them whenever possible people.


I also found out that the boot on my drag link tie rod end has a pin hole in it...

Ugh...

Made a shopping list for tomorrow...
686keydragon is offline   Reply With Quote
Unread 01-05-2014, 07:39 AM   #92016
Rican142
Registered User
1997 TJ Wrangler 
 
Join Date: Mar 2012
Location: Vineland, New Jersey
Posts: 1,193
Quote:
Originally Posted by lockedwheels
Had a blast today on the trail.. I ended up getting two cracks in my fuel cell, broke my center cap on my rear passenger rim, and sheared a bolt on my control arm which was fixed with a torx wrench and duct tap. My wife however is officially a bada$$ bought her JKUR last night at 6pm, we hit the trails at 1030am. She wheeled the snot out of it. She walked away with nothing but skid plate scrapes. I don't have any pics of the obstacles at this moment, I will share those later.
whats that sticker on the roll bar say?
__________________
64 Ford F-100
89 Jeep Comanche
97 Jeep Wrangler
Rican142 is offline   Reply With Quote
Unread 01-05-2014, 08:07 AM   #92017
lockedwheels
Registered User
1999 TJ Wrangler 
 
Join Date: Aug 2011
Location: Las Vegas, NV
Posts: 627
Quote:
Originally Posted by Rican142 View Post
whats that sticker on the roll bar say?
Not lost... Geographically misplaced
lockedwheels is offline   Reply With Quote
Unread 01-05-2014, 08:32 AM   #92018
357transam
There's a better way....
 
357transam's Avatar
1998 TJ Wrangler 
 
Join Date: Sep 2009
Location: Broken Arrow
Posts: 438
Quote:
Originally Posted by DezertTJ View Post
Told it it's getting a younger brother today as I fly off to pueblo, co for the LJ. Can't wait to bring it home!!!
I grew up there.....
357transam is offline   Reply With Quote
Unread 01-05-2014, 08:33 AM   #92019
rikkards
Web Wheeler
 
rikkards's Avatar
1998 TJ Wrangler 
 
Join Date: Jun 2008
Location: Ottawa, Ontario
Posts: 3,172
Quote:
Originally Posted by 686keydragon View Post
Replaced my broken transmission mount with one of these:
Attachment 970794

Spun a nursert out when reinstalling the skid... Replaced it with one I had sitting around that I got from black magic brakes a while back.

Repainted the frame rail after grinding some rust off. While I waited for the paint to dry I took a look around...

Found out my d30 pinion seal is leaking... I have had vibes at ~50mph since I lifted the jeep and I have long since guessed that it was my pinion angle. I too the leaking seal as an indicator that I was probably right and removed my front driveshaft. Turns out it was, but I think it is my pinion angle causing it and not the ds being out of balance.

While removing the driveshaft I noticed that one of my front stock upper control arms is bent...

Re-greased my suspension and steering...

Found out one of my Johnny joints in my rear uppers had spit part of the urethane bushing out the side... Emailed Gerald at Savvy about the issue and about getting some adjustable front uppers to replace the bent one and fix the pinion angle. I sent the email at 1130pm central time and he got back to me in under 2 hours. He explained that that issue is normally caused by over greasing and said he'd toss one in my order for the front uppers. I can't say enough good things about Gerald and Savvy. Buy from them whenever possible people.


I also found out that the boot on my drag link tie rod end has a pin hole in it...

Ugh...

Made a shopping list for tomorrow...
You running poly motor mounts as well? I have heard (not experienced) that mixing rubber and poly is not ideal.
__________________
Machete don't tweet
- Machete
rikkards is offline   Reply With Quote
Unread 01-05-2014, 08:55 AM   #92020
lockedwheels
Registered User
1999 TJ Wrangler 
 
Join Date: Aug 2011
Location: Las Vegas, NV
Posts: 627
Some video of yesterday. The wife's stock JKUR made the video.

Here I am parked on an angle to relieve some stress on the cracked fuel cell and you can see the JKUR up on the side of the hill.


East coast wheeling doesn't even compare. Good riddance South Carolina.
lockedwheels is offline   Reply With Quote
Unread 01-05-2014, 10:42 AM   #92021
bbradUSMC
Registered User
2004 TJ Wrangler 
 
Join Date: May 2010
Location: Corpus Christi, Texas
Posts: 1,379
Quote:
Originally Posted by 686keydragon View Post
Replaced my broken transmission mount with one of these:
Attachment 970794

Spun a nursert out when reinstalling the skid... Replaced it with one I had sitting around that I got from black magic brakes a while back.

Repainted the frame rail after grinding some rust off. While I waited for the paint to dry I took a look around...

Found out my d30 pinion seal is leaking... I have had vibes at ~50mph since I lifted the jeep and I have long since guessed that it was my pinion angle. I too the leaking seal as an indicator that I was probably right and removed my front driveshaft. Turns out it was, but I think it is my pinion angle causing it and not the ds being out of balance.

While removing the driveshaft I noticed that one of my front stock upper control arms is bent...

Re-greased my suspension and steering...

Found out one of my Johnny joints in my rear uppers had spit part of the urethane bushing out the side... Emailed Gerald at Savvy about the issue and about getting some adjustable front uppers to replace the bent one and fix the pinion angle. I sent the email at 1130pm central time and he got back to me in under 2 hours. He explained that that issue is normally caused by over greasing and said he'd toss one in my order for the front uppers. I can't say enough good things about Gerald and Savvy. Buy from them whenever possible people.


I also found out that the boot on my drag link tie rod end has a pin hole in it...

Ugh...

Made a shopping list for tomorrow...
Do you get more vibes with poly mount

Live Free,
Brad
bbradUSMC is offline   Reply With Quote
Unread 01-05-2014, 11:10 AM   #92022
686keydragon
Registered User
2002 TJ Wrangler 
 
Join Date: Jun 2012
Posts: 297
Quote:
Originally Posted by rikkards
You running poly motor mounts as well? I have heard (not experienced) that mixing rubber and poly is not ideal.
I am using the stock motor mounts. What's the reasoning behind it not being ideal?

Quote:
Originally Posted by bbradUSMC
Do you get more vibes with poly mount Live Free, Brad
I definitely have more vibes when stopped and first starting out, nothing crazy but more than with the stock mount. Once it's moving I don't notice any vibes.
686keydragon is offline   Reply With Quote
Unread 01-05-2014, 11:12 AM   #92023
jeepwrangler97
Registered User
1997 TJ Wrangler 
 
Join Date: Jul 2008
Location: FL
Posts: 3,661
Quote:
Originally Posted by 686keydragon View Post

I am using the stock motor mounts. What's the reasoning behind it not being ideal?

I definitely have more vibes when stopped and first starting out, nothing crazy but more than with the stock mount. Once it's moving I don't notice any vibes.
I think some ppl report vibes with poly motor mounts & sticking with rubber trans mount.

I don't think there're bad vibes with my poly mm & trans mount

Sent by a messenger bird
jeepwrangler97 is offline   Reply With Quote
Unread 01-05-2014, 12:33 PM   #92024
LC_Sahara
Registered User
1997 TJ Wrangler 
 
Join Date: Dec 2013
Location: Las Cruces, NM
Posts: 36
Installed a new pioneer Bluetooth receiver. Best interior mod you can do. Links up to my iPhone instantly when in range and the sound is clear!
LC_Sahara is offline   Reply With Quote
Unread 01-05-2014, 12:55 PM   #92025
joeyk803c
Registered User
2003 TJ Wrangler 
 
Join Date: Mar 2011
Location: Spring Valley, Ca
Posts: 1,369
New Bestop went on yesterday after my rampage took a crap on me. Still in safari mode due to the beautiful weather we are having here in sunny san diego.
joeyk803c is offline   Reply With Quote
Reply

Tags
modifications , tj
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.